aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-03-25 23:12:51 +0800
committertj <tj@FreeBSD.org>2016-03-25 23:12:51 +0800
commit81637fc73a56247721a0376f26119790a630bd20 (patch)
tree9212298b72f982ece96280557f2db051441bcb26 /textproc
parenteba17b7afec6440403182bce2b84682a0a0848df (diff)
downloadfreebsd-ports-gnome-81637fc73a56247721a0376f26119790a630bd20.tar.gz
freebsd-ports-gnome-81637fc73a56247721a0376f26119790a630bd20.tar.zst
freebsd-ports-gnome-81637fc73a56247721a0376f26119790a630bd20.zip
Update to 2.2.1
Changes: https://www.elastic.co/guide/en/elasticsearch/reference/2.2/release-notes-2.2.1.html PR: 206918
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch2/Makefile5
-rw-r--r--textproc/elasticsearch2/distinfo4
-rw-r--r--textproc/elasticsearch2/files/elasticsearch.in18
-rw-r--r--textproc/elasticsearch2/pkg-plist7
4 files changed, 24 insertions, 10 deletions
diff --git a/textproc/elasticsearch2/Makefile b/textproc/elasticsearch2/Makefile
index a5885a0b133c..cf7c9cbad7bc 100644
--- a/textproc/elasticsearch2/Makefile
+++ b/textproc/elasticsearch2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 2.1.1
+PORTVERSION= 2.2.1
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -26,7 +26,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-LUCENEVER= 5.3.1
+LUCENEVER= 5.4.1
CONFIG_FILES= elasticsearch.yml logging.yml
BINS= elasticsearch.in.sh \
elasticsearch \
@@ -71,6 +71,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
(cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/ "-name *\.jar")
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
@${MKDIR} ${STAGEDIR}${ELASTIC_DBDIR} ${STAGEDIR}${ELASTIC_LOGDIR}
diff --git a/textproc/elasticsearch2/distinfo b/textproc/elasticsearch2/distinfo
index 742a4007ae03..d3a4af8d4d47 100644
--- a/textproc/elasticsearch2/distinfo
+++ b/textproc/elasticsearch2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (elasticsearch-2.1.1.tar.gz) = ebd69c0483f20ba7e51caa9606d4e3ce5fe2667e1216c799f0cdbb815c317ce6
-SIZE (elasticsearch-2.1.1.tar.gz) = 29007342
+SHA256 (elasticsearch-2.2.1.tar.gz) = 7d43d18a8ee8d715d827ed26b4ff3d939628f5a5b654c6e8de9d99bf3a9b2e03
+SIZE (elasticsearch-2.2.1.tar.gz) = 29424648
diff --git a/textproc/elasticsearch2/files/elasticsearch.in b/textproc/elasticsearch2/files/elasticsearch.in
index 20975366a3ab..087e119b6bbe 100644
--- a/textproc/elasticsearch2/files/elasticsearch.in
+++ b/textproc/elasticsearch2/files/elasticsearch.in
@@ -49,6 +49,13 @@ command_args="-d --pidfile=${pidfile}"
elasticsearch_precmd()
{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -n "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} is already running: $rc_pid."
+ return 1
+ fi
touch ${pidfile}
chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
@@ -56,8 +63,17 @@ elasticsearch_precmd()
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
}
+
elasticsearch_console()
{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -n "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} is already running: $rc_pid."
+ return 1
+ fi
+
command_args=""
run_rc_command "start"
}
@@ -104,7 +120,7 @@ elasticsearch_check_pidfile()
debug "pid file ($_pidfile): no pid in file."
return
fi
- if [ -n "`%%LOCALBASE%%/bin/jps -l | grep -e "^$_pid"`" ]; then
+ if [ -n "`/usr/bin/su -m ${elasticsearch_user} -c '%%LOCALBASE%%/bin/jps -l' | grep -e "^$_pid"`" ]; then
echo -n $_pid
fi
}
diff --git a/textproc/elasticsearch2/pkg-plist b/textproc/elasticsearch2/pkg-plist
index 625d0be050aa..c0353f38ef3f 100644
--- a/textproc/elasticsearch2/pkg-plist
+++ b/textproc/elasticsearch2/pkg-plist
@@ -4,15 +4,11 @@
@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
bin/elasticsearch-plugin
lib/elasticsearch/lib/HdrHistogram-2.1.6.jar
-lib/elasticsearch/lib/antlr-runtime-3.5.jar
lib/elasticsearch/lib/apache-log4j-extras-1.2.17.jar
-lib/elasticsearch/lib/asm-4.1.jar
-lib/elasticsearch/lib/asm-commons-4.1.jar
lib/elasticsearch/lib/commons-cli-1.3.1.jar
lib/elasticsearch/lib/compiler-0.8.13.jar
lib/elasticsearch/lib/compress-lzf-1.0.2.jar
lib/elasticsearch/lib/elasticsearch-%%PORTVERSION%%.jar
-lib/elasticsearch/lib/groovy-all-2.4.4-indy.jar
lib/elasticsearch/lib/guava-18.0.jar
lib/elasticsearch/lib/hppc-0.7.1.jar
lib/elasticsearch/lib/jackson-core-2.6.2.jar
@@ -28,7 +24,6 @@ lib/elasticsearch/lib/log4j-1.2.17.jar
lib/elasticsearch/lib/lucene-analyzers-common-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-backward-codecs-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-core-%%LUCENEVER%%.jar
-lib/elasticsearch/lib/lucene-expressions-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-grouping-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-highlighter-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-join-%%LUCENEVER%%.jar
@@ -41,6 +36,7 @@ lib/elasticsearch/lib/lucene-spatial-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-spatial3d-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-suggest-%%LUCENEVER%%.jar
lib/elasticsearch/lib/netty-3.10.5.Final.jar
+lib/elasticsearch/lib/securesm-1.0.jar
lib/elasticsearch/lib/snakeyaml-1.15.jar
lib/elasticsearch/lib/spatial4j-0.5.jar
lib/elasticsearch/lib/t-digest-3.0.jar
@@ -52,6 +48,7 @@ lib/elasticsearch/bin/plugin
%%PORTDOCS%%%%DOCSDIR%%/README.textile
@dir lib/elasticsearch/lib
@dir lib/elasticsearch/bin
+@dir lib/elasticsearch/modules
@dir lib/elasticsearch/plugins
@dir lib/elasticsearch
@dir libexec/elasticsearch