aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-20 06:15:52 +0800
committerknu <knu@FreeBSD.org>2001-03-20 06:15:52 +0800
commitccd630eb444008d79b511ffcb19921c55ea0788d (patch)
treecd935e5e86efd1e01f6d3b94a9cb1e02404d9553 /textproc
parentd58abf077c8a544d23f3be86422f6ab51b3bb1a2 (diff)
downloadfreebsd-ports-gnome-ccd630eb444008d79b511ffcb19921c55ea0788d.tar.gz
freebsd-ports-gnome-ccd630eb444008d79b511ffcb19921c55ea0788d.tar.zst
freebsd-ports-gnome-ccd630eb444008d79b511ffcb19921c55ea0788d.zip
Use the threaded version of Qt2 library for 5-CURRENT.
Mark ruby-qt2gl broken for 4-STABLE due to the thread library problem.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-qt2xml/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/textproc/ruby-qt2xml/Makefile b/textproc/ruby-qt2xml/Makefile
index a76afd1fcac9..ad952c2a00b1 100644
--- a/textproc/ruby-qt2xml/Makefile
+++ b/textproc/ruby-qt2xml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qt2xml
PORTVERSION= ${RUBY_QT2_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= textproc x11-toolkits ruby
MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -23,13 +24,11 @@ USE_RUBY_EXTCONF= yes
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../x11-toolkits/ruby-qt2/Makefile.common"
WRKSRC= ${RUBY_QT2_WRKSRC}/modules/xml
-CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
- --with-qt2-lib=${X11BASE}/lib \
- --with-qt2=qt2 \
- --with-x11-dir=${X11BASE}
+CONFIGURE_ARGS= ${RUBY_QT2_CONFIGURE_ARGS}
MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
@@ -39,4 +38,4 @@ post-install:
${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>