aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-03 00:00:36 +0800
committerpav <pav@FreeBSD.org>2004-01-03 00:00:36 +0800
commite5d8c997cc12b31b5ec2d5700b1b1968337f1984 (patch)
tree01370cec74a890f9e26c6f69c06fa42bbd06f172 /textproc
parent94538eee131f6bde55493146b745f32a5ece3441 (diff)
downloadfreebsd-ports-gnome-e5d8c997cc12b31b5ec2d5700b1b1968337f1984.tar.gz
freebsd-ports-gnome-e5d8c997cc12b31b5ec2d5700b1b1968337f1984.tar.zst
freebsd-ports-gnome-e5d8c997cc12b31b5ec2d5700b1b1968337f1984.zip
Add words, a free Latin-English dictionary program which contains over
30000 entries and, through additional word construction with hundreds of prefixes and suffixes, may generate more, leading to many hundreds of thousands of 'words' that can be formed by declension and conjugation. This is also our first port written in ADA. PR: ports/60822 Submitted by: Leland Wang <llwang@infor.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/words/Makefile60
-rw-r--r--textproc/words/distinfo1
-rw-r--r--textproc/words/files/words3
-rw-r--r--textproc/words/pkg-descr15
-rw-r--r--textproc/words/pkg-plist11
6 files changed, 91 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 873411ebacca..1d0c361a0038 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -502,6 +502,7 @@
SUBDIR += whitespace.el
SUBDIR += word2x
SUBDIR += wordnet
+ SUBDIR += words
SUBDIR += wv
SUBDIR += wv2
SUBDIR += xalan-c
diff --git a/textproc/words/Makefile b/textproc/words/Makefile
new file mode 100644
index 000000000000..024379092ea7
--- /dev/null
+++ b/textproc/words/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: words
+# Date created: 2 January 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= words
+PORTVERSION= 1.97
+CATEGORIES= textproc
+MASTER_SITES= http://users.erols.com/whitaker/
+DISTNAME= ${PORTNAME}all
+EXTRACT_SUFX= .zip
+
+MAINTAINER= llwang@infor.org
+COMMENT= A Latin-English Dictionary Program
+
+BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
+.if defined(PACKAGE_BUILDING)
+STATIC= yes
+.endif
+.if defined(STATIC)
+GNATLINK_ARGS= -largs -static
+.else
+LIB_DEPENDS= gnat-3.15.1:${PORTSDIR}/lang/gnat
+.endif
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+
+GNATMAKE= gnatmake
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${GNATMAKE} -O3 words ${GNATLINK_ARGS} && \
+ ${GNATMAKE} makedict && \
+ ${GNATMAKE} makestem && \
+ ${GNATMAKE} makeinfl && \
+ ${ECHO_CMD} G | ./makedict DICTLINE.GEN && \
+ ${ECHO_CMD} G | ./makestem STEMLIST.GEN && \
+ ./makeinfl INFLECTS.LAT
+ @${CAT} ${FILESDIR}/words | ${SED} -e 's|%%DATADIR%%|${DATADIR}|' > ${WRKDIR}/words.sh
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/words ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/DICTFILE.GEN ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/STEMFILE.GEN ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/INDXFILE.GEN ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/INFLECTS.SEC ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ADDONS.LAT ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/UNIQUES.LAT ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/words.sh ${PREFIX}/bin/words
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/WORDSDOC.HTM ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/words/distinfo b/textproc/words/distinfo
new file mode 100644
index 000000000000..cc07c140f138
--- /dev/null
+++ b/textproc/words/distinfo
@@ -0,0 +1 @@
+MD5 (wordsall.zip) = 9664d88aedd747ffb547dcc1682fbaa9
diff --git a/textproc/words/files/words b/textproc/words/files/words
new file mode 100644
index 000000000000..8a190201b570
--- /dev/null
+++ b/textproc/words/files/words
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && ./words $@
diff --git a/textproc/words/pkg-descr b/textproc/words/pkg-descr
new file mode 100644
index 000000000000..3f9824ad78b7
--- /dev/null
+++ b/textproc/words/pkg-descr
@@ -0,0 +1,15 @@
+WORDS is a free Latin-English dictionary program which takes keyboard
+input or a file of Latin text lines and provides an analysis/morphology
+(declension, conjugation, case, tense, etc.) of each word individually,
+the dictionary form, and the translation (meaning).
+
+The dictionary contains over 30000 entries and, through additional word
+construction with hundreds of prefixes and suffixes, may generate more,
+leading to many hundreds of thousands of 'words' that can be formed by
+declension and conjugation. Present emphisis is on classical Latin and
+late Latin, but medieval Latin entries are increasing. WORDS provides a
+tool to help in translations for the Latin student and a memory jog for
+researchers.
+
+Author: William Whitaker <whitaker@erols.com>
+WWW: http://users.erols.com/whitaker/words.htm
diff --git a/textproc/words/pkg-plist b/textproc/words/pkg-plist
new file mode 100644
index 000000000000..ca1d9f1c1d0f
--- /dev/null
+++ b/textproc/words/pkg-plist
@@ -0,0 +1,11 @@
+%%DATADIR%%/words
+%%DATADIR%%/DICTFILE.GEN
+%%DATADIR%%/STEMFILE.GEN
+%%DATADIR%%/INDXFILE.GEN
+%%DATADIR%%/INFLECTS.SEC
+%%DATADIR%%/ADDONS.LAT
+%%DATADIR%%/UNIQUES.LAT
+@dirrm %%DATADIR%%
+bin/words
+%%PORTDOCS%%%%DOCSDIR%%/WORDSDOC.HTM
+%%PORTDOCS%%@dirrm %%DOCSDIR%%