aboutsummaryrefslogtreecommitdiffstats
path: root/www/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-02-02 20:42:48 +0800
committeredwin <edwin@FreeBSD.org>2005-02-02 20:42:48 +0800
commitfe87e401dd226adef2d72aa6b863e8bc9214fb70 (patch)
tree227560d6882e5cbca7e4d48c2892c978687b3ab6 /www/Makefile
parent0a37e0753d8f8c65e2e3c675de9d25f854e58081 (diff)
downloadfreebsd-ports-gnome-fe87e401dd226adef2d72aa6b863e8bc9214fb70.tar.gz
freebsd-ports-gnome-fe87e401dd226adef2d72aa6b863e8bc9214fb70.tar.zst
freebsd-ports-gnome-fe87e401dd226adef2d72aa6b863e8bc9214fb70.zip
NEW PORT: www/pear-HTTP_Client (High level HTTP class)
This is my first port with code from PEAR, so I hope I got it right. I based it off of www/pear-HTTP. The HTTP_Client class wraps around HTTP_Request and provides a higher level interface for performing multiple HTTP requests. Features: * Manages cookies and referrers between requests * Handles HTTP redirection * Has methods to set default headers and request parameters * Implements the Subject-Observer design pattern: the base class sends events to listeners that do the response processing. PR: ports/76995 Submitted by: Joseph Scott <joseph@randomnetworks.com>
Diffstat (limited to 'www/Makefile')
-rw-r--r--www/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 766048e6b8af..15703718e90e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -570,6 +570,7 @@
SUBDIR += peacock
SUBDIR += pear-APC
SUBDIR += pear-HTTP
+ SUBDIR += pear-HTTP_Client
SUBDIR += pear-HTTP_Download
SUBDIR += pear-HTTP_Header
SUBDIR += pear-HTTP_Request