aboutsummaryrefslogtreecommitdiffstats
path: root/www/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-11-16 22:15:15 +0800
committerclsung <clsung@FreeBSD.org>2011-11-16 22:15:15 +0800
commit5dd11172aa98cc8fd580ac4fbf127d01289a9aa3 (patch)
tree29e6569fef0b037cd70cabf7612eb8be247e5428 /www/Makefile
parent9cb04cc024dbf6ba478c72b7eacf0d5a4089c94a (diff)
downloadfreebsd-ports-gnome-5dd11172aa98cc8fd580ac4fbf127d01289a9aa3.tar.gz
freebsd-ports-gnome-5dd11172aa98cc8fd580ac4fbf127d01289a9aa3.tar.zst
freebsd-ports-gnome-5dd11172aa98cc8fd580ac4fbf127d01289a9aa3.zip
This is a django application that tries to eliminate annoying
things in the Django framework. Features: render_to decorator - reduce typing in django views. signals decorator - allow use signals as decorators. ajax_request decorator - returns JsonResponse with this dict as content. autostrip decorator - strip text form fields before validation. get_object_or_None function - similar to get_object_or_404, but returns None if object not found. get_config function - get settings from django.conf if exists, return default value otherwise. AutoOneToOne field - creates related object on first call if it doesn't exist yet. HttpResponseReload - reload and stay on same page from where request was made. StaticServer middleware - instead of configuring urls.py, just add this middleware and it will serve you static files. JSONField - custom field that lets you easily store JSON data in one of your model fields. WWW: https://bitbucket.org/offline/django-annoying/wiki/Home Feature safe: yes
Diffstat (limited to 'www/Makefile')
-rw-r--r--www/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3c918bde026e..e3b35ae28bdc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1471,6 +1471,7 @@
SUBDIR += py-clientform
SUBDIR += py-cssutils
SUBDIR += py-django
+ SUBDIR += py-django-annoying
SUBDIR += py-django-app-plugins
SUBDIR += py-django-appmedia
SUBDIR += py-django-classy-tags