aboutsummaryrefslogtreecommitdiffstats
path: root/www/ach
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-11-05 05:08:20 +0800
committerglarkin <glarkin@FreeBSD.org>2010-11-05 05:08:20 +0800
commitc57ce516ed823e4110027637bf07871db1e67c23 (patch)
treee5999e646dc9c208ead9642f83061c5dc3918825 /www/ach
parent501345c2fbff4bd2b2637a3668743436c3d9c5e0 (diff)
downloadfreebsd-ports-gnome-c57ce516ed823e4110027637bf07871db1e67c23.tar.gz
freebsd-ports-gnome-c57ce516ed823e4110027637bf07871db1e67c23.tar.zst
freebsd-ports-gnome-c57ce516ed823e4110027637bf07871db1e67c23.zip
A software companion to a 30+ year-old CIA research methodology,
Open Source Analysis of Competing Hypotheses (ACH) will help you think objectively and logically about overwhelming amounts of data and hypotheses. It can also guide research teams toward more productive discussions by identifying the exact points of contention. WWW: http://www.competinghypotheses.org/ PR: ports/151225 Submitted by: Carlo Strub <c-s at c-s.li>
Diffstat (limited to 'www/ach')
-rw-r--r--www/ach/Makefile49
-rw-r--r--www/ach/distinfo3
-rw-r--r--www/ach/files/pkg-message.in41
-rw-r--r--www/ach/pkg-descr7
-rw-r--r--www/ach/pkg-plist266
5 files changed, 366 insertions, 0 deletions
diff --git a/www/ach/Makefile b/www/ach/Makefile
new file mode 100644
index 000000000000..401631928dba
--- /dev/null
+++ b/www/ach/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ACH
+# Date Created: 2010-10-05
+# Whom: Carlo Strub <c-s@c-s.li>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ACH
+PORTVERSION= 1.0.2
+CATEGORIES= www
+MASTER_SITES= http://cloud.github.com/downloads/Burton/Analysis-of-Competing-Hypotheses/
+EXTRACT_SUFX= -alpha.tar
+
+MAINTAINER= c-s@c-s.li
+COMMENT= A free, open source tool for complex research problems
+
+LICENSE= GPLv3
+
+USE_MYSQL= yes
+USE_PHP= yes
+IGNORE_WITH_PHP= 4
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
+NO_BUILD= yes
+SUB_FILES+= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+
+# Get rid of temp files packaged in the upstream distfile
+post-extract:
+ @${FIND} ${WRKSRC} -type f -not -name .htaccess -a \
+ -name .\* -delete
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${WWWDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/ach/distinfo b/www/ach/distinfo
new file mode 100644
index 000000000000..05b5829957ae
--- /dev/null
+++ b/www/ach/distinfo
@@ -0,0 +1,3 @@
+MD5 (ACH-1.0.2-alpha.tar) = 404f620dffddf6b0aabfb4f497f7885a
+SHA256 (ACH-1.0.2-alpha.tar) = 9d4be8bf8edc56be210230b69d04703501a186923f9b85112e8eab30bd78f48b
+SIZE (ACH-1.0.2-alpha.tar) = 2180096
diff --git a/www/ach/files/pkg-message.in b/www/ach/files/pkg-message.in
new file mode 100644
index 000000000000..e62fa5b50deb
--- /dev/null
+++ b/www/ach/files/pkg-message.in
@@ -0,0 +1,41 @@
+You now need to create the DB where ACH is going to live.
+
+MySQL:
+ mysqladmin -u dba_user -p create ach
+ mysql -u dba_user -p
+ GRANT ALL PRIVILEGES ON ach.* TO ach@localhost IDENTIFIED BY 'passwd';
+ mysql -u ach -p passwd ach < %%WWWDIR%%/db.sql
+
+In %%WWWDIR%%/code/common_db.php, add your database connection
+details:
+
+ $dbhost = '127.0.0.1';
+ $dbusername = 'ach';
+ $dbuserpassword = 'passwd';
+ $default_dbname = 'ach';
+
+At the top of %%WWWDIR%%/parts/includes.php, edit the following
+lines to reflect your environment, replacing SITEURL with your own domain
+and application URL. Do not include a trailing slash (eg. domain.com
+instead of domain.com/) in the PHP base_URL variable.
+
+ <base href="http://SITEURL/">
+ <?php $base_URL="http://SITEURL";
+ $email_domain="SITEURL"?>
+
+You also need to add appropriate configuration directives to your webserver.
+A typical configuration might read:
+
+ Alias /ach "%%WWWDIR%%"
+ <Directory "%%WWWDIR%%">
+ Options Indexes FollowSymlinks
+ AllowOverride All
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+Finally, change the RewriteBase URL in %%WWWDIR%%/.htaccess so it
+matches the URL in the Alias directive above, e.g.:
+
+ RewriteBase /ach
+
diff --git a/www/ach/pkg-descr b/www/ach/pkg-descr
new file mode 100644
index 000000000000..bf8516a0f259
--- /dev/null
+++ b/www/ach/pkg-descr
@@ -0,0 +1,7 @@
+A software companion to a 30+ year-old CIA research methodology,
+Open Source Analysis of Competing Hypotheses (ACH) will help you
+think objectively and logically about overwhelming amounts of data
+and hypotheses. It can also guide research teams toward more
+productive discussions by identifying the exact points of contention.
+
+WWW: http://www.competinghypotheses.org/
diff --git a/www/ach/pkg-plist b/www/ach/pkg-plist
new file mode 100644
index 000000000000..508ca755117b
--- /dev/null
+++ b/www/ach/pkg-plist
@@ -0,0 +1,266 @@
+%%WWWDIR%%/COPYING
+%%WWWDIR%%/README
+%%WWWDIR%%/.htaccess
+%%WWWDIR%%/action.php
+%%WWWDIR%%/add_comment_action.php
+%%WWWDIR%%/add_project.php
+%%WWWDIR%%/add_project_action.php
+%%WWWDIR%%/ajax/zxml.js
+%%WWWDIR%%/auth/check_log_in.php
+%%WWWDIR%%/auth/forgot.php
+%%WWWDIR%%/auth/log_out.php
+%%WWWDIR%%/class_action.php
+%%WWWDIR%%/code/class_comment.php
+%%WWWDIR%%/code/class_credibility.php
+%%WWWDIR%%/code/class_evidence.php
+%%WWWDIR%%/code/class_hypothesis.php
+%%WWWDIR%%/code/class_project.php
+%%WWWDIR%%/code/class_user.php
+%%WWWDIR%%/code/common_db.php
+%%WWWDIR%%/code/frameworks/framework_database.php
+%%WWWDIR%%/code/functions.php
+%%WWWDIR%%/code/includes.php
+%%WWWDIR%%/code/nusoap/lib/changelog
+%%WWWDIR%%/code/nusoap/lib/class.nusoap_base.php
+%%WWWDIR%%/code/nusoap/lib/class.soap_fault.php
+%%WWWDIR%%/code/nusoap/lib/class.soap_parser.php
+%%WWWDIR%%/code/nusoap/lib/class.soap_server.php
+%%WWWDIR%%/code/nusoap/lib/class.soap_transport_http.php
+%%WWWDIR%%/code/nusoap/lib/class.soap_val.php
+%%WWWDIR%%/code/nusoap/lib/class.soapclient.php
+%%WWWDIR%%/code/nusoap/lib/class.wsdl.php
+%%WWWDIR%%/code/nusoap/lib/class.wsdlcache.php
+%%WWWDIR%%/code/nusoap/lib/class.xmlschema.php
+%%WWWDIR%%/code/nusoap/lib/nusoap.php
+%%WWWDIR%%/code/nusoap/lib/nusoapmime.php
+%%WWWDIR%%/code/nusoap/samples/client1.php
+%%WWWDIR%%/code/nusoap/samples/client2.php
+%%WWWDIR%%/code/nusoap/samples/client3.php
+%%WWWDIR%%/code/nusoap/samples/getfile1client.php
+%%WWWDIR%%/code/nusoap/samples/getfile2client.php
+%%WWWDIR%%/code/nusoap/samples/index.html
+%%WWWDIR%%/code/nusoap/samples/mimeclient.php
+%%WWWDIR%%/code/nusoap/samples/sslclient.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient1.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient10.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient11.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient12.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient13.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient14.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient2.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient3.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient3b.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient3c.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient4.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient5.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient6.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient7.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient8.php
+%%WWWDIR%%/code/nusoap/samples/wsdlclient9.php
+%%WWWDIR%%/css/chat.css
+%%WWWDIR%%/css/chat_ie.css
+%%WWWDIR%%/css/chat_old.css
+%%WWWDIR%%/css/large.css
+%%WWWDIR%%/css/medium.css
+%%WWWDIR%%/css/sortabletable.css
+%%WWWDIR%%/css/style.css
+%%WWWDIR%%/css/ydsf.css
+%%WWWDIR%%/db.sql
+%%WWWDIR%%/delete_evidence.php
+%%WWWDIR%%/delete_hypothesis.php
+%%WWWDIR%%/dupe_personal_matrix.php
+%%WWWDIR%%/edit_profile.php
+%%WWWDIR%%/edit_profile_action.php
+%%WWWDIR%%/edit_project_action.php
+%%WWWDIR%%/evidence_by_serial.php
+%%WWWDIR%%/help/about.php
+%%WWWDIR%%/help/ach.php
+%%WWWDIR%%/help/ach_2.php
+%%WWWDIR%%/help/collaboration_steps.php
+%%WWWDIR%%/help/evidence.php
+%%WWWDIR%%/help/howto_collaborate.php
+%%WWWDIR%%/help/howto_evidence.php
+%%WWWDIR%%/help/howto_hypotheses.php
+%%WWWDIR%%/help/howto_matrices.php
+%%WWWDIR%%/help/howto_project_management.php
+%%WWWDIR%%/help/hypotheses.php
+%%WWWDIR%%/help/images/samplematrix.png
+%%WWWDIR%%/help/index.php
+%%WWWDIR%%/help/rate_consistency.php
+%%WWWDIR%%/images/ach-header-web.png
+%%WWWDIR%%/images/banner.gif
+%%WWWDIR%%/images/bg.jpg
+%%WWWDIR%%/images/chat_shadow.png
+%%WWWDIR%%/images/chat_tab.png
+%%WWWDIR%%/images/clear.png
+%%WWWDIR%%/images/consensusgauge.gif
+%%WWWDIR%%/images/container_bg.jpg
+%%WWWDIR%%/images/gauge.gif
+%%WWWDIR%%/images/header.jpg
+%%WWWDIR%%/images/icons/accept.png
+%%WWWDIR%%/images/icons/add.png
+%%WWWDIR%%/images/icons/calendar.png
+%%WWWDIR%%/images/icons/cancel.png
+%%WWWDIR%%/images/icons/flag_red.png
+%%WWWDIR%%/images/icons/house.png
+%%WWWDIR%%/images/icons/page_add.png
+%%WWWDIR%%/images/icons/page_copy.png
+%%WWWDIR%%/images/icons/printer.png
+%%WWWDIR%%/images/icons/user_red.png
+%%WWWDIR%%/images/icons/xhtml.png
+%%WWWDIR%%/images/icons/zoom.png
+%%WWWDIR%%/images/icons/zoom_in.png
+%%WWWDIR%%/images/icons/zoom_out.png
+%%WWWDIR%%/images/monkey.jpg
+%%WWWDIR%%/images/no_photo.gif
+%%WWWDIR%%/images/shadow-grid.gif
+%%WWWDIR%%/images/shadow.png
+%%WWWDIR%%/images/sort_down.gif
+%%WWWDIR%%/images/sort_down_1_dark.gif
+%%WWWDIR%%/images/sort_down_1_pale.gif
+%%WWWDIR%%/images/sort_down_2_dark.gif
+%%WWWDIR%%/images/sort_down_2_pale.gif
+%%WWWDIR%%/images/sort_down_3_dark.gif
+%%WWWDIR%%/images/sort_down_3_pale.gif
+%%WWWDIR%%/images/sort_up.gif
+%%WWWDIR%%/images/sort_up_1_dark.gif
+%%WWWDIR%%/images/sort_up_1_pale.gif
+%%WWWDIR%%/images/sort_up_2_dark.gif
+%%WWWDIR%%/images/sort_up_2_pale.gif
+%%WWWDIR%%/images/sort_up_3_dark.gif
+%%WWWDIR%%/images/sort_up_3_pale.gif
+%%WWWDIR%%/import.php
+%%WWWDIR%%/import_action.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/insert_message.php
+%%WWWDIR%%/intro.php
+%%WWWDIR%%/join_request_action.php
+%%WWWDIR%%/js/chat.js
+%%WWWDIR%%/js/cookies.js
+%%WWWDIR%%/js/lib/prototype.js
+%%WWWDIR%%/js/misc.js
+%%WWWDIR%%/js/overlib/Mini/overlib_anchor_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_centerpopup_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_crossframe_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_csstyle_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_debug_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_exclusive_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_followscroll_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_hideform_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_setonoff_mini.js
+%%WWWDIR%%/js/overlib/Mini/overlib_shadow_mini.js
+%%WWWDIR%%/js/overlib/makemini.pl
+%%WWWDIR%%/js/overlib/overlib.js
+%%WWWDIR%%/js/overlib/overlib_anchor.js
+%%WWWDIR%%/js/overlib/overlib_centerpopup.js
+%%WWWDIR%%/js/overlib/overlib_crossframe.js
+%%WWWDIR%%/js/overlib/overlib_cssstyle.js
+%%WWWDIR%%/js/overlib/overlib_debug.js
+%%WWWDIR%%/js/overlib/overlib_exclusive.js
+%%WWWDIR%%/js/overlib/overlib_followscroll.js
+%%WWWDIR%%/js/overlib/overlib_hideform.js
+%%WWWDIR%%/js/overlib/overlib_setonoff.js
+%%WWWDIR%%/js/overlib/overlib_shadow.js
+%%WWWDIR%%/js/sortabletable.js
+%%WWWDIR%%/js/src/builder.js
+%%WWWDIR%%/js/src/controls.js
+%%WWWDIR%%/js/src/dragdrop.js
+%%WWWDIR%%/js/src/effects.js
+%%WWWDIR%%/js/src/scriptaculous.js
+%%WWWDIR%%/js/src/slider.js
+%%WWWDIR%%/js/src/unittest.js
+%%WWWDIR%%/js/styleswitcher.js
+%%WWWDIR%%/js/table_resize.js
+%%WWWDIR%%/js/tablekit.js
+%%WWWDIR%%/js/zxml.js
+%%WWWDIR%%/make_new_account.php
+%%WWWDIR%%/new_account.php
+%%WWWDIR%%/parts/ajax_table.php
+%%WWWDIR%%/parts/chat_panel.php
+%%WWWDIR%%/parts/footer.php
+%%WWWDIR%%/parts/header.php
+%%WWWDIR%%/parts/includes.php
+%%WWWDIR%%/parts/login_sidebar.php
+%%WWWDIR%%/parts/menu_sidebar.php
+%%WWWDIR%%/parts/print_table.php
+%%WWWDIR%%/parts/project_add_evidence.php
+%%WWWDIR%%/parts/project_add_evidence_multiple.php
+%%WWWDIR%%/parts/project_add_hypothesis.php
+%%WWWDIR%%/parts/project_add_hypothesis_multiple.php
+%%WWWDIR%%/parts/project_cell.php
+%%WWWDIR%%/parts/project_compare-restore.php
+%%WWWDIR%%/parts/project_compare.php
+%%WWWDIR%%/parts/project_compare_print.php
+%%WWWDIR%%/parts/project_edit.php
+%%WWWDIR%%/parts/project_edit_scores.php
+%%WWWDIR%%/parts/project_evidence.php
+%%WWWDIR%%/parts/project_export.php
+%%WWWDIR%%/parts/project_group.php
+%%WWWDIR%%/parts/project_group_print.php
+%%WWWDIR%%/parts/project_hypothesis.php
+%%WWWDIR%%/parts/project_personal.php
+%%WWWDIR%%/parts/project_personal_print.php
+%%WWWDIR%%/parts/project_user-restore.php
+%%WWWDIR%%/parts/project_user.php
+%%WWWDIR%%/parts/project_user_print.php
+%%WWWDIR%%/parts/recent_activity.php
+%%WWWDIR%%/parts/save_cell_rating.php
+%%WWWDIR%%/parts/save_cred_rating.php
+%%WWWDIR%%/parts/save_cred_weight.php
+%%WWWDIR%%/password_reset.php
+%%WWWDIR%%/password_reset_action.php
+%%WWWDIR%%/password_reset_change.php
+%%WWWDIR%%/phpinfo.php
+%%WWWDIR%%/profile.php
+%%WWWDIR%%/project.php
+%%WWWDIR%%/project_add_evidence_action.php
+%%WWWDIR%%/project_add_evidence_multiple_action.php
+%%WWWDIR%%/project_add_hypothesis_action.php
+%%WWWDIR%%/project_add_hypothesis_multiple_action.php
+%%WWWDIR%%/project_chat.php
+%%WWWDIR%%/project_compare_two_users_action.php
+%%WWWDIR%%/project_compare_users_action.php
+%%WWWDIR%%/project_delete.php
+%%WWWDIR%%/project_edit_evidence_action.php
+%%WWWDIR%%/project_edit_hypothesis_action.php
+%%WWWDIR%%/project_invite_viewer.php
+%%WWWDIR%%/project_join.php
+%%WWWDIR%%/project_leave.php
+%%WWWDIR%%/project_ratings_action.php
+%%WWWDIR%%/project_ratings_user_action.php
+%%WWWDIR%%/projects.php
+%%WWWDIR%%/recent_activity.php
+%%WWWDIR%%/robots.txt
+%%WWWDIR%%/show_active_users.php
+%%WWWDIR%%/switch_cred.php
+%%WWWDIR%%/switch_flag.php
+%%WWWDIR%%/tag.php
+%%WWWDIR%%/testmysql.php
+%%WWWDIR%%/time.php
+%%WWWDIR%%/xml_cell.php
+%%WWWDIR%%/xml_evidence.php
+%%WWWDIR%%/xml_hypothesis.php
+@dirrm %%WWWDIR%%/parts
+@dirrm %%WWWDIR%%/js/src
+@dirrm %%WWWDIR%%/js/overlib/Mini
+@dirrm %%WWWDIR%%/js/overlib
+@dirrm %%WWWDIR%%/js/lib
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/imports
+@dirrm %%WWWDIR%%/images/user
+@dirrm %%WWWDIR%%/images/icons
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/help/images
+@dirrm %%WWWDIR%%/help
+@dirrm %%WWWDIR%%/css
+@dirrm %%WWWDIR%%/code/nusoap/samples
+@dirrm %%WWWDIR%%/code/nusoap/lib
+@dirrm %%WWWDIR%%/code/nusoap
+@dirrm %%WWWDIR%%/code/frameworks
+@dirrm %%WWWDIR%%/code
+@dirrm %%WWWDIR%%/auth
+@dirrm %%WWWDIR%%/ajax
+@dirrm %%WWWDIR%%
+@exec mkdir -p %D/%%WWWDIR%%/imports
+@exec mkdir -p %D/%%WWWDIR%%/images/user