aboutsummaryrefslogtreecommitdiffstats
path: root/www/aolserver
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2012-07-30 23:38:16 +0800
committerzeising <zeising@FreeBSD.org>2012-07-30 23:38:16 +0800
commit6206eb198735d6fa934388b80c68810c6c88507b (patch)
tree3c7d2809f9d108527a0b6d550b748c38091337ad /www/aolserver
parentcc15ecb06c5c13452f4b6540373f2fa344bb87e2 (diff)
downloadfreebsd-ports-gnome-6206eb198735d6fa934388b80c68810c6c88507b.tar.gz
freebsd-ports-gnome-6206eb198735d6fa934388b80c68810c6c88507b.tar.zst
freebsd-ports-gnome-6206eb198735d6fa934388b80c68810c6c88507b.zip
Misc. fixes:
- Remove pre/post include - No need for ARCH check since ONLY_FOR_ARCHS is used - Use USERS/GROUPS - Fix invalid @exec in plist causing directory to be created in the wrong place with pkgng Add nogroup to GIDs since this port uses it. PR: ports/169984 Submitted by: maintainer Approved by: kwm (mentor)
Diffstat (limited to 'www/aolserver')
-rw-r--r--www/aolserver/Makefile10
-rw-r--r--www/aolserver/pkg-plist4
2 files changed, 6 insertions, 8 deletions
diff --git a/www/aolserver/Makefile b/www/aolserver/Makefile
index e451072b4a92..c51cea4625a4 100644
--- a/www/aolserver/Makefile
+++ b/www/aolserver/Makefile
@@ -26,6 +26,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
AOLSERVERBASE?= ${PORTNAME}
AOLSERVERUSER?= nobody
AOLSERVERGROUP?= nogroup
+USERS= ${AOLSERVERUSER}
+GROUPS= ${AOLSERVERGROUP}
MANPREFIX= ${PREFIX}/${AOLSERVERBASE}
USE_GMAKE= yes
@@ -52,15 +54,11 @@ HTMLDOCS_DESC= Install HTML documentation
MANPAGES_DESC= Install manpages
TESTS_DESC= Install tests in example directory
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
SUB_LIST+= MKDIR="${MKDIR}" ECHO_CMD="${ECHO_CMD}" \
CHOWN="${CHOWN}" CHMOD="${CHMOD}"
-.if (${ARCH} == "ia64")
-BROKEN= does not compile on ia64
-.endif
-
CONFIGURE_ENV+= TCLSH="${TCLSH}"
CONFIGURE_ARGS+= --prefix="${PREFIX}/${AOLSERVERBASE}" \
--with-tcl="${TCL_LIBDIR}"
@@ -738,4 +736,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/aolserver/pkg-plist b/www/aolserver/pkg-plist
index 52d6432b2d2d..873ec9752cb5 100644
--- a/www/aolserver/pkg-plist
+++ b/www/aolserver/pkg-plist
@@ -832,8 +832,8 @@
@dirrmtry %%AOLSERVERBASE%%/servers/server1
@dirrmtry %%AOLSERVERBASE%%/servers
@dirrmtry %%AOLSERVERBASE%%
-@exec mkdir -p %%AOLSERVERBASE%%/log
-@exec mkdir -p %%AOLSERVERBASE%%/servers/server1/modules/nslog
+@exec mkdir -p %D/%%AOLSERVERBASE%%/log
+@exec mkdir -p %D/%%AOLSERVERBASE%%/servers/server1/modules/nslog
%%TESTS%%%%EXAMPLESDIR%%/tests/adp/test1.adp
%%TESTS%%%%EXAMPLESDIR%%/tests/adp/test2.adp
%%TESTS%%%%EXAMPLESDIR%%/tests/adp/test3.adp