aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache-jserv
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-11-13 12:48:16 +0800
committersteve <steve@FreeBSD.org>2000-11-13 12:48:16 +0800
commit2e197cdf6039af0469092fa52c52637b68adc81c (patch)
treef35c3e1bf5fead31345873c204fd6d0fe20bd042 /www/apache-jserv
parent4e7ff97f58008c35459ef92a69ff9ac9e51819a7 (diff)
downloadfreebsd-ports-gnome-2e197cdf6039af0469092fa52c52637b68adc81c.tar.gz
freebsd-ports-gnome-2e197cdf6039af0469092fa52c52637b68adc81c.tar.zst
freebsd-ports-gnome-2e197cdf6039af0469092fa52c52637b68adc81c.zip
- Provide the full path for gmake(1) so configure doesn't fall over.
- Re-order a couple of USE_* directives. - Add USE_PERL5 since it does. - Pass the configure script the full patch to perl. PR: 22693 Reviewed by: Allan Bowhill <kosmos@bowhill.yi.org>
Diffstat (limited to 'www/apache-jserv')
-rw-r--r--www/apache-jserv/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/apache-jserv/Makefile b/www/apache-jserv/Makefile
index a1495a020f6b..76bb2b0d81ac 100644
--- a/www/apache-jserv/Makefile
+++ b/www/apache-jserv/Makefile
@@ -20,10 +20,12 @@ RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/javavmwrapper\
${LOCALBASE}/sbin/apachectl:${PORTSDIR}/www/apache13\
${LOCALBASE}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
-USE_LIBTOOL= yes
USE_GMAKE= yes
+GMAKE= ${LOCALBASE}/bin/gmake # Must have the full path.
+USE_LIBTOOL= yes
+USE_PERL5= yes
JAVAVM?= ${LOCALBASE}/bin/javavm
-CONFIGURE_ENV= MAKE=${LOCALBASE}/bin/${GMAKE}
+CONFIGURE_ENV= PERL=${PERL}
CONFIGURE_ARGS= --prefix=${PREFIX}\
--libexecdir=${LOCALBASE}/libexec/apache\
--libdir=${LOCALBASE}/libexec/apache\