aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache13
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2007-10-01 13:53:05 +0800
committerache <ache@FreeBSD.org>2007-10-01 13:53:05 +0800
commit80b1005f7626b7cf075119a70bc4981ac488d245 (patch)
treec7759a023cf235fb7d34a4f3281f742e863ea059 /www/apache13
parent150ee35dfa977f6271ca0dfd7bcb7dc491435459 (diff)
downloadfreebsd-ports-gnome-80b1005f7626b7cf075119a70bc4981ac488d245.tar.gz
freebsd-ports-gnome-80b1005f7626b7cf075119a70bc4981ac488d245.tar.zst
freebsd-ports-gnome-80b1005f7626b7cf075119a70bc4981ac488d245.zip
Stop linking data and cgi-bin to -dist ones by default, it affects packages
badly when they installed in batch (they write into -dist dirs). Try to create empty data and cgi-bin instead.
Diffstat (limited to 'www/apache13')
-rw-r--r--www/apache13/Makefile6
-rw-r--r--www/apache13/files/patch-ab29
-rw-r--r--www/apache13/pkg-plist14
3 files changed, 18 insertions, 31 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index 0331817b8ecc..c932c0bb57f6 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache
PORTVERSION= 1.3.39
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
@@ -145,13 +145,9 @@ MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
${SUEXEC_MAN}
pre-install:
- -@${CHMOD} u+w ${DOCUMENT_ROOT}-dist ${CGIBIN_ROOT}-dist
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
- @${TOUCH} ${DOCUMENT_ROOT}-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
- @${TOUCH} ${CGIBIN_ROOT}-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
- @${CHMOD} a-w ${DOCUMENT_ROOT}-dist ${CGIBIN_ROOT}-dist
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/apache13/files/patch-ab b/www/apache13/files/patch-ab
index 567c58ca2e00..986749781248 100644
--- a/www/apache13/files/patch-ab
+++ b/www/apache13/files/patch-ab
@@ -1,19 +1,21 @@
---- Makefile.tmpl.orig Thu Mar 14 00:05:27 2002
-+++ Makefile.tmpl Sat Jun 22 09:33:52 2002
-@@ -270,10 +270,10 @@
+--- Makefile.tmpl.orig 2006-07-12 12:16:05.000000000 +0400
++++ Makefile.tmpl 2007-10-01 09:21:04.000000000 +0400
+@@ -227,10 +227,12 @@
$(MKDIR) $(root)$(mandir)/man1
$(MKDIR) $(root)$(mandir)/man8
$(MKDIR) $(root)$(sysconfdir)
- $(MKDIR) $(root)$(htdocsdir)
++ $(MKDIR) $(root)$(htdocsdir)/
+ $(MKDIR) $(root)$(htdocsdir)-dist
$(MKDIR) $(root)$(manualdir)
$(MKDIR) $(root)$(iconsdir)
- $(MKDIR) $(root)$(cgidir)
++ $(MKDIR) $(root)$(cgidir)/
+ $(MKDIR) $(root)$(cgidir)-dist
$(MKDIR) $(root)$(includedir)
$(MKDIR) $(root)$(includedir)/xml
$(MKDIR) $(root)$(runtimedir)
-@@ -459,33 +459,29 @@
+@@ -416,33 +418,23 @@
# icons and distributed CGI scripts.
install-data:
@echo "===> [data: Installing initial data files]"
@@ -36,13 +38,11 @@
(cd $(root)$(manualdir)/ && $(TAR) -xf -); \
find $(root)$(manualdir)/ -type d -exec chmod a+rx {} \; ; \
- find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ; \
-+ find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ;
-+ if [ ! -d $(root)$(htdocsdir)/ ]; then \
-+ $(LN) -sf $(root)$(htdocsdir)-dist $(root)$(htdocsdir); \
- fi
+- fi
- -@if [ -f $(root)$(cgidir)/printenv ]; then \
- echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
- else \
++ find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ;
for script in printenv test-cgi; do \
cat $(TOP)/cgi-bin/$${script} |\
sed -e 's;^#!/.*perl;#!$(PERL);' \
@@ -54,13 +54,10 @@
+ echo "$(INSTALL_DATA) $(TOP)/conf/$${script}[*] $(root)$(cgidir)-dist/$${script}"; \
+ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(cgidir)-dist/$${script}; \
+ done;
-+ if [ ! -d $(root)$(cgidir)/ ]; then \
-+ $(LN) -sf $(root)$(cgidir)-dist $(root)$(cgidir); \
-+ fi
@echo "Copying tree $(TOP)/icons/ -> $(root)$(iconsdir)/"; \
(cd $(TOP)/icons/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(iconsdir)/ && $(TAR) -xf -); \
-@@ -524,10 +520,10 @@
+@@ -481,10 +473,10 @@
-e 's;logs/accept\.lock;$(runtimedir)/$(TARGET).lock;' \
-e 's;logs/apache_runtime_status;$(runtimedir)/$(TARGET).scoreboard;' \
-e 's;logs/httpd\.pid;$(runtimedir)/$(TARGET).pid;' \
@@ -73,9 +70,9 @@
+ -e "s;logs/referer_log;$(logfiledir)/$${target_prefix}httpd-referer.log;" \
+ -e "s;logs/agent_log;$(logfiledir)/$${target_prefix}httpd-agent.log;" \
-e 's;conf/magic;$(sysconfdir)/magic;' \
- -e 's;conf/mime\.types;$(sysconfdir)/mime.types;' \
- -e 's;User nobody;User $(conf_user);' \
-@@ -537,8 +533,8 @@
+ -e 's;conf/srm.conf;$(sysconfdir)/srm.conf;' \
+ -e 's;conf/access.conf;$(sysconfdir)/access.conf;' \
+@@ -496,8 +488,8 @@
-e 's;ServerAdmin you@your.address;ServerAdmin $(conf_serveradmin);' \
-e 's;ServerName new.host.name;ServerName $(conf_servername);' \
> $(TOP)/$(SRC)/.apaci.install.tmp && \
@@ -86,7 +83,7 @@
if [ ! -f "$(root)$(sysconfdir)/$${target_conf}" ]; then \
echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}"; \
$(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}; \
-@@ -547,8 +543,8 @@
+@@ -506,8 +498,8 @@
fi; \
done
-@for conf in mime.types magic; do \
diff --git a/www/apache13/pkg-plist b/www/apache13/pkg-plist
index e259706ffa73..be7bc2428491 100644
--- a/www/apache13/pkg-plist
+++ b/www/apache13/pkg-plist
@@ -105,9 +105,7 @@ sbin/logresolve
sbin/rotatelogs
%%SUB_SUEXEC%%sbin/suexec
@exec mkdir -p -m 755 %D/www/data-dist
-@unexec chmod u+w %D/www/data-dist
-www/data-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
-@exec [ -d %D/www/data/ ] || ln -fs %B %D/www/data
+@exec [ -d %D/www/data/ ] || mkdir -p -m 755 %D/www/data/
www/data-dist/apache_pb.gif
www/data-dist/index.html.ca
www/data-dist/index.html.cz
@@ -139,7 +137,6 @@ www/data-dist/index.html.ru.ucs4
www/data-dist/index.html.ru.utf8
www/data-dist/index.html.se
www/data-dist/index.html.zh-tw.big5
-@exec chmod a-w %D/www/data-dist
%%DOCSDIR%%/LICENSE
%%DOCSDIR%%/bind.html.en
%%DOCSDIR%%/bind.html.fr
@@ -432,12 +429,9 @@ www/data-dist/index.html.zh-tw.big5
%%DOCSDIR%%/windows.html.html
%%DOCSDIR%%/windows.html.ja.jis
@exec mkdir -p -m 755 %D/www/cgi-bin-dist
-@unexec chmod u+w %D/www/cgi-bin-dist
-www/cgi-bin-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
-@exec [ -d %D/www/cgi-bin/ ] || ln -fs %B %D/www/cgi-bin
+@exec [ -d %D/www/cgi-bin/ ] || mkdir -p -m 755 %D/www/cgi-bin/
www/cgi-bin-dist/printenv
www/cgi-bin-dist/test-cgi
-@exec chmod a-w %D/www/cgi-bin-dist
www/icons/README
www/icons/README.html
www/icons/a.gif
@@ -657,8 +651,6 @@ www/icons/world1.png
www/icons/world2.gif
www/icons/world2.png
@exec mkdir -p %D/www/proxy
-@unexec if [ -L %D/www/cgi-bin ]; then rm -f %D/www/cgi-bin; fi
-@unexec if [ -L %D/www/data ]; then rm -f %D/www/data; fi
@unexec rm -f %D/etc/apache/httpd.conf.bak 2> /dev/null || true
@dirrmtry etc/apache
@dirrm include/apache/xml
@@ -671,7 +663,9 @@ www/icons/world2.png
@dirrm %%DOCSDIR%%/programs
@dirrm %%DOCSDIR%%/vhosts
@dirrm %%DOCSDIR%%
+@dirrmtry www/data/
@dirrm www/data-dist
+@dirrmtry www/cgi-bin/
@dirrm www/cgi-bin-dist
@dirrm www/icons/small
@dirrmtry www/icons