aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20/Makefile.modules.3rd
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-10-12 16:27:40 +0800
committerclement <clement@FreeBSD.org>2004-10-12 16:27:40 +0800
commitdccde7096af9a8c07f8ccc6d1b5200fe7f8d108e (patch)
tree4027048ecf97714c3893306bcd3d7562b42a6a25 /www/apache20/Makefile.modules.3rd
parent32a57f0e52b27fcef8ef677b366067e2236720fb (diff)
downloadfreebsd-ports-gnome-dccde7096af9a8c07f8ccc6d1b5200fe7f8d108e.tar.gz
freebsd-ports-gnome-dccde7096af9a8c07f8ccc6d1b5200fe7f8d108e.tar.zst
freebsd-ports-gnome-dccde7096af9a8c07f8ccc6d1b5200fe7f8d108e.zip
- Update to 2.0.52
- Use "PORTDOCS= #" and get rid of docs entry in plist. - Support for FreeBSD 6 in apr - Move of cache modules from THREADS to EXPERIMENTAL category and make sure we enable THREADS modules (cgid only) when a threaded MPM is selected. - Resurect WITH_EXTRA_MODULES knob - powerlogo.gif is now hosted by FreeBSD mirrors - WITH_<category> is definitively no longer supported. - Add Includes dir when installed via a package [1] PR: ports/72309 [1] Submitted by: Christian Kratzer <ck at cksoft dot de> [1]
Diffstat (limited to 'www/apache20/Makefile.modules.3rd')
-rw-r--r--www/apache20/Makefile.modules.3rd10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index dd3a040a2648..04078a435f64 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -116,6 +116,11 @@ do-install:
.else # PORT_IS_SERVER
+# For slave ports:
+.if defined(SLAVE_DESIGNED_FOR) && ${PORTVERSION} != ${SLAVE_DESIGNED_FOR}
+IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
+.endif
+
# Module selection
.for category in ${DEFAULT_MODULES_CATEGORIES}
DEFAULT_MODULES+= ${${category}_MODULES}
@@ -150,10 +155,13 @@ _APACHE_MODULES+= ${WITH_MODULES}
. if defined (WITH_CUSTOM_${category})
_APACHE_MODULES+= ${WITH_CUSTOM_${category}}
. endif
-.elif defined(WITH_${category}_MODULES) || defined(WITH_${category})
+.elif defined(WITH_${category}_MODULES)
_APACHE_MODULES+= ${${category}_MODULES}
.endif
.endfor
+. if defined(WITH_EXTRA_MODULES)
+_APACHE_MODULES+= ${WITH_EXTRA_MODULES}
+. endif
.endif