aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-07-13 17:32:44 +0800
committerclement <clement@FreeBSD.org>2004-07-13 17:32:44 +0800
commit3bb297de5744ab3be3cfff7b5aac20cec79d5acb (patch)
tree6dace4ddddc3d276683a7ff19dc59d26ff99d979 /www/apache20
parent33417460745d05559ed280e4b5c560f7b017a8df (diff)
downloadfreebsd-ports-gnome-3bb297de5744ab3be3cfff7b5aac20cec79d5acb.tar.gz
freebsd-ports-gnome-3bb297de5744ab3be3cfff7b5aac20cec79d5acb.tar.zst
freebsd-ports-gnome-3bb297de5744ab3be3cfff7b5aac20cec79d5acb.zip
- Fix hostname resolution if IPv4 are mapped. [1]
- Add WITHOUT_V4MAPPED knob and explicitly set --disable-v4-mapped if WITHOUT_V4MAPPED or WITH_IPV6_V6ONLY Also submitted by: Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp> [1]
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile4
-rw-r--r--www/apache20/Makefile.doc2
-rw-r--r--www/apache20/files/patch-fix-srclib:apr:network_io:unix:sockaddr.c10
3 files changed, 15 insertions, 1 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 69ceaf6db346..3e06a63f474c 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -77,7 +77,9 @@ WITH_HTTP_PORT?= 80
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
-.elif !defined(WITH_IPV6_V6ONLY)
+.elif defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
+CONFIGURE_ARGS+= --disable-v4-mapped
+.else
CONFIGURE_ARGS+= --enable-v4-mapped
.endif
diff --git a/www/apache20/Makefile.doc b/www/apache20/Makefile.doc
index 12a65693a560..fb54f7c9f6dc 100644
--- a/www/apache20/Makefile.doc
+++ b/www/apache20/Makefile.doc
@@ -23,6 +23,8 @@
## WITHOUT_AUTH: Disable auth modules
## WITH_CUSTOM_AUTH: Let you choose which auth modules you wish
## WITHOUT_DAV: Disable DAV support
+## WITHOUT_IPV6: Disable IPv6 support
+## WITHOUT_V4MAPPED
## WITH_IPV6_V6ONLY: Don't allow IPv6 sockets to handle IPv4
## connections
## WITHOUT_SSL: Disable SSL support
diff --git a/www/apache20/files/patch-fix-srclib:apr:network_io:unix:sockaddr.c b/www/apache20/files/patch-fix-srclib:apr:network_io:unix:sockaddr.c
new file mode 100644
index 000000000000..336671027754
--- /dev/null
+++ b/www/apache20/files/patch-fix-srclib:apr:network_io:unix:sockaddr.c
@@ -0,0 +1,10 @@
+--- srclib/apr/network_io/unix/sockaddr.c.orig Tue Jul 13 09:08:03 2004
++++ srclib/apr/network_io/unix/sockaddr.c Tue Jul 13 09:08:46 2004
+@@ -612,6 +612,7 @@
+ struct sockaddr_in tmpsa;
+ tmpsa.sin_family = AF_INET;
+ tmpsa.sin_addr.s_addr = ((apr_uint32_t *)sockaddr->ipaddr_ptr)[3];
++ tmpsa.sin_len = sizeof(tmpsa);
+
+ rc = getnameinfo((const struct sockaddr *)&tmpsa, sizeof(tmpsa),
+ tmphostname, sizeof(tmphostname), NULL, 0,