aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-07-26 16:25:13 +0800
committerclement <clement@FreeBSD.org>2005-07-26 16:25:13 +0800
commit051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40 (patch)
treee17dc127919d3064cc1912d059343be2096e578a /www/apache20
parentc0cb020fd929842f3e720c25db3bfc98c9130398 (diff)
downloadfreebsd-ports-gnome-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.tar.gz
freebsd-ports-gnome-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.tar.zst
freebsd-ports-gnome-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.zip
Security: fix a buffer overrun in ssl_callback_SSLVerify_CRL()
Reported by: thierry
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile1
-rw-r--r--www/apache20/files/patch-secfix-ssl_engine_kernel.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 0873160a4f3a..1d81c75dde42 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,6 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.54
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo
diff --git a/www/apache20/files/patch-secfix-ssl_engine_kernel.c b/www/apache20/files/patch-secfix-ssl_engine_kernel.c
new file mode 100644
index 000000000000..3b8be849954b
--- /dev/null
+++ b/www/apache20/files/patch-secfix-ssl_engine_kernel.c
@@ -0,0 +1,11 @@
+--- modules/ssl/ssl_engine_kernel.c 2005/06/08 09:00:24 189561
++++ modules/ssl/ssl_engine_kernel.c 2005/06/08 09:08:09 189562
+@@ -1398,7 +1398,7 @@
+ BIO_printf(bio, ", nextUpdate: ");
+ ASN1_UTCTIME_print(bio, X509_CRL_get_nextUpdate(crl));
+
+- n = BIO_read(bio, buff, sizeof(buff));
++ n = BIO_read(bio, buff, sizeof(buff) - 1);
+ buff[n] = '\0';
+
+ BIO_free(bio);