aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-04-16 21:29:29 +0800
committerclement <clement@FreeBSD.org>2004-04-16 21:29:29 +0800
commita83b08642d3f92f5107ca32d513020060a6c204b (patch)
tree7208e44a47510c831d14cc61e45c2360bc2fcca4 /www/apache20
parentc72f8bd74ef4e08fa26c47787652ae3429b218dc (diff)
downloadfreebsd-ports-gnome-a83b08642d3f92f5107ca32d513020060a6c204b.tar.gz
freebsd-ports-gnome-a83b08642d3f92f5107ca32d513020060a6c204b.tar.zst
freebsd-ports-gnome-a83b08642d3f92f5107ca32d513020060a6c204b.zip
Remove noisy apache version detection
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile.modules.3rd14
1 files changed, 3 insertions, 11 deletions
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index 7c788bded38a..c2c5c982557d 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -26,19 +26,13 @@ BROKEN= "This module require apache13 and you have apache2 installed"
. endif
.elif exists(${LOCALBASE}/include/apache/http_core.h)
WITH_APACHE13= YES
-.if exists(${LOCALBASE}/sbin/pkg_info)
-PKGINFO= ${LOCALBASE}/sbin/pkg_info
-.else
-PKGINFO= /usr/sbin/pkg_info
-.endif
-APACHE_PORT!= ${PKGINFO} -qo `${PKGINFO} -qW /usr/local/include/apache/http_core.h `
. if defined (WANT_APACHE)
. if ${WANT_APACHE} == 2
-BROKEN= "This module require apache2 and you have ${APACHE_PORT} installed"
+BROKEN= "This module require apache2 and you have apache13 installed"
. endif
. endif
. ifdef(WITH_APACHE2)
-.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but ${APACHE_PORT} is installed Please undefine and try again.
+.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but apache13 is installed Please undefine and try again.
. endif
.endif
@@ -60,9 +54,7 @@ AP_VER= 2
.else
AP_BUILDEXT= so
PLIST_SUB+= APACHEMODDIR="libexec/apache"
-. if !defined(APACHE_PORT)
-APACHE_PORT= www/apache13
-. endif
+APACHE_PORT?= www/apache13
AP_VER= 13
.endif