aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache21
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-01-11 21:45:05 +0800
committerclement <clement@FreeBSD.org>2005-01-11 21:45:05 +0800
commit4e1149fd37dd757e4994fdc980cd5b0b2461f5b2 (patch)
treeaeea5674d5102def97d6322c40f75cf06f776ac7 /www/apache21
parentb35a929f7a4cd48ba6e761d978f0d1c13b180a18 (diff)
downloadfreebsd-ports-gnome-4e1149fd37dd757e4994fdc980cd5b0b2461f5b2.tar.gz
freebsd-ports-gnome-4e1149fd37dd757e4994fdc980cd5b0b2461f5b2.tar.zst
freebsd-ports-gnome-4e1149fd37dd757e4994fdc980cd5b0b2461f5b2.zip
o startup script:
- Use apache{2,21}flags variable in apache{2,21}_checkconfig(). It fixes restart when apache2ssl_enable is set to YES in rc.conf and httpd.conf is "old" (i.e. non -DSSL safe) [1] o Makefile - split post-install target to add install-startup-script: User can now upgrade startup script without reinstalling apache2. NOTE: this is NOT package-safe and NOT supported, even if in most of cases they're no risk. Noticed by: many [1]
Diffstat (limited to 'www/apache21')
-rw-r--r--www/apache21/Makefile13
-rw-r--r--www/apache21/files/apache.sh4
2 files changed, 12 insertions, 5 deletions
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index 8195f5c957bd..afa43f37f6e7 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -210,10 +210,17 @@ post-configure:
pre-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-post-install:
- @${MKDIR} ${PREFIX}/etc/apache21/Includes
+install-startup-script:
+.if !exists(${WRKDIR}/apache21.sh)
+ @${MKDIR} ${WRKDIR}
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/apache.sh > ${WRKDIR}/apache21.sh
+.endif
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache21.sh startup script."
- @${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache21.sh ${PREFIX}/etc/rc.d/apache21.sh
+ @${INSTALL_SCRIPT} -m 555 ${WRKDIR}/apache21.sh ${PREFIX}/etc/rc.d/apache21.sh
+
+post-install: install-startup-script
+ @${MKDIR} ${PREFIX}/etc/apache21/Includes
@@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/apache21/files/apache.sh b/www/apache21/files/apache.sh
index 87300ba82a54..42a4dca6f1b0 100644
--- a/www/apache21/files/apache.sh
+++ b/www/apache21/files/apache.sh
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/www/apache21/files/Attic/apache.sh,v 1.7 2004-12-11 18:06:04 clement Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache21/files/Attic/apache.sh,v 1.8 2005-01-11 13:45:05 clement Exp $
#
# PROVIDE: apache21
@@ -49,7 +49,7 @@ checkyesno apache21ssl_enable && \
apache21_checkconfig()
{
echo "Performing sanity check on apache21 configuration:"
- ${command} -t
+ ${command} ${apache21_flags} -t
}
apache21_precmd()