aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache22/Makefile.modules
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-12-14 02:48:03 +0800
committerclement <clement@FreeBSD.org>2004-12-14 02:48:03 +0800
commitf26e8c8b43d2a848944fa0196da97f060394b991 (patch)
tree23050945d9a4ed264fdeabd5af342b984a9120d3 /www/apache22/Makefile.modules
parent56cc4ebbb98f9c23847b71cb8cee7f254775db2d (diff)
downloadfreebsd-ports-gnome-f26e8c8b43d2a848944fa0196da97f060394b991.tar.gz
freebsd-ports-gnome-f26e8c8b43d2a848944fa0196da97f060394b991.tar.zst
freebsd-ports-gnome-f26e8c8b43d2a848944fa0196da97f060394b991.zip
- Move standard configuration files to ${EXAMPLESDIR} to not get
dist config files installed in ${PREFIX}/etc/apache21 - Add support for Event MPM and add backport from apr to support APR_POLLSET_THREADSAFE (needed by Event MPM and forgotten @ release time) [1] - misc cleanups - Bump PORTREVISION to reflect all cool changes which occured today ;) Obtained from: apr svn repository
Diffstat (limited to 'www/apache22/Makefile.modules')
-rw-r--r--www/apache22/Makefile.modules13
1 files changed, 8 insertions, 5 deletions
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 71663322e595..1f2404e60556 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -24,19 +24,22 @@ WITH_THREADS= yes
WITH_THREADS_MODULES= yes
WITHOUT_MODULES+= cgi
. if ${WITH_MPM:L} == "worker"
-PLIST_SUB+= PREFORK="@comment " WORKER="" THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="" THREADPOOL="@comment " EVENT="@comment "
. elif ${WITH_MPM:L} == "perchild"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
. elif ${WITH_MPM:L} == "threadpool"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL=""
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="" EVENT="@comment "
+. elif ${WITH_MPM:L} == "event"
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT=""
+EXTRA_PATCHES+= ${FILESDIR}/exp-event-mpm-apr-backport.patch
. else
IGNORE= "Unknown MPM: ${WITH_MPM}"
. endif
. else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
. endif
.else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
.endif
# xDBM section