aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache22
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-12-12 07:37:04 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-12-12 07:37:04 +0800
commit443450fe4e8b18013d8891c02578a16a8af461bf (patch)
treeaa13277c1edf2cd44ee22906d8843e282a71cbbf /www/apache22
parenta4435dc8eaaaab0f79f339865b4c62a409d4796b (diff)
downloadfreebsd-ports-gnome-443450fe4e8b18013d8891c02578a16a8af461bf.tar.gz
freebsd-ports-gnome-443450fe4e8b18013d8891c02578a16a8af461bf.tar.zst
freebsd-ports-gnome-443450fe4e8b18013d8891c02578a16a8af461bf.zip
- Fix handling of apache22_http_accept_enable="YES|NO"
o Note, don't use required_modules you can not check the return value to conditionalize the -DNOHTTPACCEPT flag PR: ports/138373 Submitted by: Helmut Schneider <jumper99@gmx.de>
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/apache22.in24
2 files changed, 9 insertions, 17 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 510cb999de11..9c26d6b71440 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/apache22.in b/www/apache22/files/apache22.in
index 811390bcd2d6..f91ddc86cc41 100644
--- a/www/apache22/files/apache22.in
+++ b/www/apache22/files/apache22.in
@@ -49,21 +49,13 @@ required_files=%%PREFIX%%/etc/apache22/httpd.conf
[ -z "$apache22_fib" ] && apache22_fib="NO"
apache22_accf() {
- retcode=0
- if checkyesno apache22_http_accept_enable
- then
- /sbin/kldstat -v | grep accf_http >/dev/null 2>&1
- retcode=${?}
- if [ ${retcode} -ne 0 ]
- then
- /sbin/kldload accf_http 2> /dev/null
- retcode=${?}
- fi
- else
- apache22_flags="${apache22_flags} -DNOHTTPACCEPT"
- fi
- [ ${retcode} -ne 0 ] && echo "Unable to load accf_http module"
- return ${retcode}
+
+ if checkyesno apache22_http_accept_enable; then
+ /sbin/kldstat -v | grep accf_http > /dev/null 2>&1 || /sbin/kldload accf_http || return ${?}
+ /sbin/kldstat -v | grep accf_data > /dev/null 2>&1 || /sbin/kldload accf_data || return ${?}
+ else
+ apache22_flags="${apache22_flags} -DNOHTTPACCEPT"
+ fi
}
load_rc_config $name
@@ -125,7 +117,7 @@ else
fi
if [ "${1}" != "stop" ] ; then \
- apache22_accf || apache22_flags="${apache22_flags} -DNOHTTPACCEPT"
+ apache22_accf
fi
apache22_requirepidfile()