aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache22
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-13 08:59:32 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-13 08:59:32 +0800
commit3a0aa49e05d307197089540ee44381eb94692c25 (patch)
tree53c1b9c3592eaa5397b3cb067b56eebb6805dd5a /www/apache22
parent89688c822e368874cf749c1d0d49f29b1e4a0004 (diff)
downloadfreebsd-ports-gnome-3a0aa49e05d307197089540ee44381eb94692c25.tar.gz
freebsd-ports-gnome-3a0aa49e05d307197089540ee44381eb94692c25.tar.zst
freebsd-ports-gnome-3a0aa49e05d307197089540ee44381eb94692c25.zip
- Remove use of $] which is deprecated in perl and gone in perl 5.12
This is already being discussed at dev@httpd and will be committed upstream Reported by: brad clawsie <clawsie@fastmail.fm> (on apache@ list) With Hat: apache@
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/patch-support__apxs.in16
2 files changed, 13 insertions, 5 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 1de60b21666a..516be1a5d8b8 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.15
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/patch-support__apxs.in b/www/apache22/files/patch-support__apxs.in
index 6fa4ed065c94..975586835a90 100644
--- a/www/apache22/files/patch-support__apxs.in
+++ b/www/apache22/files/patch-support__apxs.in
@@ -1,6 +1,14 @@
--- ./support/apxs.in.orig 2006-07-11 23:38:44.000000000 -0400
-+++ ./support/apxs.in 2010-05-06 19:37:54.268730293 -0400
-@@ -547,7 +547,10 @@
++++ ./support/apxs.in 2010-05-12 20:57:31.242745632 -0400
+@@ -83,7 +83,6 @@
+ my ($argumentative, @ARGV) = @_;
+ my $errs = 0;
+ local $_;
+- local $[ = 0;
+
+ my @args = split / */, $argumentative;
+ while (@ARGV && ($_ = $ARGV[0]) =~ /^-(.)(.*)/) {
+@@ -547,7 +546,10 @@
$c = '#' if ($opt_A);
foreach $lmd (@lmd) {
my $what = $opt_A ? "preparing" : "activating";
@@ -12,7 +20,7 @@
# check for open <containers>, so that the new LoadModule
# directive always appears *outside* of an <container>.
-@@ -610,7 +613,13 @@
+@@ -610,7 +612,13 @@
}
} else {
# replace already existing LoadModule line
@@ -27,7 +35,7 @@
}
$lmd =~ m|LoadModule\s+(.+?)_module.*|;
notice("[$what module `$1' in $CFG_SYSCONFDIR/$CFG_TARGET.conf]");
-@@ -619,8 +628,7 @@
+@@ -619,8 +627,7 @@
if (open(FP, ">$CFG_SYSCONFDIR/$CFG_TARGET.conf.new")) {
print FP $content;
close(FP);