aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache2
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-01-22 05:21:12 +0800
committerclement <clement@FreeBSD.org>2004-01-22 05:21:12 +0800
commit7e572c6e0859915e3167729dc07ef936d603c87f (patch)
tree5d26a070f5e240c442541f91e65fad837108928b /www/apache2
parent29d57823d68b98cffb1a7f6403ce33ce226e8a0d (diff)
downloadfreebsd-ports-gnome-7e572c6e0859915e3167729dc07ef936d603c87f.tar.gz
freebsd-ports-gnome-7e572c6e0859915e3167729dc07ef936d603c87f.tar.zst
freebsd-ports-gnome-7e572c6e0859915e3167729dc07ef936d603c87f.zip
Add WITH_PTHREAD_LIBS and WITH_EXPERIMENTAL_THREADS.
These options are for people who want to directly link apache against libkse and libthr. Usage: WITH_EXPERIMENTAL_THREADS=YES Overrides default pthread detection behaviour. WITH_PTHREAD_LIBS={kse;thr} Lets you choose your pthread lib. Don't even try to use "c_r"... *** These options are unsupported *** But all gdb backtraces are welcome :-) AFAIK, apache works well, but mod_php4 (worker MPM) behavior is quite funny. All modules which use apr mutexes may crash with KSE. Since I'm working on it, if you have coredumps, feel free to send me the backtrace (you must compile libkse, apache and modules with debugging symbols). Don't forget to set kern.sugid_coredump to 1. (using CoreDumpDirectory in httpd.conf can help too)
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/Makefile.modules3
2 files changed, 5 insertions, 0 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 2acca795e91f..c919f4092518 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -111,6 +111,8 @@ BROKEN= "apr is installed and may conflict with apache one\
. endif
.endif
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+
.include "${APACHEDIR}/Makefile.doc"
.include "${APACHEDIR}/Makefile.modules"
diff --git a/www/apache2/Makefile.modules b/www/apache2/Makefile.modules
index 59eba703fe77..d172ac3e8175 100644
--- a/www/apache2/Makefile.modules
+++ b/www/apache2/Makefile.modules
@@ -172,6 +172,9 @@ _APACHE_MODULES+= ${LDAP_MODULES}
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
CFLAGS+= -DFREEBSD_THREAD_HACK
+. if defined(WITH_EXPERIMENTAL_THREADS)
+CONFIGURE_ARGS+= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS}
+. endif
. if !defined(WITH_CUSTOM_THREADS)
_APACHE_MODULES+= ${THREAD_MODULES}
. else