aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache2
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-06-07 22:56:53 +0800
committerclement <clement@FreeBSD.org>2004-06-07 22:56:53 +0800
commitd23013f25bb89d68e2ebfc0ea8372d8e96a8c063 (patch)
treed53363a4234c26fc018bd9c49616de814c644d2a /www/apache2
parentcbe40423b7d9e9a1fc6eac77cc2ddc7b5bead3b0 (diff)
downloadfreebsd-ports-gnome-d23013f25bb89d68e2ebfc0ea8372d8e96a8c063.tar.gz
freebsd-ports-gnome-d23013f25bb89d68e2ebfc0ea8372d8e96a8c063.tar.zst
freebsd-ports-gnome-d23013f25bb89d68e2ebfc0ea8372d8e96a8c063.zip
- change limits from user www to daemon class to be in sync with
apachectl - fix limits (missing eval)
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/files/apache.sh7
-rw-r--r--www/apache2/pkg-message2
3 files changed, 6 insertions, 5 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 844c2dd78400..54c9a1b8f766 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -65,7 +65,7 @@ CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" \
LOCALBASE="${LOCALBASE}"
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} WWWOWN=${WWWOWN}
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAKE_ENV+= DESTDIR=${DESTDIR} EXPR_COMPAT=yes
diff --git a/www/apache2/files/apache.sh b/www/apache2/files/apache.sh
index 0ed476f53974..15f20ae0d5d8 100644
--- a/www/apache2/files/apache.sh
+++ b/www/apache2/files/apache.sh
@@ -20,7 +20,7 @@
# just before apache starts.
# apache2_flags (str): Set to "" by default.
# Extra flags passed to start command
-# apache2limits_args (str): Default to "-e -U %%WWWOWN%%"
+# apache2limits_args (str): Default to "-e -C daemon"
# Arguments of pre-start limits run.
#
. %%RC_SUBR%%
@@ -36,7 +36,7 @@ required_files=%%PREFIX%%/etc/apache2/httpd.conf
[ -z "$apache2ssl_enable" ] && apache2ssl_enable="NO"
[ -z "$apache2_flags" ] && apache2_flags=""
[ -z "$apache2limits_enable" ] && apache2limits_enable="NO"
-[ -z "$apache2limits_args" ] && apache2limits_args="-e -U %%WWWOWN%%"
+[ -z "$apache2limits_args" ] && apache2limits_args="-e -C daemon"
load_rc_config $name
@@ -44,8 +44,9 @@ checkyesno apache2ssl_enable && \
apache2_flags="-DSSL $apache2_flags"
checkyesno apache2limits_enable && \
- start_precmd="`/usr/bin/limits ${apache2limits_args}`"
+ start_precmd="eval `/usr/bin/limits ${apache2limits_args}` 2>/dev/null"
sig_reload=SIGUSR1
+extra_commands="reload"
run_rc_command "$1"
diff --git a/www/apache2/pkg-message b/www/apache2/pkg-message
index dab739d8b825..589e430f4ec0 100644
--- a/www/apache2/pkg-message
+++ b/www/apache2/pkg-message
@@ -14,6 +14,6 @@ Available variables you add/set to /etc/rc.conf.
just before apache starts.
- apache2_flags (str): Set to "" by default.
Extra flags passed to start command.
-- apache2limits_args (str): Default to "-e -U %%WWWOWN%%"
+- apache2limits_args (str): Default to "-e -C daemon"
Arguments of pre-start limits run.