aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache2
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-10-16 22:45:40 +0800
committerclement <clement@FreeBSD.org>2004-10-16 22:45:40 +0800
commitd7263a5a5634b5d5d7c01fc9b9ac62e25cd4391e (patch)
tree1e2e59d173f466ca368d1f1ec2979a72e060d146 /www/apache2
parent763d5694f4e331d83494f499bb5d2d907a7af658 (diff)
downloadfreebsd-ports-gnome-d7263a5a5634b5d5d7c01fc9b9ac62e25cd4391e.tar.gz
freebsd-ports-gnome-d7263a5a5634b5d5d7c01fc9b9ac62e25cd4391e.tar.zst
freebsd-ports-gnome-d7263a5a5634b5d5d7c01fc9b9ac62e25cd4391e.zip
- Remove WITH_APR_FROM_PORTS knob
- Add a note to UPDATING, to warn users they won't be able to build apache2 if they keep apr 0.9.x Discussed with: Craig Rodrigues (apr maintainer), kuriyama
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile21
-rw-r--r--www/apache2/pkg-plist152
2 files changed, 78 insertions, 95 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 5a3dde87d761..ab6256cf320c 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -126,25 +126,8 @@ CONFIGURE_ARGS+= --with-ldap \
.include <bsd.port.pre.mk>
-# Untested and may fail !
-.if defined(WITH_APR_FROM_PORTS)
-. if defined (WITH_BDB) || defined(WITH_BERKELEYDB)
-IGNORE= "You can't set WITH_BDB or WITH_BERKELEYDB when WITH_APR_FROM_PORTS is defined"
-. endif
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr
-CONFIGURE_ARGS+= --with-apr=${LOCALBASE}/bin/apr-1-config \
- --with-apr-util=${LOCALBASE}/bin/apu-1-config
-CONFIGURE_ENV+= LTFLAGS="--tag=CXX"
-PLIST_SUB+= PORTS_APR="@comment "
-.else
-. if exists(${LOCALBASE}/lib/libapr-1.so)
-IGNORE= apr is installed and may conflict with apache one\
- (if you want to use apr port define WITH_APR_FROM_PORTS,\
- at your own risk)
-. endif
-PLIST_SUB+= PORTS_APR=""
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/apache2
+.if exists(${LOCALBASE}/lib/libapr-0.so) || defined(WITH_APR_FROM_PORTS)
+IGNORE= : apr from ports (WITH_APR_FROM_PORTS) is no longer supported
.endif
WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//:S/-//}
diff --git a/www/apache2/pkg-plist b/www/apache2/pkg-plist
index 01d56cd36110..b662d4185fdc 100644
--- a/www/apache2/pkg-plist
+++ b/www/apache2/pkg-plist
@@ -14,7 +14,7 @@ etc/apache2/mime.types-dist
@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
etc/apache2/ssl-std.conf
@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
-%%PORTS_APR%%etc/rc.d/000.apache2libs.sh
+etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
include/apache2/ap_config.h
@@ -26,68 +26,68 @@ include/apache2/ap_mpm.h
include/apache2/ap_provider.h
include/apache2/ap_regkey.h
include/apache2/ap_release.h
-%%PORTS_APR%%include/apache2/apr.h
-%%PORTS_APR%%include/apache2/apr_allocator.h
-%%PORTS_APR%%include/apache2/apr_anylock.h
-%%PORTS_APR%%include/apache2/apr_atomic.h
-%%PORTS_APR%%include/apache2/apr_base64.h
-%%PORTS_APR%%include/apache2/apr_buckets.h
-%%PORTS_APR%%include/apache2/apr_compat.h
-%%PORTS_APR%%include/apache2/apr_date.h
-%%PORTS_APR%%include/apache2/apr_dbm.h
-%%PORTS_APR%%include/apache2/apr_dso.h
-%%PORTS_APR%%include/apache2/apr_env.h
-%%PORTS_APR%%include/apache2/apr_errno.h
-%%PORTS_APR%%include/apache2/apr_file_info.h
-%%PORTS_APR%%include/apache2/apr_file_io.h
-%%PORTS_APR%%include/apache2/apr_fnmatch.h
-%%PORTS_APR%%include/apache2/apr_general.h
-%%PORTS_APR%%include/apache2/apr_getopt.h
-%%PORTS_APR%%include/apache2/apr_global_mutex.h
-%%PORTS_APR%%include/apache2/apr_hash.h
-%%PORTS_APR%%include/apache2/apr_hooks.h
-%%PORTS_APR%%include/apache2/apr_inherit.h
-%%PORTS_APR%%include/apache2/apr_ldap.h
-%%PORTS_APR%%include/apache2/apr_ldap_url.h
-%%PORTS_APR%%include/apache2/apr_lib.h
-%%PORTS_APR%%include/apache2/apr_md4.h
-%%PORTS_APR%%include/apache2/apr_md5.h
-%%PORTS_APR%%include/apache2/apr_mmap.h
-%%PORTS_APR%%include/apache2/apr_network_io.h
-%%PORTS_APR%%include/apache2/apr_optional.h
-%%PORTS_APR%%include/apache2/apr_optional_hooks.h
-%%PORTS_APR%%include/apache2/apr_poll.h
-%%PORTS_APR%%include/apache2/apr_pools.h
-%%PORTS_APR%%include/apache2/apr_portable.h
-%%PORTS_APR%%include/apache2/apr_proc_mutex.h
-%%PORTS_APR%%include/apache2/apr_queue.h
-%%PORTS_APR%%include/apache2/apr_reslist.h
-%%PORTS_APR%%include/apache2/apr_ring.h
-%%PORTS_APR%%include/apache2/apr_rmm.h
-%%PORTS_APR%%include/apache2/apr_sdbm.h
-%%PORTS_APR%%include/apache2/apr_sha1.h
-%%PORTS_APR%%include/apache2/apr_shm.h
-%%PORTS_APR%%include/apache2/apr_signal.h
-%%PORTS_APR%%include/apache2/apr_strings.h
-%%PORTS_APR%%include/apache2/apr_strmatch.h
-%%PORTS_APR%%include/apache2/apr_support.h
-%%PORTS_APR%%include/apache2/apr_tables.h
-%%PORTS_APR%%include/apache2/apr_thread_cond.h
-%%PORTS_APR%%include/apache2/apr_thread_mutex.h
-%%PORTS_APR%%include/apache2/apr_thread_proc.h
-%%PORTS_APR%%include/apache2/apr_thread_rwlock.h
-%%PORTS_APR%%include/apache2/apr_time.h
-%%PORTS_APR%%include/apache2/apr_uri.h
-%%PORTS_APR%%include/apache2/apr_user.h
-%%PORTS_APR%%include/apache2/apr_uuid.h
-%%PORTS_APR%%include/apache2/apr_version.h
-%%PORTS_APR%%include/apache2/apr_want.h
-%%PORTS_APR%%include/apache2/apr_xlate.h
-%%PORTS_APR%%include/apache2/apr_xml.h
-%%PORTS_APR%%include/apache2/apu.h
-%%PORTS_APR%%include/apache2/apu_compat.h
-%%PORTS_APR%%include/apache2/apu_version.h
-%%PORTS_APR%%include/apache2/apu_want.h
+include/apache2/apr.h
+include/apache2/apr_allocator.h
+include/apache2/apr_anylock.h
+include/apache2/apr_atomic.h
+include/apache2/apr_base64.h
+include/apache2/apr_buckets.h
+include/apache2/apr_compat.h
+include/apache2/apr_date.h
+include/apache2/apr_dbm.h
+include/apache2/apr_dso.h
+include/apache2/apr_env.h
+include/apache2/apr_errno.h
+include/apache2/apr_file_info.h
+include/apache2/apr_file_io.h
+include/apache2/apr_fnmatch.h
+include/apache2/apr_general.h
+include/apache2/apr_getopt.h
+include/apache2/apr_global_mutex.h
+include/apache2/apr_hash.h
+include/apache2/apr_hooks.h
+include/apache2/apr_inherit.h
+include/apache2/apr_ldap.h
+include/apache2/apr_ldap_url.h
+include/apache2/apr_lib.h
+include/apache2/apr_md4.h
+include/apache2/apr_md5.h
+include/apache2/apr_mmap.h
+include/apache2/apr_network_io.h
+include/apache2/apr_optional.h
+include/apache2/apr_optional_hooks.h
+include/apache2/apr_poll.h
+include/apache2/apr_pools.h
+include/apache2/apr_portable.h
+include/apache2/apr_proc_mutex.h
+include/apache2/apr_queue.h
+include/apache2/apr_reslist.h
+include/apache2/apr_ring.h
+include/apache2/apr_rmm.h
+include/apache2/apr_sdbm.h
+include/apache2/apr_sha1.h
+include/apache2/apr_shm.h
+include/apache2/apr_signal.h
+include/apache2/apr_strings.h
+include/apache2/apr_strmatch.h
+include/apache2/apr_support.h
+include/apache2/apr_tables.h
+include/apache2/apr_thread_cond.h
+include/apache2/apr_thread_mutex.h
+include/apache2/apr_thread_proc.h
+include/apache2/apr_thread_rwlock.h
+include/apache2/apr_time.h
+include/apache2/apr_uri.h
+include/apache2/apr_user.h
+include/apache2/apr_uuid.h
+include/apache2/apr_version.h
+include/apache2/apr_want.h
+include/apache2/apr_xlate.h
+include/apache2/apr_xml.h
+include/apache2/apu.h
+include/apache2/apu_compat.h
+include/apache2/apu_version.h
+include/apache2/apu_want.h
%%WORKER%%include/apache2/fdqueue.h
%%THREADPOOL%%include/apache2/pod.h
include/apache2/http_config.h
@@ -131,16 +131,16 @@ include/apache2/util_md5.h
include/apache2/util_script.h
include/apache2/util_time.h
include/apache2/util_xml.h
-%%PORTS_APR%%lib/apache2/apr-config
-%%PORTS_APR%%lib/apache2/apr.exp
-%%PORTS_APR%%lib/apache2/aprutil.exp
-%%PORTS_APR%%lib/apache2/apu-config
-%%PORTS_APR%%lib/apache2/libapr-0.a
-%%PORTS_APR%%lib/apache2/libapr-0.so
-%%PORTS_APR%%lib/apache2/libapr-0.so.9
-%%PORTS_APR%%lib/apache2/libaprutil-0.a
-%%PORTS_APR%%lib/apache2/libaprutil-0.so
-%%PORTS_APR%%lib/apache2/libaprutil-0.so.9
+lib/apache2/apr-config
+lib/apache2/apr.exp
+lib/apache2/aprutil.exp
+lib/apache2/apu-config
+lib/apache2/libapr-0.a
+lib/apache2/libapr-0.so
+lib/apache2/libapr-0.so.9
+lib/apache2/libaprutil-0.a
+lib/apache2/libaprutil-0.so
+lib/apache2/libaprutil-0.so.9
libexec/apache2/httpd.exp
%%MOD_ACCESS%%libexec/apache2/mod_access.so
%%MOD_ACTIONS%%libexec/apache2/mod_actions.so
@@ -212,12 +212,12 @@ sbin/httpd
sbin/logresolve
sbin/rotatelogs
%%MOD_SUEXEC%%sbin/suexec
-%%PORTS_APR%%share/apache2/build/apr_rules.mk
+share/apache2/build/apr_rules.mk
share/apache2/build/config_vars.mk
share/apache2/build/config.nice
share/apache2/build/instdso.sh
share/apache2/build/library.mk
-%%PORTS_APR%%share/apache2/build/libtool
+share/apache2/build/libtool
share/apache2/build/ltlib.mk
share/apache2/build/program.mk
share/apache2/build/rules.mk
@@ -522,7 +522,7 @@ share/apache2/build/special.mk
@dirrm share/apache2/build
@dirrm share/apache2
@unexec rmdir %D/libexec/apache2 2> /dev/null || true
-%%PORTS_APR%%@dirrm lib/apache2
+@dirrm lib/apache2
@dirrm include/apache2
@exec mkdir -p %D/etc/apache2/Includes 2> /dev/null || true
@unexec rmdir %D/etc/apache2/Includes 2> /dev/null || true