aboutsummaryrefslogtreecommitdiffstats
path: root/www/aria/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /www/aria/Makefile
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'www/aria/Makefile')
-rw-r--r--www/aria/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/aria/Makefile b/www/aria/Makefile
index d25de8169349..514611233893 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -16,12 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.t/test/}
MAINTAINER= nakai@FreeBSD.org
COMMENT= Yet another download tool
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not build"
-.endif
-
USE_BZIP2= yes
USE_GNOME= gtk12
USE_OPENSSL= yes
@@ -31,6 +25,12 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g; \
s|-lssl|-lcrypto -lssl|g; \