aboutsummaryrefslogtreecommitdiffstats
path: root/www/aria2
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-09 12:42:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-09 12:42:20 +0800
commitb266d71d833f96ce508294112abdad340988910c (patch)
tree2ba8bcbf71b619c505cda9acd16b2e81ddb62922 /www/aria2
parenta5ef21f3bf025d621fc49ba5aeabbfe9c2ceaea3 (diff)
downloadfreebsd-ports-gnome-b266d71d833f96ce508294112abdad340988910c.tar.gz
freebsd-ports-gnome-b266d71d833f96ce508294112abdad340988910c.tar.zst
freebsd-ports-gnome-b266d71d833f96ce508294112abdad340988910c.zip
- Sort CONFIGURE_ARGS
- Do not USE_GETTEXT when WITHOUT_NLS is set - Fix PLIST - Use USE_SQLITE - Use DOCSDIR - Cosmetic change - Take maintainership Submitted by: sunpoet (myself) Approved by: miwi (maintainer, via IRC)
Diffstat (limited to 'www/aria2')
-rw-r--r--www/aria2/Makefile92
1 files changed, 47 insertions, 45 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index d2964b2589c1..26bc974853cc 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -10,59 +10,68 @@ PORTVERSION= 1.15.1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
-MAINTAINER= miwi@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Yet another download tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --with-libxml2 \
- --without-gnutls --with-openssl \
- --without-libcares --with-libz --enable-bittorrent \
- --enable-metalink --disable-epoll --enable-threads=pth
+CONFIGURE_ARGS= --enable-bittorrent --disable-epoll --enable-metalink --enable-threads=pth \
+ --with-libz --with-libxml2 --with-openssl \
+ --without-gnutls --without-libcares
CONFIGURE_ENV= OPENSSL_CFLAGS=-I${OPENSSLINC} OPENSSL_LIBS="-L${OPENSSLLIB} -lssl" \
ZLIB_CFLAGS=-I${INCLUDEDIR} ZLIB_LIBS="-L${LIBDIR} -lz"
-
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack libxml2
-USE_GETTEXT= yes
-GNU_CONFIGURE= yes
USE_OPENSSL= yes
-MAKE_JOBS_SAFE= yes
-.ifdef WITHOUT_NLS
-CONFIGURE_ARGS+= --disable-nls
-.else
-LANGS= ar bg ca da de el en@boldquot en@quot es fi fr he hu id it ko ja \
- nl nn pl pt pt_BR ru sk sr sv th tr uk vi zh_CN zh_TW
-.endif
+MAN1= aria2c.1
+MANLANG= "" ru
+PLIST_FILES= bin/aria2c
-PLIST_FILES= bin/aria2c \
- ${LANGS:S|^|share/locale/|:S|$|/LC_MESSAGES/aria2.mo|} \
- share/doc/aria2/README \
- share/doc/aria2/README.html \
- share/doc/aria2/README.rst \
- share/doc/aria2/aria2c.1.html \
- share/doc/aria2/aria2c.1.asciidoc \
- share/doc/aria2/README.asciidoc \
- share/doc/aria2/bash_completion/README.txt \
- share/doc/aria2/bash_completion/aria2c \
- share/doc/aria2/xmlrpc/aria2mon \
- share/doc/aria2/xmlrpc/aria2rpc \
- share/doc/aria2/xmlrpc/README.txt \
- share/doc/aria2/ru/aria2c.1.html \
- share/doc/aria2/ru/aria2c.1.asciidoc
+OPTIONS_DEFINE= NLS SQLITE
+OPTIONS_DEFAULT=NLS SQLITE
-PLIST_DIRS= share/doc/aria2/bash_completion \
- share/doc/aria2/xmlrpc \
- share/doc/aria2/ru \
- share/doc/aria2
+.include <bsd.port.options.mk>
-MANLANG= "" ru
-MAN1= aria2c.1
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_FILES+= %%DOCSDIR%%/README \
+ %%DOCSDIR%%/README.html \
+ %%DOCSDIR%%/README.rst \
+ %%DOCSDIR%%/bash_completion/README.txt \
+ %%DOCSDIR%%/bash_completion/aria2c \
+ %%DOCSDIR%%/xmlrpc/README.txt \
+ %%DOCSDIR%%/xmlrpc/aria2mon \
+ %%DOCSDIR%%/xmlrpc/aria2rpc
+PLIST_DIRS= %%DOCSDIR%%/xmlrpc \
+ %%DOCSDIR%%/bash_completion \
+ %%DOCSDIR%%
+.endif
-OPTIONS_DEFINE= SQLITE
-OPTIONS_DEFAULT= SQLITE
+.if ${PORT_OPTIONS:MNLS}
+CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
+USE_GETTEXT= yes
+LANGS= ar bg ca da de el en@boldquot en@quot es fi fr he hu id it ja \
+ ko nl nn pl pt pt_BR ru sk sr sv th tr uk vi zh_CN zh_TW
+PLIST_FILES+= ${LANGS:S|^|share/locale/|:S|$|/LC_MESSAGES/aria2.mo|}
+.else
+CONFIGURE_ARGS+=--disable-nls
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+CONFIGURE_ARGS+=--with-sqlite3
+USE_SQLITE= yes
+.else
+CONFIGURE_ARGS+=--without-sqlite3
+.endif
+
+post-patch:
+.if ${PORT_OPTIONS:MDOCS}
+.else
+ @${REINPLACE_CMD} -e 's|\(install-exec-am\) install-data-am|\1|' ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
+.endif
.include <bsd.port.pre.mk>
@@ -70,11 +79,4 @@ OPTIONS_DEFAULT= SQLITE
BROKEN= Does not install on powerpc-9
.endif
-.if ${PORT_OPTIONS:MSQLITE}
-CONFIGURE_ARGS+= --with-sqlite3
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
-.else
-CONFIGURE_ARGS+= --without-sqlite3
-.endif
-
.include <bsd.port.post.mk>