aboutsummaryrefslogtreecommitdiffstats
path: root/www/asterisk-stat/Makefile
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2007-10-03 02:51:44 +0800
committerlwhsu <lwhsu@FreeBSD.org>2007-10-03 02:51:44 +0800
commit84c3c17860e030994c48ec5249116cfde1b080bf (patch)
tree74553e32c9d2b674c06ca52aad7ea12cdf1cf70b /www/asterisk-stat/Makefile
parentc305f9531aa70c29858d85a14730aac0ddb2e2a3 (diff)
downloadfreebsd-ports-gnome-84c3c17860e030994c48ec5249116cfde1b080bf.tar.gz
freebsd-ports-gnome-84c3c17860e030994c48ec5249116cfde1b080bf.tar.zst
freebsd-ports-gnome-84c3c17860e030994c48ec5249116cfde1b080bf.zip
- Change maintainer's email
- Remove dependence on apache - Mark BROKEN on ${OSVERSION} >= 700000 only when using mysql - Use ${COPYTREE_SHARE}, ${INSTALL_DATA} to replace ${CP} -r - Use explicit pkg-plist - Tweak pgsql cdr template - Bump PORTREVISION Approved by: maintainer Pointed out by: sat Suggested by: dougb, pav, rafan, danfe
Diffstat (limited to 'www/asterisk-stat/Makefile')
-rw-r--r--www/asterisk-stat/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/www/asterisk-stat/Makefile b/www/asterisk-stat/Makefile
index 42b54b828dcb..31e2a83bd3b0 100644
--- a/www/asterisk-stat/Makefile
+++ b/www/asterisk-stat/Makefile
@@ -7,17 +7,17 @@
PORTNAME= asterisk-stat
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.areski.net/${SITE_SUBDIR}/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}
-MAINTAINER= jfkimura@yahoo.com
+MAINTAINER= jfkimura@yahoo.co.jp
COMMENT= ASTERISK Call Detail Records Analizer
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
NO_BUILD= yes
-USE_APACHE= yes
USE_PHP= session gd pcre
WANT_PHP_WEB= yes
ASTERISKDIR?= ${WWWDIR}
@@ -30,21 +30,21 @@ OPTIONS= PGSQL "Use PostgreSQL instead of MySQL" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-BROKEN= Depends on net/asterisk-addons which does not build on 7-CURRENT
-.endif
-
.if defined(WITH_PGSQL)
ASTERISKSTATDB= pgsql
.else
+. if ${OSVERSION} >= 700000
+BROKEN= Depends on net/asterisk-addons which does not build on 7-CURRENT
+. endif
ASTERISKSTATDB= mysql
-# net/asterisk-addons
RUN_DEPENDS+= ${LOCALBASE}/lib/asterisk/modules/cdr_addon_mysql.so:${PORTSDIR}/net/asterisk-addons
.endif
USE_PHP+= ${ASTERISKSTATDB}
EXTRA_PATCHES+= ${FILESDIR}/${ASTERISKSTATDB}__patch-cdr.php \
${FILESDIR}/${ASTERISKSTATDB}__patch-defines.php
+PLIST_SUB+= ASTERISKDIR=${ASTERISKDIR:S,^${PREFIX}/,,} \
+ ASTERISKSTATDB=${ASTERISKSTATDB}
post-patch:
@${MV} ${WRKSRC}/images/print.css ${WRKSRC}/css
@@ -58,16 +58,9 @@ post-patch:
do-install:
@${MKDIR} ${ASTERISKDIR}
@${MV} ${WRKSRC}/lib/defines.php ${WRKSRC}/lib/defines.php-dist
- ${CP} -r ${WRKSRC}/ ${ASTERISKDIR}
- ${CP} ${FILESDIR}/cdr_${ASTERISKSTATDB}.tbl ${PREFIX}/etc/asterisk
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} \* ${ASTERISKDIR})
+ ${MKDIR} ${PREFIX}/etc/asterisk
+ ${INSTALL_DATA} ${FILESDIR}/cdr_${ASTERISKSTATDB}.tbl ${PREFIX}/etc/asterisk
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${ASTERISKDIR}
-post-install:
- @${FIND} ${WRKSRC}/${file} -not -type d \
- | ${SED} -ne 's,^${WRKSRC},${ASTERISKDIR:S,^${TARGETDIR}/,,},p' >> ${TMPPLIST}
- @${FIND} -d ${WRKSRC}/${file} -type d \
- | ${SED} -ne 's,^${WRKSRC},@dirrm ${ASTERISKDIR:S,^${TARGETDIR}/,,},p' >> ${TMPPLIST}
- @${ECHO} etc/asterisk/cdr_${ASTERISKSTATDB}.tbl >> ${TMPPLIST}
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>