aboutsummaryrefslogtreecommitdiffstats
path: root/www/august/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-10-19 10:02:20 +0800
committertrevor <trevor@FreeBSD.org>2003-10-19 10:02:20 +0800
commita3a61d7bc15d4d05b8f0a601285c0ba5ea90d33c (patch)
treee4704b0d362a4a64c361722e1fe910a2d4fbb50e /www/august/Makefile
parentffeccbe68515c11ebf80de5f86e632960241a6f7 (diff)
downloadfreebsd-ports-gnome-a3a61d7bc15d4d05b8f0a601285c0ba5ea90d33c.tar.gz
freebsd-ports-gnome-a3a61d7bc15d4d05b8f0a601285c0ba5ea90d33c.tar.zst
freebsd-ports-gnome-a3a61d7bc15d4d05b8f0a601285c0ba5ea90d33c.zip
Use Tk 8.4 rather than 8.3 (requested by kris). Avoid using Perl.
Diffstat (limited to 'www/august/Makefile')
-rw-r--r--www/august/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/august/Makefile b/www/august/Makefile
index 52f6e6d2dac5..9ec139797629 100644
--- a/www/august/Makefile
+++ b/www/august/Makefile
@@ -9,6 +9,7 @@
PORTNAME= august
PORTVERSION= 0.63b
+PORTREVISION= 1
CATEGORIES= www editors
MASTER_SITES= http://www.bostream.nu/johanb/august/ \
http://www.lls.se/~johanb/august/
@@ -19,14 +20,15 @@ COMMENT= HTML editor for the experienced Web author
RUN_DEPENDS= weblint:${PORTSDIR}/www/weblint \
identify:${PORTSDIR}/graphics/ImageMagick \
- wish8.3:${PORTSDIR}/x11-toolkits/tk83
+ wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
PLIST= ${WRKDIR}/pkg-plist
do-patch:
- ${PERL} -pi -e "s:/usr/bin/wish:${PREFIX}/bin/wish8.3:g" \
- ${WRKSRC}/august
+ ${MV} ${WRKSRC}/august ${WRKSRC}/august.orig
+ ${SED} -e "s:/usr/bin/wish:${PREFIX}/bin/wish8.4:g" \
+ < ${WRKSRC}/august.orig > ${WRKSRC}/august
pre-install:
${ECHO_CMD} bin/august > ${PLIST}