aboutsummaryrefslogtreecommitdiffstats
path: root/www/auth_ldap
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2001-09-28 16:59:50 +0800
committernik <nik@FreeBSD.org>2001-09-28 16:59:50 +0800
commitd170576f2edf708e8e772761431c36ec40a8e581 (patch)
tree86c21c2ce8528302cb2bc2a7ebc9a52f49a01005 /www/auth_ldap
parentaff6c6dd09de13052e215f678de787368c039f10 (diff)
downloadfreebsd-ports-gnome-d170576f2edf708e8e772761431c36ec40a8e581.tar.gz
freebsd-ports-gnome-d170576f2edf708e8e772761431c36ec40a8e581.tar.zst
freebsd-ports-gnome-d170576f2edf708e8e772761431c36ec40a8e581.zip
Add auth_ldap, an Apache module that can authenticate against an LDAP
directory.
Diffstat (limited to 'www/auth_ldap')
-rw-r--r--www/auth_ldap/Makefile33
-rw-r--r--www/auth_ldap/distinfo1
-rw-r--r--www/auth_ldap/pkg-comment1
-rw-r--r--www/auth_ldap/pkg-descr6
-rw-r--r--www/auth_ldap/pkg-plist3
5 files changed, 44 insertions, 0 deletions
diff --git a/www/auth_ldap/Makefile b/www/auth_ldap/Makefile
new file mode 100644
index 000000000000..943c980fe507
--- /dev/null
+++ b/www/auth_ldap/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: auth_ldap
+# Date created: 25 September 2001
+# Whom: nik
+#
+# $FreeBSD$
+#
+
+PORTNAME= auth_ldap
+PORTVERSION= 1.6.0
+CATEGORIES= www
+MASTER_SITES= http://www.rudedog.org/auth_ldap/
+
+MAINTAINER= nik
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= lber.2:${PORTSDIR}/net/openldap2
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-sdk-headers=${LOCALBASE}/include \
+ --with-sdk-libs=${LOCALBASE}/lib \
+ --with-ldap-sdk=openldap
+
+USE_GMAKE= yes
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+MAKE_ARGS+= APXS=${APXS}
+
+do-install:
+ ${APXS} -i -A -n ldap ${WRKSRC}/auth_ldap.so
+
+.include <bsd.port.mk>
diff --git a/www/auth_ldap/distinfo b/www/auth_ldap/distinfo
new file mode 100644
index 000000000000..322be7a6bdb2
--- /dev/null
+++ b/www/auth_ldap/distinfo
@@ -0,0 +1 @@
+MD5 (auth_ldap-1.6.0.tar.gz) = ff7de9027fe8852facd27be93462c5cc
diff --git a/www/auth_ldap/pkg-comment b/www/auth_ldap/pkg-comment
new file mode 100644
index 000000000000..0ca571c64f94
--- /dev/null
+++ b/www/auth_ldap/pkg-comment
@@ -0,0 +1 @@
+Apache module to authenticate against an LDAP directory.
diff --git a/www/auth_ldap/pkg-descr b/www/auth_ldap/pkg-descr
new file mode 100644
index 000000000000..48d08c89910e
--- /dev/null
+++ b/www/auth_ldap/pkg-descr
@@ -0,0 +1,6 @@
+This module allows Apache to authenticate a location against an
+entry, or entries, in an LDAP database.
+
+WWW: http://www.rudedog.org/auth_ldap/
+
+- Nik Clayton <nik@FreeBSD.org>
diff --git a/www/auth_ldap/pkg-plist b/www/auth_ldap/pkg-plist
new file mode 100644
index 000000000000..3d6d61273ccd
--- /dev/null
+++ b/www/auth_ldap/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/auth_ldap.so
+@exec %D/sbin/apxs -e -A -n ldap %D/%F
+@unexec %D/sbin/apxs -e -A -n ldap %D/%F