aboutsummaryrefslogtreecommitdiffstats
path: root/www/autoindex/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-06 21:20:11 +0800
committergarga <garga@FreeBSD.org>2005-10-06 21:20:11 +0800
commit0fd43f3673873098a0d074d77df57d85b85f94f7 (patch)
tree6ffd5650ce23464e138c94cba9e35822fba5349e /www/autoindex/Makefile
parentb3b75ba82fe2862398b3f55060e839d710babb12 (diff)
downloadfreebsd-ports-gnome-0fd43f3673873098a0d074d77df57d85b85f94f7.tar.gz
freebsd-ports-gnome-0fd43f3673873098a0d074d77df57d85b85f94f7.tar.zst
freebsd-ports-gnome-0fd43f3673873098a0d074d77df57d85b85f94f7.zip
- Update to 1.5.4
PR: ports/86983 Submitted by: maintainer
Diffstat (limited to 'www/autoindex/Makefile')
-rw-r--r--www/autoindex/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/www/autoindex/Makefile b/www/autoindex/Makefile
index 4c5adcc9e123..d7acfd9c0929 100644
--- a/www/autoindex/Makefile
+++ b/www/autoindex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AutoIndex
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= autoindex
@@ -19,26 +19,24 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
BROKEN_WITH_PHP= 5
USE_PHP= yes
CONFLICTS= AutoIndex-2*
-
NO_BUILD= yes
+PLIST_SUB+= INSTALLDIR=${INSTALLDIR}
+
+pre-fetch:
+.if !defined(INSTALLDIR)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Define INSTALLDIR to override default of 'www/data/${PORTNAME}'."
+ @${ECHO_MSG} ""
+.endif
+
+INSTALLDIR?= www/data/${PORTNAME}
+
do-install:
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/index_icons
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/index_icons/apache
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/index_icons/kde
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/index_icons/osx
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/index_icons/winxp
- @${MKDIR} ${PREFIX}/www/data/${PORTNAME}/languages
- ${INSTALL_DATA} ${WRKSRC}/.htpasswd.autoindex ${PREFIX}/www/data/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/*.php ${PREFIX}/www/data/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/www/data/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/stylesheet.css ${PREFIX}/www/data/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/index_icons/apache/* ${PREFIX}/www/data/${PORTNAME}/index_icons/apache
- ${INSTALL_DATA} ${WRKSRC}/index_icons/kde/* ${PREFIX}/www/data/${PORTNAME}/index_icons/kde
- ${INSTALL_DATA} ${WRKSRC}/index_icons/osx/* ${PREFIX}/www/data/${PORTNAME}/index_icons/osx
- ${INSTALL_DATA} ${WRKSRC}/index_icons/winxp/* ${PREFIX}/www/data/${PORTNAME}/index_icons/winxp
- ${INSTALL_DATA} ${WRKSRC}/languages/* ${PREFIX}/www/data/${PORTNAME}/languages
+ @${MKDIR} ${PREFIX}/${INSTALLDIR}
+ @${CP} -Rp ${WRKSRC}/* ${PREFIX}/${INSTALLDIR}
+ @${CP} -p ${WRKSRC}/.htpasswd.autoindex ${PREFIX}/${INSTALLDIR}/.htpasswd.autoindex-dist
+ @${CHMOD} 666 ${PREFIX}/${INSTALLDIR}/config.php
@${ECHO_CMD} ""
post-install: