aboutsummaryrefslogtreecommitdiffstats
path: root/www/awstats-devel
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-26 08:30:46 +0800
committermnag <mnag@FreeBSD.org>2005-10-26 08:30:46 +0800
commite9543082dafb6f572436e0232dc39c943b51201b (patch)
tree0afc017189f98159bcb8b57efa914e802e120c5a /www/awstats-devel
parent2d484e56bc6c84cec97698c9d15b332f675c9abd (diff)
downloadfreebsd-ports-gnome-e9543082dafb6f572436e0232dc39c943b51201b.tar.gz
freebsd-ports-gnome-e9543082dafb6f572436e0232dc39c943b51201b.tar.zst
freebsd-ports-gnome-e9543082dafb6f572436e0232dc39c943b51201b.zip
Respect PREFIX
PR: 86481 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> Approved by: webmaster@lightningfire.net (maintainer timeout, 32 days)
Diffstat (limited to 'www/awstats-devel')
-rw-r--r--www/awstats-devel/Makefile22
-rw-r--r--www/awstats-devel/files/patch-tools-awstats_buildstaticpages.pl13
-rw-r--r--www/awstats-devel/files/patch-tools-awstats_configure.pl17
-rw-r--r--www/awstats-devel/files/patch-tools-awstats_updateall.pl13
-rw-r--r--www/awstats-devel/files/patch-wwwroot-cgi-bin-awstats.pl11
-rw-r--r--www/awstats-devel/files/pkg-message.in (renamed from www/awstats-devel/pkg-message)10
6 files changed, 74 insertions, 12 deletions
diff --git a/www/awstats-devel/Makefile b/www/awstats-devel/Makefile
index 39b7dbeaed6a..99a5cda3ada2 100644
--- a/www/awstats-devel/Makefile
+++ b/www/awstats-devel/Makefile
@@ -20,6 +20,21 @@ RUN_DEPENDS= ${SITE_PERL}/Net/XWhois.pm:${PORTSDIR}/net/p5-Net-XWhois
NO_BUILD= yes
USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+post-patch:
+# ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/tools/awstats_buildstaticpages.pl
+# ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/tools/awstats_configure.pl
+# ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/tools/awstats_updateall.pl
+# ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/wwwroot/cgi-bin/awstats.pl
do-install:
@${MKDIR} ${PREFIX}/www/awstats
@@ -86,7 +101,6 @@ do-install:
@${ECHO_CMD} "* Rename ${PREFIX}/www/awstats/cgi-bin/awstats.model.conf to awstats.site.conf to setup awstats"
@${ECHO_CMD} "* Documentation has been installed in ${PREFIX}/share/doc/awstats"
@${ECHO_CMD} ""
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
@@ -98,10 +112,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-.endif
-
.include <bsd.port.post.mk>
diff --git a/www/awstats-devel/files/patch-tools-awstats_buildstaticpages.pl b/www/awstats-devel/files/patch-tools-awstats_buildstaticpages.pl
new file mode 100644
index 000000000000..434520700291
--- /dev/null
+++ b/www/awstats-devel/files/patch-tools-awstats_buildstaticpages.pl
@@ -0,0 +1,13 @@
+--- tools/awstats_buildstaticpages.pl.orig Sun Feb 20 11:11:06 2005
++++ tools/awstats_buildstaticpages.pl Thu Sep 22 20:33:32 2005
+@@ -293,8 +293,8 @@
+ # Check if AWSTATS prog is found
+ my $AwstatsFound=0;
+ if (-s "$Awstats") { $AwstatsFound=1; }
+-elsif (-s "/usr/local/awstats/wwwroot/cgi-bin/awstats.pl") {
+- $Awstats="/usr/local/awstats/wwwroot/cgi-bin/awstats.pl";
++elsif (-s "%%PREFIX%%/www/awstats/cgi-bin/awstats.pl") {
++ $Awstats="%%PREFIX%%/www/awstats/cgi-bin/awstats.pl";
+ $AwstatsFound=1;
+ }
+ if (! $AwstatsFound) {
diff --git a/www/awstats-devel/files/patch-tools-awstats_configure.pl b/www/awstats-devel/files/patch-tools-awstats_configure.pl
new file mode 100644
index 000000000000..e9240f4531c4
--- /dev/null
+++ b/www/awstats-devel/files/patch-tools-awstats_configure.pl
@@ -0,0 +1,17 @@
+--- tools/awstats_configure.pl.orig Sat Jan 15 17:42:58 2005
++++ tools/awstats_configure.pl Thu Sep 22 20:34:07 2005
+@@ -29,10 +29,10 @@
+ $AWSTATS_DIRDATA_PATH
+ /;
+ $AWSTATS_PATH='';
+-$AWSTATS_ICON_PATH='/usr/local/awstats/wwwroot/icon';
+-$AWSTATS_CSS_PATH='/usr/local/awstats/wwwroot/css';
+-$AWSTATS_CLASSES_PATH='/usr/local/awstats/wwwroot/classes';
+-$AWSTATS_CGI_PATH='/usr/local/awstats/wwwroot/cgi-bin';
++$AWSTATS_ICON_PATH='%%PREFIX%%/www/awstats/icon';
++$AWSTATS_CSS_PATH='%%PREFIX%%/www/awstats/css';
++$AWSTATS_CLASSES_PATH='%%PREFIX%%/www/awstats/classes';
++$AWSTATS_CGI_PATH='%%PREFIX%%/www/awstats/cgi-bin';
+ $AWSTATS_MODEL_CONFIG='/etc/awstats/awstats.model.conf'; # Used only when configure ran on linux
+ $AWSTATS_DIRDATA_PATH='/var/lib/awstats'; # Used only when configure ran on linux
+
diff --git a/www/awstats-devel/files/patch-tools-awstats_updateall.pl b/www/awstats-devel/files/patch-tools-awstats_updateall.pl
new file mode 100644
index 000000000000..21d9d6d3cb54
--- /dev/null
+++ b/www/awstats-devel/files/patch-tools-awstats_updateall.pl
@@ -0,0 +1,13 @@
+--- tools/awstats_updateall.pl.orig Mon Jun 7 08:27:26 2004
++++ tools/awstats_updateall.pl Thu Sep 22 01:30:15 2005
+@@ -121,8 +121,8 @@
+ # Check if AWSTATS prog is found
+ my $AwstatsFound=0;
+ if (-s "$Awstats") { $AwstatsFound=1; }
+- elsif (-s "/usr/local/awstats/wwwroot/cgi-bin/awstats.pl") {
+- $Awstats="/usr/local/awstats/wwwroot/cgi-bin/awstats.pl";
++ elsif (-s "%%PREFIX%%/www/awstats/cgi-bin/awstats.pl") {
++ $Awstats="%%PREFIX%%/www/awstats/cgi-bin/awstats.pl";
+ $AwstatsFound=1;
+ }
+ if (! $AwstatsFound) {
diff --git a/www/awstats-devel/files/patch-wwwroot-cgi-bin-awstats.pl b/www/awstats-devel/files/patch-wwwroot-cgi-bin-awstats.pl
new file mode 100644
index 000000000000..8e1c95ad7e97
--- /dev/null
+++ b/www/awstats-devel/files/patch-wwwroot-cgi-bin-awstats.pl
@@ -0,0 +1,11 @@
+--- wwwroot/cgi-bin/awstats.pl.orig Thu Feb 24 16:02:23 2005
++++ wwwroot/cgi-bin/awstats.pl Thu Sep 22 20:33:18 2005
+@@ -1835,7 +1835,7 @@
+ # Windows and standard package: "$DIR/plugins" (plugins in same dir than awstats.pl)
+ # Redhat : "/usr/local/awstats/wwwroot/cgi-bin/plugins"
+ # Debian package : "/usr/share/awstats/plugins"
+- my @PossiblePluginsDir=("$DIR/plugins","/usr/local/awstats/wwwroot/cgi-bin/plugins","/usr/share/awstats/plugins");
++ my @PossiblePluginsDir=("$DIR/plugins","%%PREFIX%%/www/awstats/cgi-bin/plugins","/usr/share/awstats/plugins");
+ my %DirAddedInINC=();
+
+ #Removed for security reason
diff --git a/www/awstats-devel/pkg-message b/www/awstats-devel/files/pkg-message.in
index 0729d1a863a9..5997bb49d373 100644
--- a/www/awstats-devel/pkg-message
+++ b/www/awstats-devel/files/pkg-message.in
@@ -4,15 +4,15 @@ Please add the following to your apache config, and restart.
#
# Directives to allow use of AWStats as a CGI
#
-Alias /awstatsclasses "/usr/local/www/awstats/classes/"
-Alias /awstatscss "/usr/local/www/awstats/css/"
-Alias /awstatsicons "/usr/local/www/awstats/icons/"
-ScriptAlias /awstats/ "/usr/local/www/awstats/cgi-bin/"
+Alias /awstatsclasses "%%PREFIX%%/www/awstats/classes/"
+Alias /awstatscss "%%PREFIX%%/www/awstats/css/"
+Alias /awstatsicons "%%PREFIX%%/www/awstats/icons/"
+ScriptAlias /awstats/ "%%PREFIX%%/www/awstats/cgi-bin/"
#
# This is to permit URL access to scripts/files in AWStats directory.
#
-<Directory "/usr/local/www/awstats/">
+<Directory "%%PREFIX%%/www/awstats/">
Options None
AllowOverride None
Order allow,deny
+0800'>2001-07-111-1/+2 * Added <application> tagsKevin Breit2001-07-105-7/+15 * EditingKevin Breit2001-07-106-39/+52 * Validation.Aaron Weber2001-07-092-6/+8 * Mention UNMATCHEDKevin Breit2001-07-093-3/+24 * Spell checkKevin Breit2001-07-072-10/+12 * Spell checkKevin Breit2001-07-073-54/+58 * Added orderedlists.Kevin Breit2001-07-062-21/+84 * Added orderedlists.Kevin Breit2001-07-062-94/+132 * Added orderedlists.Kevin Breit2001-07-062-394/+484 * Chris pointed out an error in the DB versioning question.Aaron Weber2001-07-061-2/+1 * Put in lots of orderedlists...more SGML, less for the user to read.Kevin Breit2001-07-043-366/+650 * Updated slightly.Jeffrey Stedfast2001-07-033-85/+164 * Created its own file.Kevin Breit2001-07-037-406/+353 * Pulled organizing stuff, made its own file.Kevin Breit2001-07-018-1415/+1409 * Added evolution-alarm-notify.Federico Mena Quintero2001-07-011-1/+2 * Revised move/rename/copy questions, now that these functions work.Aaron Weber2001-06-272-35/+13 * Now that bug-buddy works with our bugzilla, update faq to reflect it.Aaron Weber2001-06-262-23/+26 * Put config-encryption in usage-mail.sgml. config-encryption.sgml should beKevin Breit2001-06-264-3/+153 * Elaborated on the mailing listsKevin Breit2001-06-262-0/+9 * Added info about mailing listsKevin Breit2001-06-262-115/+100 * Here too.Peter Williams2001-06-262-4/+6 * ... and comment out more exec summary stuff.Peter Williams2001-06-262-6/+10 * Fix make dist.Peter Williams2001-06-264-6/+13 * Fixed a few typosKevin Breit2001-06-252-2/+4 * Added section for importing filesKevin Breit2001-06-252-2/+63 * Removed some *'s that are causing problems.Kevin Breit2001-06-254-10/+12 * Sync - FedericoFederico Mena Quintero2001-06-259-169/+348 * Put in Contacts information in the quicktasks.Kevin Breit2001-06-232-18/+72 * Pulled some redundant information.Kevin Breit2001-06-222-9/+65 * Updated screenshots and redid layout for graphics on pages.battery8412001-06-226-28/+100 * disable executive summary build because it is no longer builtJP Rosevear2001-06-222-1/+6 * add new libJP Rosevear2001-06-222-1/+6 * Fixed .gif problemKevin Breit2001-06-224-12/+13 * Specify the file formatKevin Breit2001-06-222-2/+7 * Trying to fix the .gif problemKevin Breit2001-06-222-11/+20 * Redid graphics to add labels to them and described the labels in text.Kevin Breit2001-06-224-0/+40 * calendar/cal-client/Makefile.am: calendar/cal-util/Makefile.am:Peter Williams2001-06-226-428/+785 * Added config-encryption.sgml for buildingKevin Breit2001-06-223-0/+150 * Updated graphics for newer UI.Kevin Breit2001-06-2212-0/+4 * Redid graphics to add labels to them and described in labels in text.Kevin Breit2001-06-2210-20/+108 * Added fileKevin Breit2001-06-212-9/+160 * Moved my entires to doc/ChangeLog per request of danwKevin Breit2001-06-212-24/+57 * Updated for new UI.Kevin Breit2001-06-211-30/+18 * Updated for a newer UI (need to update at a later date.Kevin Breit2001-06-211-52/+34 * Make less monotone soundingKevin Breit2001-06-212-7/+5 * Added more postscript descriptionKevin Breit2001-06-211-3/+3 * Reworded a little bit for more descrip.Kevin Breit2001-06-211-2/+3 * Documented categorizing an event.Kevin Breit2001-06-211-2/+37 * Updated Bcc: exampleKevin Breit2001-06-201-1/+3 * Took out a reference to gloss.Kevin Breit2001-06-201-0/+10 * Made it build.Kevin Breit2001-06-201-1/+1 * Checked for validity.Aaron Weber2001-06-201-1/+7 * A couple changes to Kevin's update. Mostly just checking over.Aaron Weber2001-06-202-25/+26 * Basic editsKevin Breit2001-06-201-36/+42 * Updated to say "My Evolution"Kevin Breit2001-06-201-16/+12 * Added definition.Kevin Breit2001-06-201-73/+52 * Commented out DTD which shouldn't be thereKevin Breit2001-06-191-2/+2 * added *-undocumented.txt to .cvsignoreDamon Chaplin2001-06-142-0/+2 * added *-undocumented.txtDamon Chaplin2001-06-143-0/+7 * fixed a typo pointed out by Greg Leblanc. s/listen/listed/Duncan Mak2001-06-082-1/+5 * removed duplicate "If mozilla can..." question.Aaron Weber2001-06-071-17/+0 * Note that I think I may have CVS Tag problems at least with the changelog.Aaron Weber2001-06-076-79/+109 * added questions about KDE, redid other questions.Aaron Weber2001-06-021-444/+516 * s/Helix Code/XimianFederico Mena Quintero2001-05-252-2/+6 * Untabify.Ettore Perazzoli2001-05-231-732/+732 * Add Emacs-like local variable settings to disable `indent-tabs-mode'.Ettore Perazzoli2001-05-231-1/+5 * More (minor) indentation fixes.Ettore Perazzoli2001-05-231-7/+7 * Re-indented the FAQ document.Ettore Perazzoli2001-05-232-438/+425 * Added evolution-faq as an entity.Aaron Weber2001-05-223-537/+598 * doc/C/evolution.sgml - Pulled my name from copyright listKevin Breit2001-05-221-1/+0 * Updated to ignore more built files.Ettore Perazzoli2001-05-201-6/+8 * Added a lot of new content. Fixed old content. Validated. Still need toAaron Weber2001-05-194-600/+265 * Added two questions about importing Outlook (text from Iain). Fixed someDuncan Mak2001-05-192-2/+76 * Added a question about the need for write permissions onEttore Perazzoli2001-05-181-0/+5 * Added a question about the need for write permissions onEttore Perazzoli2001-05-181-0/+21 * Return the serialized EDestinations (rather than just a string w/ e-mailJon Trowbridge2001-05-184-54/+52 * Fixed Grammar, edited a few answers, did the vfolder thing.Aaron Weber2001-05-171-22/+30 * Get the User guide and the Evolution FAQ to be installed into separateEttore Perazzoli2001-05-162-6/+25 * Evolution users worldwide, rejoice! We have a FAQ. (Yes, it stillEttore Perazzoli2001-05-162-6/+762 * yea...Jeffrey Stedfast2001-05-161-0/+3 * I've said it before and I'll say it again... man am I a dumb schmuckJeffrey Stedfast2001-05-161-0/+536 * yes, I am a dumbassJeffrey Stedfast2001-05-161-0/+791 * oops, I guess this file does belong hereJeffrey Stedfast2001-05-161-0/+301 * updated .cvsignoreJeffrey Stedfast2001-05-162-0/+3 * Removed some evolution-*-decl.txt files since these are autogenerated byJeffrey Stedfast2001-05-166-1/+29 * added file for ScrollkeeperKevin Breit2001-05-151-0/+14 * ShushJP Rosevear2001-05-084-7/+13 * UpdateKjartan Maraas2001-04-261-0/+1 * Update this a bitKjartan Maraas2001-04-261-6/+6 * Removed generated files from CVS, updated .cvsignore files to includeJon Trowbridge2001-04-2619-1698/+141 * Changed dependency for install-data-local from "evolution" toJon Trowbridge2001-04-242-1/+6 * Port builddir != srcdir patch from the evolution-0-10-branch.Ettore Perazzoli2001-04-246-7/+20 * Re-commit ChangeLog.Ettore Perazzoli2001-04-241-2/+0 * Documentation building fixes merged from the evolution-0-10-branch:Ettore Perazzoli2001-04-245-18/+34 * changed path to the importer header files, since we've had reports thatDamon Chaplin2001-04-212-3/+9 * Fixed typoHector Garcia2001-04-201-18/+19 * Fixed bug that prevented new translationsHector Garcia2001-04-201-2/+11 * Updated Spanish TranslationHector Garcia2001-04-2016-233/+404 * s/helixcode/ximian (How I missed this page on the first go-round I don'tAaron Weber2001-04-184-19/+24 * Pull up fix from the branch:Ettore Perazzoli2001-04-185-7/+15 * Updated Spanish translation.Hector Garcia2001-03-222-2/+281 * Updated Spanish TranslationHector Garcia2001-03-161-1/+64 * Removed .oafinfo files -- they are obsolete. Moved pixmaps fromGediminas Paulauskas2001-03-151-0/+2 * create doc/devel/executive-summary/MakefileGediminas Paulauskas2001-03-152-2/+5 * Deleting some files that should not have been added in the first placeHector Garcia2001-03-142-59/+0 * Adding files to help translating evolution guide using a .po wayHector Garcia2001-03-1439-0/+19852 * IMAP subscriptions stuff.Aaron Weber2001-02-232-1/+35 * Advanced search/show all/save search stuff.Aaron Weber2001-02-225-14/+61 * Validated. Verified. Markup fixed in several individual files.Aaron Weber2001-02-165-883/+16 * Added summary of services, with summary service summaries.Aaron Weber2001-02-143-115/+174 * Overhaul. Now accurate and truthful and clear.Aaron Weber2001-02-106-58/+136 * Minor Changes.Aaron Weber2001-02-097-108/+168 * s/contact manager/address book/ and revised text.Aaron Weber2001-02-085-47/+69 * Final docs.Iain Holmes2001-02-023-2/+18 * More docs...Iain Holmes2001-02-027-51/+76 * Wheeee pretty documentationIain Holmes2001-02-0214-0/+1097 * Change (nonexistant) importer.sgml references to evolution-importer.sgmlJohn R. Sheets2001-01-282-12/+17 * Doc updates - FedericoFederico Mena Quintero2001-01-203-228/+228 * create a new cal component alarm (cal_component_add_alarm): add alarm toJP Rosevear2001-01-193-230/+245 * More of Megan's revisions, and Field Chooser functions in the SortAaron Weber2001-01-196-242/+290 * Um, why was the doc directory removed from SUBDIRS?Federico Mena Quintero2001-01-191-18/+18 * Use "typedef enum { ... } Blah;" instead of "typedef enum _Blah Blah; enumFederico Mena Quintero2001-01-184-51/+46 * Some API documentation for the importerIain Holmes2001-01-1816-2/+465 * Ximianified.Federico Mena Quintero2001-01-1713-290/+376 * remove old config messageJP Rosevear2001-01-151-82/+82 * pass -module and -avoid-version to conduit linkerJP Rosevear2001-01-144-168/+144 * Make it work when gtk-doc is not installed.Federico Mena Quintero2001-01-116-0/+91 * More Makefile organization to compileMiguel de Icaza2001-01-1010-121/+71 * Added calendar/gui/alarm-notify/Makefile.Federico Mena Quintero2001-01-102-83/+93 * Remove non-existent fileJP Rosevear2001-01-052-92/+91 * Unconditionally remove the client from the alarm notification system.Federico Mena Quintero2001-01-033-136/+136 * Remove deleted fileJP Rosevear2000-12-234-137/+136 * Alarm trigger queueing for the GUI part.Federico Mena Quintero2000-12-232-11/+11 * Added proper dependency lists to the gtk-doc mess.Federico Mena Quintero2000-12-2016-562/+875 * Alarm instance generation support for the Wombat.Federico Mena Quintero2000-12-195-0/+69 * Revisions as suggested by Dan. Especially to filter dialogs... which stillAaron Weber2000-12-154-125/+189 * make it public-reference.sgml not referenc.sgml here.Larry Ewing2000-12-142-1/+6 * upd.Michael Meeks2000-12-101-1/+5 * upd.Michael Meeks2000-12-051-0/+33 * return NULL if we can't create a view.Michael Meeks2000-12-051-0/+28 * Finished the calendar architecture chapter.Federico Mena Quintero2000-11-302-3/+76 * added some <glossterms>, added linkends to existing glossterms.Aaron Weber2000-11-3010-107/+342 * Added an id for the API reference <part>. Added the FDL <legalnotice>.Federico Mena Quintero2000-11-3011-87/+963 * Fixed validation errors.Aaron Weber2000-11-028-217/+610 * added composer keybindings descriptionRadek Doulik2000-11-022-0/+13 * Add Keybindings, please populateMiguel de Icaza2000-11-021-0/+4 * Actions -> New Directory Server added.Aaron Weber2000-10-265-11/+111 * Re-checked validity of all files. Made minor changes to menuref.sgml,Aaron Weber2000-10-129-67/+99 * Re-took most screenshots; last batch had wrong Sawfish theme.Aaron Weber2000-10-1112-76/+174 * Described Search features.Aaron Weber2000-10-059-180/+410 * Spellcheck. Fixed some wording, and responded to clahey's suggestions--Aaron Weber2000-10-0411-391/+503 * Switched to the "official" FSF markup. I will have to make changes to theAaron Weber2000-09-226-795/+649 * Fixed sig stuff here and in setupassist.Aaron Weber2000-09-205-35/+46 * Fixed to install the stylesheet-images as well.Federico Mena Quintero2000-09-204-7/+22 * Made the toplevel <book> id be "index".Federico Mena Quintero2000-09-162-1/+6 * The Commit from hell that breaks all UI related stuff;Michael Meeks2000-09-141-7/+0 * contact-editor.png, mail-composer.png, filter-assist-fig.png,Aaron Weber2000-09-084-0/+0 * Redid "soft" intro stuff, worked on mail a little. minor commit.Aaron Weber2000-09-082-19/+21 * Accidentally broke docs, now valid.Aaron Weber2000-09-087-188/+298 * Grammar, links, screenshots.Aaron Weber2000-09-067-0/+0 * Added coverage of news, clarified POP/IMAP distinction (there's a theme toAaron Weber2000-09-024-47/+136 * Added regular expressions to glossary. Explanation should be removed fromAaron Weber2000-08-316-223/+262 * Added "quickref and pointers" sections. Props to O'Reilly for the copy ofAaron Weber2000-08-315-58/+326 * Redid filter and vFolder assistant descriptions.Aaron Weber2000-08-25