aboutsummaryrefslogtreecommitdiffstats
path: root/www/axis/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-04-30 19:23:23 +0800
committerlawrance <lawrance@FreeBSD.org>2006-04-30 19:23:23 +0800
commit18adcbc0b1b09381125a84b210919b0afa3362be (patch)
treebc8ba5e11fe6d8d6e9c99a7eb6f2dc574b91c4f5 /www/axis/Makefile
parentb4cb71059f0f40b15b6e4bef12c41902ed987f9b (diff)
downloadfreebsd-ports-gnome-18adcbc0b1b09381125a84b210919b0afa3362be.tar.gz
freebsd-ports-gnome-18adcbc0b1b09381125a84b210919b0afa3362be.tar.zst
freebsd-ports-gnome-18adcbc0b1b09381125a84b210919b0afa3362be.zip
Install jar library files into ${JAVAJARDIR}, instead of into the JDK's
home directory. This is as directed by PH "Best Practices" for Java libraries. It also fixes the build of jboss4 (due to library pollution) when axis is installed. PR: ports/92781 Submitted by: Alex Kiesel Approved by: rui@ruilopes.com (maintainer, timeout 10 weeks)
Diffstat (limited to 'www/axis/Makefile')
-rw-r--r--www/axis/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/www/axis/Makefile b/www/axis/Makefile
index c96b5b094a49..ec7e7b22cf6f 100644
--- a/www/axis/Makefile
+++ b/www/axis/Makefile
@@ -43,22 +43,12 @@ USER= www
GROUP= www
.include <bsd.port.pre.mk>
-#
-# Change install directory by JDK version
-#
-.if defined(JAVA_PORT_VERSION) && (${JAVA_PORT_VERSION} == "1.4.1")
-LIB_SUBDIR= endorsed
-.else
-LIB_SUBDIR= ext
-.endif
-JAR_INSTALL_DEST_DIR= ${JAVA_HOME}/jre/lib/${LIB_SUBDIR}
#
# Install procedure
#
-SYSTEM_JARS= jaxrpc.jar saaj.jar
-PLIST_SUB= PREFIX=${PREFIX} WEBAPPS=${WEBAPPDIR} JRE_HOME="${JAVA_HOME}/jre" \
- LIB_SUBDIR=${LIB_SUBDIR} USER=${USER} GROUP=${GROUP}
+SYSTEM_JARS= axis.jar jaxrpc.jar saaj.jar
+PLIST_SUB+= PREFIX=${PREFIX} WEBAPPS=${WEBAPPDIR} USER=${USER} GROUP=${GROUP}
.if !defined(NOPORTDOCS)
SAMPLECLASSES=''
@@ -67,9 +57,9 @@ SAMPLECLASSES=classes
.endif
do-install:
- ${MKDIR} ${JAR_INSTALL_DEST_DIR}
.for i in ${SYSTEM_JARS}
- ${INSTALL_DATA} ${WRKSRC}/lib/${i} ${JAR_INSTALL_DEST_DIR}
+ ${MKDIR} ${JAVAJARDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${i} ${JAVAJARDIR}/${PORTNAME}
.endfor
(cd ${WRKSRC}/webapps ; tar cf - --exclude "${SAMPLECLASSES}" axis) | (cd ${WEBAPPDIR} ; tar xvf -)
${CHOWN} -R ${USER}:${GROUP} ${WEBAPPDIR}/axis