aboutsummaryrefslogtreecommitdiffstats
path: root/www/bacon
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-09-09 22:55:08 +0800
committertaoka <taoka@FreeBSD.org>1999-09-09 22:55:08 +0800
commitef0e9d9b198c6def75a54dc9e4aa71cb7fc668dd (patch)
treedc1051f7d251cc2d1cfeb5a83c3461d42c6ab459 /www/bacon
parent42f5d4006457a174e13d6ca9dd0fe09f00ef8644 (diff)
downloadfreebsd-ports-gnome-ef0e9d9b198c6def75a54dc9e4aa71cb7fc668dd.tar.gz
freebsd-ports-gnome-ef0e9d9b198c6def75a54dc9e4aa71cb7fc668dd.tar.zst
freebsd-ports-gnome-ef0e9d9b198c6def75a54dc9e4aa71cb7fc668dd.zip
Quick, easy-to-read, web statistics program
PR: 12708 Submitted by: Justin Robinson <jmrobins@samurai.ruin.org>
Diffstat (limited to 'www/bacon')
-rw-r--r--www/bacon/Makefile32
-rw-r--r--www/bacon/distinfo1
-rw-r--r--www/bacon/pkg-comment1
-rw-r--r--www/bacon/pkg-descr8
-rw-r--r--www/bacon/pkg-message6
-rw-r--r--www/bacon/pkg-plist3
6 files changed, 51 insertions, 0 deletions
diff --git a/www/bacon/Makefile b/www/bacon/Makefile
new file mode 100644
index 000000000000..3285562968d1
--- /dev/null
+++ b/www/bacon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bacon
+# Version required: 1.1b
+# Date created: 9 September 1999
+# Whom: Justin Robinson <jmrobins@samurai.ruin.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= bacon-1.071999
+CATEGORIES= www
+MASTER_SITES= ftp://samurai.ruin.org/pub/All/
+
+MAINTAINER= jmrobins@samurai.ruin.org
+
+USE_PERL5= YES
+
+DIST= bacon.pl
+
+do-build:
+ @cd ${WRKSRC}; ${MV} ${DIST} ${DIST}.orig; \
+ ${SED} -e 's;^#! */usr/local/bin/perl *;#!${PERL5};' \
+ ${DIST}.orig > ${DIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bacon.pl ${PREFIX}/www/cgi-bin/bacon.pl
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/doc/bacon/
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/bacon/INSTALL
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/www/bacon/distinfo b/www/bacon/distinfo
new file mode 100644
index 000000000000..3f0f286ba9bc
--- /dev/null
+++ b/www/bacon/distinfo
@@ -0,0 +1 @@
+MD5 (bacon-1.071999.tar.gz) = 50dfc8301d9b789c02665b83e9c4d192
diff --git a/www/bacon/pkg-comment b/www/bacon/pkg-comment
new file mode 100644
index 000000000000..c99e4afbaf91
--- /dev/null
+++ b/www/bacon/pkg-comment
@@ -0,0 +1 @@
+Quick, easy-to-read, web statistics program
diff --git a/www/bacon/pkg-descr b/www/bacon/pkg-descr
new file mode 100644
index 000000000000..eea5f5606504
--- /dev/null
+++ b/www/bacon/pkg-descr
@@ -0,0 +1,8 @@
+Bacon is a perl program designed to make viewing and reading weblogs easy.
+It has support for multiple virtual hosts and lets you know who has been
+to your webpage.
+
+WWW: http://bacon.ruin.org/
+
+-Justin Robinson
+jmrobins@samurai.ruin.org
diff --git a/www/bacon/pkg-message b/www/bacon/pkg-message
new file mode 100644
index 000000000000..a70497e1ef83
--- /dev/null
+++ b/www/bacon/pkg-message
@@ -0,0 +1,6 @@
+
+---------------------------------------------------------------------
+Please read the ${PREFIX}/share/doc/bacon/INSTALL file for info on
+configuring this program."
+---------------------------------------------------------------------
+
diff --git a/www/bacon/pkg-plist b/www/bacon/pkg-plist
new file mode 100644
index 000000000000..74eddef3a63e
--- /dev/null
+++ b/www/bacon/pkg-plist
@@ -0,0 +1,3 @@
+www/cgi-bin/bacon.pl
+share/doc/bacon/INSTALL
+@dirrm share/doc/bacon
ng also forgerald2003-05-061-1/+1 * G++ headers are now installed in c++/<gcc_ver> rather than g++-v3.obrien2003-05-061-1/+1 * Upgrade to the 28-April-2003 GCC 3.3 in-development snapshot.obrien2003-05-042-6/+6 * Upgrade to the 21-April-2003 GCC 3.3 in-development snapshot.obrien2003-04-282-6/+6 * Merge targets pre-configure and pre-build, simplify them, and removegerald2003-04-262-20/+2 * Make MAINTAINER overrideable by slave ports.gerald2003-04-251-1/+1 * Fifty-one months after ELF flag day, and after the system compiler becamegerald2003-04-243-96/+0 * Further fixes to pkg-plist. (Tested according to Porter's Handbook 2.4 ongerald2003-04-231-3/+1 * Allow YACC to be used, rather than Bison, for C/C++.obrien2003-04-231-0/+29 * merge changes from gcc32 to gcc33 after testingdinoex2003-04-212-7/+36 * Not sure how I missed these patches in my 24-March-2003 GCC 3.3obrien2003-04-212-90/+10 * Remove files/patch-t-freebsd. The underlying problem has been fixed ingerald2003-04-171-10/+0 * Remove the last part of jdp's profile fixes from 1998/10/08, which actuallygerald2003-04-151-11/+0 * Appease portlint by various whitespace changes. Remove last traces ofgerald2003-04-061-12/+8 * Finally remove the parts of this patch that date back to 1998 and have nowgerald2003-04-031-24/+0 * Remove special alpha optimization warning. alpha support now should begerald2003-04-021-20/+0 * LATEST_LINK can now be overwritten by the slave port.dinoex2003-03-311-1/+1 * Upgrade to the 24-March-2003 GCC 3.3 in-development snapshot.obrien2003-03-303-18/+60 * Fix COMMENT and a Makefile comment.gerald2003-03-251-2/+2 * De-pkg-comment.knu2003-02-212-1/+1 * Use the most modern spelling of egcs.cygnus.com.obrien2002-12-041-1/+1 * The effort to maintain these for FreeBSD just isn't worth it with the lackobrien2002-11-051-1/+1 * Use MASTER_SITES_GCC.knu2002-10-201-3/+2 * Upgrade to the 14-Oct-2002 GCC 3.3 in-development snapshot.obrien2002-10-182-9/+9 * Upgrade to a 7-Oct-2002 GCC 3.3 in-development checkout.obrien2002-10-115-146/+165 * ftp://ftp.netwinder.org/ is no longer a MASTER_SITE.gerald2002-07-311-1/+0 * This is now in the stock FSF sources.obrien2002-05-191-64/+0 * Upgrade to a 18-May-2002 GCC 3.2 in-development checkout.obrien2002-05-181-15/+15 * GCC 2.95 and later aren't called egcs (any longer). Also updategerald2002-04-172-13/+3 * GCC 2.95 and later aren't called egcs (any longer), so remove two patchesgerald2002-04-122-23/+0 * Upgrade to a 06-April-2002 GCC 3.2 in-development checkout.obrien2002-04-072-30/+30 * Upgrade to a 27-March-2002 GCC 3.2 in-development checkout.obrien2002-03-292-24/+28 * Upgrade to a 12-March-2002 GCC 3.2 in-development checkout.obrien2002-03-131-2/+2 * Upgrade to the 10-March-2002 GCC 3.2 in-development snapshot.obrien2002-03-132-41/+46 * Mark broken while I find a suitable snapshot.obrien2002-03-101-0/+1 * Sync with gcc30's style.obrien2002-03-053-85/+39 * Upgrade to the 25-Feb-2002 GCC 3.1 development snapshot.obrien2002-03-033-28/+10 * Update to the 2002-02-04 snapshot.obrien2002-02-102-6/+6 * This allows the port to build, but it still has install problems.obrien2002-02-051-2/+5 * Upgrade to the 28-Jan-2002 GCC 3.1 development snapshot.obrien2002-02-0311-297/+202 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-291-7/+7 * Style police: WWW tags should either end in a file/script or TRAILING /; Fix ...lioux2001-11-211-1/+1 * Utilize the PATCH_WRKDIR knob now that it exists.obrien2001-10-281-4/+1 * Major overhall and style clean up.obrien2001-08-161-27/+17 * Upgrade to the 30-April-2001 edition GCC 2.97 development snapshot.obrien2001-05-043-14/+29 * Upgrade to the 20-March-2001 edition GCC 2.97 development snapshot.obrien2001-03-242-6/+6 * Fix version number.obrien2001-03-111-1/+1 * Upgrade to the 5-March-2001 edition GCC 2.97 development snapshot.obrien2001-03-072-6/+6 * Fix nits in the auto lib-gcc PLIST generation.obrien2001-03-022-26/+14 * Upgrade to the 5-Feb-2001 edition GCC 2.97 development snapshot.obrien2001-02-154-130/+157 * typo clean up police: \s -> \tlioux2001-02-151-1/+1 * Upgrade to the Christmas edition GCC 2.97 development snapshot.obrien2000-12-272-6/+6 * Upgrade to the 2000-12-18 GCC 2.97 development snapshot.obrien2000-12-222-33/+29 * Forgot to commit the bits that rm's the new libjava as it breaks theobrien2000-12-141-0/+1 * Upgrade to the 2000-12-11 GCC 2.97 development snapshot.obrien2000-12-133-35/+42 * Change name of programs from e<program_name> to g<program_name>, sinceobrien2000-12-062-18/+17 * Change the libstdc++.so version number to be more like the stock one.obrien2000-12-061-1/+1 * First cut at configure support for FreeBSD PowerPC, Sparc64, and StrongARM.obrien2000-11-291-0/+64 * Upgrade to the 2000-11-20 GCC 2.97 development snapshot.obrien2000-11-299-277/+86 * Upgrade to the 2000-10-02 GCC 2.97 development snapshot.obrien2000-10-117-623/+173 * Upgrade to the 2000-08-28 GCC 2.96 development snapshot.obrien2000-09-163-69/+89 * Upgrade to the 2000-07-17 GCC 2.96 development snapshot.obrien2000-09-0610-370/+156 * Upgrade to the 2000-05-01 GCC 2.96 development snapshot.obrien2000-05-073-9/+8 * Upgrade to the 2000-04-10 GCC 2.96 development snapshot.obrien2000-04-152-6/+6 * Convert to the PORTNAME - PORTVERSION syntax.obrien2000-04-121-3/+2 * Restore useless version required comments.obrien2000-03-221-0/+1 * Remove the "version required" line.obrien2000-03-201-1/+0 * Upgrade to the 2000-03-13 GCC 2.96 development snapshot.obrien2000-03-193-27/+27 * Upgrade to the 2000-03-06 GCC 2.96 development snapshot.obrien2000-03-093-7/+9 * Upgrade to the 2000-02-21 GCC 2.96 development snapshot.obrien2000-03-083-7/+7 * Upgrade to the 2000-02-07 GCC 2.96 development snapshot.obrien2000-02-147-85/+75 * Upgrade to the 2000-01-10 GCC 2.96 development snapshot.obrien2000-01-178-89/+84 * Update to the 1999-11-10 development snapshot.obrien1999-11-152-6/+6 * Update to the 1999-11-02 development snapshot.obrien1999-11-032-6/+6 * Update to the 1999-10-25 snapshot.obrien1999-11-013-13/+10 * Upgrade to the 1999-10-04 development snapshot.obrien1999-10-112-6/+6 * Upgrade to the 1999-09-20 development snapshot.obrien1999-10-116-76/+98 * $Id$ -> $FreeBSD$peter1999-08-301-1/+1 * Change Id->FreeBSD.obrien1999-08-251-1/+1 * Merge parts of the GCC-2.95 update, in preperation for the 1st post 2.95obrien1999-08-062-25/+29 * Fix SWITCH_TAKES_ARG / WORD_SWITCH_TAKES_ARG breakage on the Alpha createdobrien1999-07-252-20/+8 * Update to the 1999-07-18 beta snapshot of GCC-2.95.obrien1999-07-203-13/+13 * Upgrade to the July 12th GCC-2.95 prerelease.obrien1999-07-153-9/+9 * Upgrade to the 1999-06-29 pre-GCC-2.95 snapshot.obrien1999-07-062-11/+11 * Correct spelling in a comment.steve1999-07-051-2/+2 * The number of things this port installs has grown.obrien1999-07-051-1/+38 * Changes to work with updated files/freebsd.h.obrien1999-07-051-12/+29 * Minor reorg of the dealing with `autoconf' and `autoheader' stuff.obrien1999-07-051-5/+5 * Upgrade to the 19990623 GCC 2.95 pre-release snapshot.obrien1999-06-253-45/+17 * Update to the 19990616 GCC 2.95-prerelease.obrien1999-06-223-79/+46 * Update to the 1999-06-08 (gcc 2.95 prerelease).obrien1999-06-156-118/+82 * Fix for alpha.simokawa1999-06-102-7/+123 * Remove the test to create ${PREFIX}/share/info/dir as it is nowmharo1999-06-062-6/+2 * Upgrade to 19990524 gcc-2.95 prerelease.obrien1999-05-263-19/+17 * Fix "EGCS_REV".obrien1999-05-251-2/+6 * Upgrade to the 19990517 snapshot. EGCS is not in a feature freeze for theobrien1999-05-194-29/+25 * Sync up with some diffs I sent to Cygnus.obrien1999-04-223-15/+17 * this should finish cleaning up the WWW_SITE -> DESCR/WWW: mess ...scrappy1999-04-222-3/+3 * I give you the latest and greatest of the EGCS snapshot series.obrien1999-04-2114-146/+508 * Mark this FORBIDDEN while DavidO works on an upgrade after a repo copy.asami1999-04-131-1/+3 * Proper URLs that reference directories end in '/'billf1999-04-091-2/+2 * Don't fetch alpha suppliment -- the bits are now part of the port.obrien1999-03-301-4/+1 * Don't create empty ``PREFIX/info/dir''. It is already taken care of for us.obrien1999-03-241-2/+1 * * Add support for ``-pthead''obrien1999-03-226-32/+569 * Upgrade to 1.1.2 release.obrien1999-03-177-73/+122 * Commit all Y2K/WWW_SITE changes from today...scrappy1999-03-121-1/+3 * Fix to make ports work with bsd.port.mk rev. 1.306.asami1999-03-081-1/+2 * Support building libstdc++ shared if "WANT_SHAREDLIBS" is defined.obrien1999-02-281-1/+8 * Upgrade to egcs-1.1.2 pre-release-2obrien1999-02-282-12/+16 * * clean up verbosity of Makefileobrien1999-02-101-9/+4 * GNUHOST is now "i386-unknown-freebsd" for an ELF machine, andobrien1999-02-105-16/+78 * Adjust port Makefiles to new EXTRACT_* variable defaults. See log ofasami1999-02-031-6/+2 * Allow '$' in labels as our offical compiler does.obrien1999-01-232-10/+36 * Wasn't in the main dir when I commited this the first time.obrien1998-12-272-2/+10 * Build and install crtbegin.o crtbeginS.o crtend.o crtendS.o for the ELF case.obrien1998-12-261-0/+10 * Use the bzip2 version of the distfile. It saves almost 3meg.obrien1998-12-052-5/+11 * EGCS 1.1.1 *Release* is out.obrien1998-12-052-11/+13 * Add OSREL to tail end of ${ARCH}-unknown-freebsd to get a properly formedobrien1998-12-041-3/+3 * "upgrade" to EGCS egcs-1.1.1-prerelease-3.obrien1998-12-023-15/+11 * switch to new pre/post bsd.port.mkobrien1998-11-131-4/+7 * i386 => ${ARCH}obrien1998-11-131-4/+4 * Make profiling work.jdp1998-10-093-4/+132 * Allow building and packaging for ELF.obrien1998-10-021-8/+6 * Doesn't package due to PLUST_SUB/GNUHOST definition and bsd.port.mkasami1998-09-281-1/+3 * Build properly on ELF systems.obrien1998-09-271-1/+6 * make fetchableobrien1998-09-271-4/+4 * back to the snaps w/egcs-19980914obrien1998-09-273-9/+15 * Upgrade to 1.1b.obrien1998-09-102-7/+7 * my goof. fetch only egcs-1.1a.tar.gz, not the entire release/egcs-1.1aobrien1998-09-051-4/+4 * egcs 1.1 HAS BEEN RELEASED!!obrien1998-09-032-7/+8 * * upgrade to 19980816 snapshotobrien1998-08-263-193/+194 * The first time I tried committing this set of manpage removals it gothoek1998-08-191-5/+1 * Fix Version-required comment.jdp1998-08-121-2/+2 * Upgrade to the 19980803 snapshot.obrien1998-08-113-189/+187 * Make these ports (TenDRA, egcs, gcc28, glibstdc++28 and guavac, allasami1998-08-081-1/+3 * Upgrade to the 19980721 snap.obrien1998-07-273-185/+185 * Sync with gcc28 port:obrien1998-07-201-0/+32 * upgrade to the July 15th (19980715) snapshotobrien1998-07-163-188/+190 * Upgrade to the 19980628 snapshot.obrien1998-07-063-191/+191 * upgrade to 19980608 snapshotobrien1998-06-104-192/+190 * + Remove the MANUAL_PACKAGE_BUILD.obrien1998-05-202-161/+185 * Upgrade to 1998-05-08 snapshot version.obrien1998-05-203-43/+43 * Upgrade to the May 2nd 1998 snapshot version.obrien1998-05-053-65/+46 * Upgrade to 980406 snapshotobrien1998-04-145-76/+67 * Used to build for me, now doesn't. Bombs in making the stage2 compiler.obrien1998-04-111-1/+3 * Upgrade to the 980315 snapshot.obrien1998-04-075-54/+49 * Upgrade to version 1.0.2 release.obrien1998-04-075-51/+57 * Fix the "Version required" comment.jdp1998-03-181-2/+2 * The private copy of float.h seems to have gone away.obrien1998-03-102-2/+2 * Fix things so it packages.obrien1998-03-083-43/+43 * Master site changed.jdp1998-02-231-2/+2 * Just-cant-get-this-one-right by: obrienobrien1998-02-171-1/+12 * Forgot to submit PLIST diff.obrien1998-02-172-34/+31 * Mark this port broken, doesn't package.asami1998-02-161-1/+2 * Upgrade to 1998-02-05 SNAP. Fixes problems several have had with 1.0.1.obrien1998-02-144-26/+48 * Set __FreeBSD__ to 2, not 3.obrien1998-02-131-1/+1 * Add MANUAL_PACKAGE_BUILD, this port installs a "libstdc++.a" inasami1998-02-031-1/+3 * Make "-fsjlj-exceptions" (use setjmp/longjmp for exceptions) thejdp1998-01-242-2/+19 * Strip the binaries.obrien1998-01-141-1/+12 * sed -> ${SED}.asami1998-01-131-2/+2