aboutsummaryrefslogtreecommitdiffstats
path: root/www/bluefish-devel/Makefile
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-06 07:01:49 +0800
committerjgh <jgh@FreeBSD.org>2013-05-06 07:01:49 +0800
commit7d866449ab60b14b460d03dda69c44d3439a22e2 (patch)
tree9f0caaf6d3cd0e3ef1a5e86991943f71fc25913c /www/bluefish-devel/Makefile
parentce79cb1e5f440a46cd2d317fe8c77990d34f4666 (diff)
downloadfreebsd-ports-gnome-7d866449ab60b14b460d03dda69c44d3439a22e2.tar.gz
freebsd-ports-gnome-7d866449ab60b14b460d03dda69c44d3439a22e2.tar.zst
freebsd-ports-gnome-7d866449ab60b14b460d03dda69c44d3439a22e2.zip
- convert to USES=gettext
Approved by: portmgr (bapt@)
Diffstat (limited to 'www/bluefish-devel/Makefile')
-rw-r--r--www/bluefish-devel/Makefile50
1 files changed, 24 insertions, 26 deletions
diff --git a/www/bluefish-devel/Makefile b/www/bluefish-devel/Makefile
index 5f66f6805f63..946b78430ce6 100644
--- a/www/bluefish-devel/Makefile
+++ b/www/bluefish-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bluefish-devel
-# Date created: 2009-10-03
-# Whom: Sylvio Cesar Teixeira <sylvio@FreeBSD.org>
-#
+# Created by: Sylvio Cesar Teixeira <sylvio@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bluefish
PORTVERSION= 1.3.7
@@ -25,13 +21,6 @@ INSTALLS_ICONS= yes
DATADIR= share/${PORTNAME}-unstable
-.if !defined(WITHOUT_WEBLINT)
-RUN_DEPENDS+= weblint:${PORTSDIR}/www/weblint
-.endif
-.if defined(WITH_TIDY)
-RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
-.endif
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
@@ -45,6 +34,15 @@ CONFIGURE_ARGS= --with-freedesktop_org-menu=${PREFIX}/share/applications \
--without-gnome2_4-appreg \
--with-icon-path=${PREFIX}/share/pixmaps
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_WEBLINT)
+RUN_DEPENDS+= weblint:${PORTSDIR}/www/weblint
+.endif
+.if defined(WITH_TIDY)
+RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
+.endif
+
# Turns debugging output on
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --with-debugging-output
@@ -54,8 +52,22 @@ CONFIGURE_ARGS+= --with-debugging-output
CONFIGURE_ARGS+= --disable-splash-screen
.endif
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= bluefish-unstable.1
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mlibgnomeui}!=""
+USE_GNOME+= libgnomeui
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Bluefish has the following tunable option(s):"
@@ -71,18 +83,4 @@ pre-everything::
pre-install:
@${MKDIR} ${PREFIX}/share/mime
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mlibgnomeui}!=""
-USE_GNOME+= libgnomeui
-.endif
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
.include <bsd.port.post.mk>