aboutsummaryrefslogtreecommitdiffstats
path: root/www/bozohttpd
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-10-29 06:20:28 +0800
committerpgj <pgj@FreeBSD.org>2012-10-29 06:20:28 +0800
commitf92742d5cc04286ec4ffdc5dab4dde9187e58c26 (patch)
tree3c57e5adb7ec5400a7f8e2b96831fed9ef148bca /www/bozohttpd
parent66dc27bd42d85ead26a13e2782e6ff3e6b1004a7 (diff)
downloadfreebsd-ports-gnome-f92742d5cc04286ec4ffdc5dab4dde9187e58c26.tar.gz
freebsd-ports-gnome-f92742d5cc04286ec4ffdc5dab4dde9187e58c26.tar.zst
freebsd-ports-gnome-f92742d5cc04286ec4ffdc5dab4dde9187e58c26.zip
- Fix handling of options
Inspired by: jhale Feature safe: yes
Diffstat (limited to 'www/bozohttpd')
-rw-r--r--www/bozohttpd/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index ef2c081568a5..432c9c1c7350 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -23,31 +23,28 @@ HTPASSWD_DESC= Enable htpassword support
SSL_DESC= Enable SSL support
CGI_DESC= Enable CGI support
-#make happy portlint
-.if empty(PORT_OPTIONS:MSSL)
-.else
-USE_OPENSSL= yes
-.endif
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHTPASSWD}
-CFLAGS+= -DDO_HTPASSWD
-MAKE_ARGS+= 'LDFLAGS+= -lcrypt'
+MAKE_ARGS+= 'COPTS+= -DDO_HTPASSWD' \
+ 'LDFLAGS+= -lcrypt'
.else
-CFLAGS+= -UDO_HTPASSWD
+MAKE_ARGS+= 'COPTS+= -UDO_HTPASSWD'
.endif
.if ${PORT_OPTIONS:MSSL}
-CFLAGS+= -UNO_SSL_SUPPORT
+USE_OPENSSL= yes
+MAKE_ARGS+= 'COPTS+= -UNO_SSL_SUPPORT'
.else
-CFLAGS+= -DNO_SSL_SUPPORT
+MAKE_ARGS+= 'COPTS+= -DNO_SSL_SUPPORT' \
+ 'CRYPTOLIBS=' \
+ 'CRYPTODEPS='
.endif
.if ${PORT_OPTIONS:MCGI}
-CFLAGS+= -UNO_CGIBIN_SUPPORT
+MAKE_ARGS+= 'COPTS+= -UNO_CGIBIN_SUPPORT'
.else
-CFLAGS+= -DNO_CGIBIN_SUPPORT
+MAKE_ARGS+= 'COPTS+= -DNO_CGIBIN_SUPPORT'
.endif
MAN8= bozohttpd.8