aboutsummaryrefslogtreecommitdiffstats
path: root/www/c-icap-modules
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /www/c-icap-modules
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'www/c-icap-modules')
-rw-r--r--www/c-icap-modules/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
index b68f073f4950..9df64531381c 100644
--- a/www/c-icap-modules/Makefile
+++ b/www/c-icap-modules/Makefile
@@ -2,7 +2,7 @@
# Date created: 15 August 2012
# Whom: Martin Matuska <mm@FreeBSD.org>
#
-# $FreeBSD: ports/www/c-icap-modules/Makefile,v 1.3 2012/08/15 01:47:11 mm Exp $
+# $FreeBSD$
#
PORTNAME= c-icap
@@ -33,8 +33,8 @@ CONFIGURE_ARGS+= --enable-static \
post-install:
@${CP} -np ${PREFIX}/etc/c-icap/srv_url_check.conf.default \
- ${PREFIX}/etc/c-icap/srv_url_check.conf
+ ${PREFIX}/etc/c-icap/srv_url_check.conf || ${TRUE}
@${CP} -np ${PREFIX}/etc/c-icap/virus_scan.conf.default \
- ${PREFIX}/etc/c-icap/virus_scan.conf
+ ${PREFIX}/etc/c-icap/virus_scan.conf || ${TRUE}
.include <bsd.port.mk>