aboutsummaryrefslogtreecommitdiffstats
path: root/www/c-icap
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-06-15 19:18:56 +0800
committersem <sem@FreeBSD.org>2006-06-15 19:18:56 +0800
commit6b04eb139d5e6f1a83cf6310f42376c262b01e2e (patch)
tree89c8bd450a4cf2ae9248e7252764419b141fcd27 /www/c-icap
parent297ca2c3f666f4637102858ad23c731be26b95a8 (diff)
downloadfreebsd-ports-gnome-6b04eb139d5e6f1a83cf6310f42376c262b01e2e.tar.gz
freebsd-ports-gnome-6b04eb139d5e6f1a83cf6310f42376c262b01e2e.tar.zst
freebsd-ports-gnome-6b04eb139d5e6f1a83cf6310f42376c262b01e2e.zip
- Update to 030606rc1
Contains fixes for a bug which causes segmentation fault to the c-icap server PR: ports/98903 Submitted by: maintainer
Diffstat (limited to 'www/c-icap')
-rw-r--r--www/c-icap/Makefile3
-rw-r--r--www/c-icap/distinfo6
-rw-r--r--www/c-icap/files/patch-configure25
-rw-r--r--www/c-icap/files/patch-configure.in29
-rw-r--r--www/c-icap/files/patch-request_common.c11
5 files changed, 64 insertions, 10 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 265caed81111..07ddb793f48e 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -7,12 +7,13 @@
PORTNAME= c-icap
PORTVERSION= 030606
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://bio3k.softboard.ru/uploads/arch/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= c_icap-${PORTVERSION}
+DISTNAME= c_icap-${PORTVERSION}rc1
MAINTAINER= b3k@mail.ru
COMMENT= An implementation of an ICAP server
diff --git a/www/c-icap/distinfo b/www/c-icap/distinfo
index b872c92d29c7..5944d5391547 100644
--- a/www/c-icap/distinfo
+++ b/www/c-icap/distinfo
@@ -1,3 +1,3 @@
-MD5 (c_icap-030606.tar.gz) = 539625e3bc95340043761b0c70a98f57
-SHA256 (c_icap-030606.tar.gz) = 554bb95d1d9e26960e8091c7db9796282fd9c116177dc6d6d6cc585dd4a7de3c
-SIZE (c_icap-030606.tar.gz) = 413457
+MD5 (c_icap-030606rc1.tar.gz) = 4e851db7fb03570b2420cf8a78b48223
+SHA256 (c_icap-030606rc1.tar.gz) = bcf7e3fa6461cdcba66b61e035ab00a41a3652b3c4a46025a36a1e625c991471
+SIZE (c_icap-030606rc1.tar.gz) = 413570
diff --git a/www/c-icap/files/patch-configure b/www/c-icap/files/patch-configure
index b98fb67f9299..00011dfbe530 100644
--- a/www/c-icap/files/patch-configure
+++ b/www/c-icap/files/patch-configure
@@ -1,5 +1,26 @@
---- configure.bak Sat Jun 10 17:33:25 2006
-+++ configure Sat Jun 10 17:34:38 2006
+--- configure.bak Mon Jun 12 22:20:15 2006
++++ configure Thu Jun 15 15:34:49 2006
+@@ -19441,7 +19441,7 @@
+ THREADS_LDADD="-lpthread"
+ THREADS_LDFLAGS=""
+ ;;
+- freebsd5.*)
++ freebsd4.*)
+ ## If I understand how all those threading models works correctly
+ ## in FreeBSD I will make an option in configure script
+ ## --with-freebsd-threads={c_r,pthreads,linuxthreads,thr}
+@@ -19454,9 +19454,9 @@
+ # THREADS_LDADD="-llthread -lgcc_r"
+ # THREADS_LDFLAGS="-L/usr/local/lib"
+
+-## FreeBSD Standard threads
++## FreeBSD 4.x Standard threads
+ CFLAGS="-pthread -D_THREAD_SAFE $CFLAGS"
+- THREADS_LDADD="-XCClinker -lc_r"
++ THREADS_LDADD="-lc_r"
+ THREADS_LDFLAGS=""
+
+ ## 1:1 threads
@@ -21574,7 +21574,7 @@
fi
diff --git a/www/c-icap/files/patch-configure.in b/www/c-icap/files/patch-configure.in
index 16e68e6497fa..becc67343baa 100644
--- a/www/c-icap/files/patch-configure.in
+++ b/www/c-icap/files/patch-configure.in
@@ -1,8 +1,29 @@
---- configure.in.bak Thu Feb 2 10:45:50 2006
-+++ configure.in Thu Feb 2 10:46:13 2006
-@@ -198,4 +198,4 @@
+--- configure.in.bak Mon Jun 12 22:19:56 2006
++++ configure.in Thu Jun 15 15:35:07 2006
+@@ -51,7 +51,7 @@
+ THREADS_LDADD="-lpthread"
+ THREADS_LDFLAGS=""
+ ;;
+- freebsd5.*)
++ freebsd4.*)
+ ## If I understand how all those threading models works correctly
+ ## in FreeBSD I will make an option in configure script
+ ## --with-freebsd-threads={c_r,pthreads,linuxthreads,thr}
+@@ -64,9 +64,9 @@
+ # THREADS_LDADD="-llthread -lgcc_r"
+ # THREADS_LDFLAGS="-L/usr/local/lib"
+
+-## FreeBSD Standard threads
++## FreeBSD 4.x Standard threads
+ CFLAGS="-pthread -D_THREAD_SAFE $CFLAGS"
+- THREADS_LDADD="-XCClinker -lc_r"
++ THREADS_LDADD="-lc_r"
+ THREADS_LDFLAGS=""
+
+ ## 1:1 threads
+@@ -328,4 +328,4 @@
AM_CONDITIONAL(USEPERL,[test a"$perlcore" != a])
AM_CONDITIONAL(USECLAMAV,[test a"$clamav" != ano])
--AC_OUTPUT([Makefile c-icap.conf services/Makefile services/echo/Makefile services/sguard/Makefile services/clamav/Makefile modules/Makefile])
+-AC_OUTPUT([Makefile c-icap.conf services/Makefile services/echo/Makefile services/url_check/Makefile services/clamav/Makefile modules/Makefile])
+AC_OUTPUT([Makefile c-icap.conf.default services/Makefile services/echo/Makefile services/sguard/Makefile services/clamav/Makefile modules/Makefile])
diff --git a/www/c-icap/files/patch-request_common.c b/www/c-icap/files/patch-request_common.c
new file mode 100644
index 000000000000..7242ba5301b3
--- /dev/null
+++ b/www/c-icap/files/patch-request_common.c
@@ -0,0 +1,11 @@
+--- request_common.c.orig Thu Jun 15 10:13:10 2006
++++ request_common.c Thu Jun 15 10:13:16 2006
+@@ -654,7 +654,7 @@
+
+
+ int client_parse_icap_header(request_t *req,ci_headers_list_t *h){
+- int readed=0,eoh=0;;
++ int readed=0,eoh=0;
+ char *buf,*end;
+ if(req->pstrblock_read_len<4)/*we need 4 bytes for the end of headers "\r\n\r\n" string*/
+ return CI_NEEDS_MORE;