aboutsummaryrefslogtreecommitdiffstats
path: root/www/cakephp-devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-07-10 02:03:21 +0800
committermiwi <miwi@FreeBSD.org>2007-07-10 02:03:21 +0800
commit8e4d76f45099ee8e46338ce5b1c94190f7c10550 (patch)
tree4de43d3f26bb5081904c4945177b26b99048f393 /www/cakephp-devel
parent545fb961387921b38711354b04d2147913cf1622 (diff)
downloadfreebsd-ports-gnome-8e4d76f45099ee8e46338ce5b1c94190f7c10550.tar.gz
freebsd-ports-gnome-8e4d76f45099ee8e46338ce5b1c94190f7c10550.tar.zst
freebsd-ports-gnome-8e4d76f45099ee8e46338ce5b1c94190f7c10550.zip
The use of "find ... -print0/xargs -0 ..." is faster than
"find ... -print/xargs -n1 ...", so use that here to fix file and directory permissions after installation. PR: 114445 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer)
Diffstat (limited to 'www/cakephp-devel')
-rw-r--r--www/cakephp-devel/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/cakephp-devel/Makefile b/www/cakephp-devel/Makefile
index 978fe8b474eb..3f229ae9df28 100644
--- a/www/cakephp-devel/Makefile
+++ b/www/cakephp-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cakephp
PORTVERSION= 1.1.15.5144
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://cakeforge.org/frs/download.php/410/
DISTNAME= cake_${PORTVERSION}
@@ -115,8 +116,8 @@ do-install:
${WRKSRC}/index.php \
${WRKSRC}/vendors ${WWWDIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- ${FIND} ${WWWDIR} -type f -print | ${XARGS} -n1 ${CHMOD} 644
- ${FIND} ${WWWDIR} -type d -print | ${XARGS} -n1 ${CHMOD} 755
+ ${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ ${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
post-install:
@if [ -d "${CONFDIR}" ]; then \