aboutsummaryrefslogtreecommitdiffstats
path: root/www/calamaris/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-01-22 07:28:03 +0800
committerbillf <billf@FreeBSD.org>1999-01-22 07:28:03 +0800
commit80467de893dc32ec70522e60f56991c0f14dc907 (patch)
treef4f2c4c1e51c6307b32840695f56dee66fc47084 /www/calamaris/Makefile
parent58511b3f542c5ab3213ab979d21a27302d4654b0 (diff)
downloadfreebsd-ports-gnome-80467de893dc32ec70522e60f56991c0f14dc907.tar.gz
freebsd-ports-gnome-80467de893dc32ec70522e60f56991c0f14dc907.tar.zst
freebsd-ports-gnome-80467de893dc32ec70522e60f56991c0f14dc907.zip
Calamaris parses the Squid Native Log and genereates reports
about Peak-usage, Request-Methods, Status-reports of incoming and outgoing requests, second and Top-level destinations, content-types and performance. http://Calamaris.Cord.de/ PR: ports/9194 Submitted By: Dima Sivachenko
Diffstat (limited to 'www/calamaris/Makefile')
-rw-r--r--www/calamaris/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/calamaris/Makefile b/www/calamaris/Makefile
new file mode 100644
index 000000000000..d420d2cfe093
--- /dev/null
+++ b/www/calamaris/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: calmaris
+# Version required: 2.8
+# Date created: 25 December 1998
+# Whom: Dima Sivachenko
+#
+# $Id$
+#
+
+DISTNAME= calamaris-2.8
+CATEGORIES= www textproc
+MASTER_SITES= http://calamaris.cord.de/ \
+ ftp://ftp.win.or.jp/pub/network/www/log-tools/ \
+ ftp://ftp.c-com.net/pub/.30/LinuxBerg/files/console/
+
+MAINTAINER= dima@Chg.RU
+
+NO_BUILD= yes
+
+post-patch:
+
+ @ ${MV} ${WRKSRC}/calamaris.pl ${WRKSRC}/calamaris.pl.pre_sed
+ @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' ${WRKSRC}/calamaris.pl.pre_sed \
+ >> ${WRKSRC}/calamaris.pl
+
+do-install:
+
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/calamaris.pl ${PREFIX}/bin/calamaris
+
+.include <bsd.port.mk>