aboutsummaryrefslogtreecommitdiffstats
path: root/www/cgic/files
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-04-01 00:23:38 +0800
committerkevlo <kevlo@FreeBSD.org>2001-04-01 00:23:38 +0800
commitee4846aee42959929eb74490b91ee7ef48fdd528 (patch)
treef7d0bec2f63a9ad4b98854d4f9a1c080cb5e7387 /www/cgic/files
parent0f8161d46c306e0fca8ad94f532298b17e33975b (diff)
downloadfreebsd-ports-gnome-ee4846aee42959929eb74490b91ee7ef48fdd528.tar.gz
freebsd-ports-gnome-ee4846aee42959929eb74490b91ee7ef48fdd528.tar.zst
freebsd-ports-gnome-ee4846aee42959929eb74490b91ee7ef48fdd528.zip
Update to version 1.07
PR: 26235 Submitted by: Ports Fury
Diffstat (limited to 'www/cgic/files')
-rw-r--r--www/cgic/files/Makefile.lib18
-rw-r--r--www/cgic/files/patch-aa29
2 files changed, 18 insertions, 29 deletions
diff --git a/www/cgic/files/Makefile.lib b/www/cgic/files/Makefile.lib
new file mode 100644
index 000000000000..def67c9c8dff
--- /dev/null
+++ b/www/cgic/files/Makefile.lib
@@ -0,0 +1,18 @@
+LIB= cgic
+
+SHLIB_MAJOR?= 1
+NOPROFILE= yes
+
+LIBDIR= ${PREFIX}/lib
+INCDIR= ${PREFIX}/include
+CFLAGS+= -I${.CURDIR}
+
+SRCS= cgic.c
+
+HEADERS= cgic.h
+
+afterinstall:
+ ${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
+ ${HEADERS} ${INCDIR}
+
+.include <bsd.lib.mk>
diff --git a/www/cgic/files/patch-aa b/www/cgic/files/patch-aa
deleted file mode 100644
index c13d472a32bd..000000000000
--- a/www/cgic/files/patch-aa
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile Fri Feb 16 00:20:09 1996
-+++ /home/andy/tmp/wrk/Makefile Tue Jul 27 15:40:18 1999
-@@ -3,16 +3,15 @@
- #or the system() function, respectively. Non-unix systems
- #will also definitely have different linker syntax.
-
--CFLAGS=
--CC=gcc
-+#CFLAGS=
-+#CC=gcc
- AR=ar
- LIBS=-L./ -lcgic
-
- all: libcgic.a cgictest capture
-
--libcgic.a: cgic.o cgic.h
-- rm -f libcgic.a
-- $(AR) rc libcgic.a cgic.o
-+libcgic.so.1: cgic.o
-+ $(CC) $(CFLAGS) -shared -Wl,-soname,libcgic.so.1 -o libcgic.so.1 cgic.o
-
- cgictest: cgictest.o libcgic.a
- gcc cgictest.o -o cgictest ${LIBS}
-@@ -20,3 +19,5 @@
- capture: capture.o libcgic.a
- gcc capture.o -o capture ${LIBS}
-
-+cgic.o: cgic.c cgic.h
-+ $(CC) $(CFLAGS) -fPIC -o cgic.o -c -s cgic.c