aboutsummaryrefslogtreecommitdiffstats
path: root/www/checkbot
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /www/checkbot
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'www/checkbot')
-rw-r--r--www/checkbot/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/www/checkbot/Makefile b/www/checkbot/Makefile
index ad378a8c88bb..05f3539efa1b 100644
--- a/www/checkbot/Makefile
+++ b/www/checkbot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= checkbot
PORTVERSION= 1.80
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Checkbot%20${PORTVERSION}
@@ -24,9 +24,6 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
USES= perl5
USE_PERL5= configure
-PLIST_FILES= bin/checkbot \
- ${SITE_PERL:S!${LOCALBASE}/!!}/${PERL_ARCH}/auto/checkbot/.packlist \
- man/man1/checkbot.1.gz
-PLIST_DIRS= ${SITE_PERL:S!${LOCALBASE}/!!}/${PERL_ARCH}/auto/checkbot
+PLIST_FILES= bin/checkbot man/man1/checkbot.1.gz
.include <bsd.port.mk>