aboutsummaryrefslogtreecommitdiffstats
path: root/www/cheetah/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-12-05 02:52:04 +0800
committerkrion <krion@FreeBSD.org>2003-12-05 02:52:04 +0800
commitefc70042371e912d143765c3405fc6b4474773db (patch)
treec03ae8b6343403399eba8a2894b2c73e7e9a98ec /www/cheetah/Makefile
parentff6e33c901cd1e02b349974c58fce90ca9621222 (diff)
downloadfreebsd-ports-gnome-efc70042371e912d143765c3405fc6b4474773db.tar.gz
freebsd-ports-gnome-efc70042371e912d143765c3405fc6b4474773db.tar.zst
freebsd-ports-gnome-efc70042371e912d143765c3405fc6b4474773db.zip
- Update to version 0.10
PR: 59647 Submitted by: Ports Fury
Diffstat (limited to 'www/cheetah/Makefile')
-rw-r--r--www/cheetah/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/cheetah/Makefile b/www/cheetah/Makefile
index d2c80eafa83f..40165c4a7330 100644
--- a/www/cheetah/Makefile
+++ b/www/cheetah/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= cheetah
-PORTVERSION= 0.05
+PORTVERSION= 0.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= cheetah
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ based light-weight web browser
@@ -18,9 +18,16 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>