aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee-devel
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-11-08 00:54:49 +0800
committeralepulver <alepulver@FreeBSD.org>2006-11-08 00:54:49 +0800
commitaba921701caa5a4217facee93812e07c2759b8ea (patch)
tree77e20d476554cddd22e0a8c9d1c43d8b0d4615b1 /www/cherokee-devel
parente0836f43abbb1be4bd26c36e1409ab3cfddc212e (diff)
downloadfreebsd-ports-gnome-aba921701caa5a4217facee93812e07c2759b8ea.tar.gz
freebsd-ports-gnome-aba921701caa5a4217facee93812e07c2759b8ea.tar.zst
freebsd-ports-gnome-aba921701caa5a4217facee93812e07c2759b8ea.zip
- Added options.
PR: ports/105171 Submitted by: Beech Rintoul <beech@alaskaparadise.com> (maintainer)
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile32
1 files changed, 25 insertions, 7 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index 1605ae75eb22..84d70334fd17 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -7,8 +7,10 @@
PORTNAME= cherokee
PORTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/
+MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/ \
+ http://www.alaskaparadise.com/freebsd/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
@@ -26,6 +28,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
--with-wwwroot=${PREFIX}/www
+
+OPTIONS= GNUTLS "TLS/SSL Use gnutls" on \
+ OPENSSL "TLS/SSL Use openssl" off \
+ NOTLS "No TLS/SSL" off \
+ NOIPV6 "No IPv6" off
+
USE_LDCONFIG= yes
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
@@ -33,16 +41,26 @@ MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_GNUTLS)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-tls=openssl
-LDFLAGS+= -lssl -lcrypto
-.else
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNUTLS)
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-tls=gnutls
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_OPENSSL)
+CFLAGS+= -DHAVE_OPENSSL
+CONFIGURE_ARGS+=--enable-tls=openssl
+LDFLAGS+= -lssl -lcrypto
+.endif
+
+.if defined(WITH_NOTLS)
+CONFIGURE_ARGS+=--disable-tls
+.endif
+
+.if defined(WITH_NOIPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
.if ${OSVERSION} < 500000
PLIST_SUB+= PAM=""