aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-23 19:48:02 +0800
committerpav <pav@FreeBSD.org>2005-04-23 19:48:02 +0800
commita5e1a2065ef67b687e574268e4ecd7f3dd0be235 (patch)
tree4787f2e790087a33d6df3f24cdbcf9f54dcf0554 /www/cherokee/Makefile
parentf892319acc595f77b5f37ff89f29eaadf7b5e076 (diff)
downloadfreebsd-ports-gnome-a5e1a2065ef67b687e574268e4ecd7f3dd0be235.tar.gz
freebsd-ports-gnome-a5e1a2065ef67b687e574268e4ecd7f3dd0be235.tar.zst
freebsd-ports-gnome-a5e1a2065ef67b687e574268e4ecd7f3dd0be235.zip
- Update to 0.4.19
- Unbreak plist PR: ports/79977 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'www/cherokee/Makefile')
-rw-r--r--www/cherokee/Makefile43
1 files changed, 34 insertions, 9 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 2db4baa29240..9b6390b0b79e 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -6,35 +6,60 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.4.17
+PORTVERSION= 0.4.19
CATEGORIES= www
-MASTER_SITES= ftp://laurel.datsi.fi.upm.es/pub/linux/cherokee/%SUBDIR%/
+MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An extremely fast and flexible web server
-LIB_DEPENDS= gnutls.12:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 15
+USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
+CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www
INSTALLS_SHLIB= yes
MAN1= cherokee-config.1 cherokee.1
-CPPFLAGS= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if defined(WITHOUT_GNUTLS)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --enable-tls=openssl
+LDFLAGS+= -lssl -lcrypto
+.else
+LIB_DEPENDS+= gnutls.12:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --enable-tls=gnutls
+.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Broken pkg-plist"
+.if ${OSVERSION} < 500000
+PLIST_SUB+= PAM="" PAM5="@comment "
+.else
+PLIST_SUB+= PAM="@comment " PAM5=""
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(top_builddir)/sherokee_reinplace|true|g' \
+ ${WRKSRC}/Makefile.in
+
+pre-build:
+.for file in advanced.conf cherokee.conf mods-ssl sites-default sites-example
+ @cd ${BUILD_WRKSRC} && ${SED} -e \
+ 's:%sysconfdir%:${PREFIX}/etc:g ; \
+ s:%datadir%:${PREFIX}/share:g ; \
+ s:%wwwroot%:${PREFIX}/www:g ; \
+ s:%prefix%:${PREFIX}:g' < ${file}.sample.pre > ${file}.sample
+.endfor
+
pre-install:
@if [ ! -f ${PREFIX}/www ]; then \
${MKDIR} ${PREFIX}/www;\