aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-09-01 08:17:59 +0800
committerahze <ahze@FreeBSD.org>2005-09-01 08:17:59 +0800
commitc1441c9ee53340826f8c9fdf130f10e889d3d19a (patch)
treeb8c4c41451b2e203cd2a7a73ca41471cd3f7ae5e /www/cherokee
parent9de45945aa9853c478ecd1e9cd3cfa09039c3b7e (diff)
downloadfreebsd-ports-gnome-c1441c9ee53340826f8c9fdf130f10e889d3d19a.tar.gz
freebsd-ports-gnome-c1441c9ee53340826f8c9fdf130f10e889d3d19a.tar.zst
freebsd-ports-gnome-c1441c9ee53340826f8c9fdf130f10e889d3d19a.zip
- Fix build on 7.x
PR: ports/85539 Submitted by: Ports Fury
Diffstat (limited to 'www/cherokee')
-rw-r--r--www/cherokee/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 9bccc9920227..23728aa89db3 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -46,6 +47,10 @@ PLIST_SUB+= PAM=""
PLIST_SUB+= PAM="@comment "
.endif
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|@mkdir_p@|${MKDIR} --|g'
+
pre-build:
.for file in advanced.conf cherokee.conf mods-ssl sites-default sites-example
@cd ${BUILD_WRKSRC} && ${SED} -e \