aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-09-13 01:03:57 +0800
committerrene <rene@FreeBSD.org>2011-09-13 01:03:57 +0800
commit1088d00fd0c42696290fd4722bcfff9f437ff5f3 (patch)
tree7ad866f8329dc23aa3e72946150d2f1007ee4206 /www/chromium/Makefile
parentcb629017dd67282263d929a8181c2a7160f52656 (diff)
downloadfreebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.tar.gz
freebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.tar.zst
freebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.zip
Switch to system ICU, this should fix building on 8.0-i386
Submitted by: pointyhat via erwin Obtained from: http://trillian.chruetertee.ch/chromium/changeset/218
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index df313a06ec25..e3bedbeda56d 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -35,7 +35,8 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
freetype.9:${PORTSDIR}/print/freetype2 \
nss3.1:${PORTSDIR}/security/nss \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
- cups.2:${PORTSDIR}/print/cups-client
+ cups.2:${PORTSDIR}/print/cups-client \
+ icudata.48:${PORTSDIR}/devel/icu
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins \
${LOCALBASE}/lib/X11/fonts/Droid/fonts.dir:${PORTSDIR}/x11-fonts/droid-fonts-ttf \
@@ -66,6 +67,7 @@ GYP_DEFINES+= use_system_ffmpeg=0
#GYP_DEFINES+= use_system_sqlite=0
GYP_DEFINES+= use_system_yasm=1
#GYP_DEFINES+= use_system_zlib=1
+GYP_DEFINES+= use_system_icu=1
GYP_DEFINES+= python_ver=${PYTHON_VER}
GYP_DEFINES+= disable_nacl=1
GYP_DEFINES+= linux_use_heapchecker=1