aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-11-02 04:01:05 +0800
committerrene <rene@FreeBSD.org>2011-11-02 04:01:05 +0800
commitd7567ef96809d324f1f45e76ed3f3dba0e049937 (patch)
treeca8142533a4e207c1a27ac5f870a8a95614e2d05 /www/chromium/Makefile
parent0af4dc1a49a7085e4b4cba3c0df64f63f311f41b (diff)
downloadfreebsd-ports-gnome-d7567ef96809d324f1f45e76ed3f3dba0e049937.tar.gz
freebsd-ports-gnome-d7567ef96809d324f1f45e76ed3f3dba0e049937.tar.zst
freebsd-ports-gnome-d7567ef96809d324f1f45e76ed3f3dba0e049937.zip
Some Makefile cleanups:
- Do not explicitly check for nss >= 3.12, this has been true for 26 months now - Prefer official spelling of Clang and GCC and use "Build" instead of "Compile" in options Submitted by: danfe@ via chromium@
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index e94c13f6e4b7..6406f1e8ac4d 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -25,9 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
bash:${PORTSDIR}/shells/bash \
yasm:${PORTSDIR}/devel/yasm \
flock:${PORTSDIR}/sysutils/flock \
- v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat \
- nss>=3.12:${PORTSDIR}/security/nss
-# minimal version of nss, LIB_DEPENDS does not enforce this
+ v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
cairo.2:${PORTSDIR}/graphics/cairo \
@@ -80,8 +78,8 @@ GYP_DEFINES+= use_cups=1 \
OPTIONS= CODECS "Compile and enable patented codecs like H.264" on \
GCONF "Use GConf2 for preferences" on \
PULSE "Enable Pulse Audio support" off \
- CLANG "Compile Chromium with clang" off \
- GCC45 "Compile Chromium with gcc 4.5+" off \
+ CLANG "Build Chromium with Clang" off \
+ GCC45 "Build Chromium with GCC 4.5+" off \
DEBUG "Compile with debug symbols and verbose output" off
.include <bsd.port.options.mk>