aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-08-03 05:12:37 +0800
committerrene <rene@FreeBSD.org>2011-08-03 05:12:37 +0800
commit2bc4c8460f169323518dfcb8486195e3fe6fa5af (patch)
treeeea3a8ca54a3cca8dd0bdf74f4f5250b825cddb7 /www/chromium/Makefile
parentbff37e0d2c02f2985df12f18eee7642763170d04 (diff)
downloadfreebsd-ports-gnome-2bc4c8460f169323518dfcb8486195e3fe6fa5af.tar.gz
freebsd-ports-gnome-2bc4c8460f169323518dfcb8486195e3fe6fa5af.tar.zst
freebsd-ports-gnome-2bc4c8460f169323518dfcb8486195e3fe6fa5af.zip
Update to 13.0.782.107
- default H.264 codecs to on [1] - drop ibus dependency, no longer needed [1] Submitted by: George Liaskos (patch updates, [1]) Obtained from: Chromium development repository Security: http://www.vuxml.org/freebsd/6887828f-0229-11e0-b84d-00262d5ed8ee.html
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 5862f6bcad88..be7e7565a177 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chromium
DISTVERSIONPREFIX= courgette-redacted-
-DISTVERSION= 12.0.742.124
+DISTVERSION= 13.0.782.107
CATEGORIES= www
MASTER_SITES= http://download.goodking.org/downloads/ \
ftp://rene-ladan.nl/pub/distfiles/ \
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
bash:${PORTSDIR}/shells/bash \
yasm:${PORTSDIR}/devel/yasm \
+ v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat \
nss>=3.12:${PORTSDIR}/security/nss
# minimal version of nss, LIB_DEPENDS does not enforce this
@@ -34,7 +35,6 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
freetype.9:${PORTSDIR}/print/freetype2 \
nss3.1:${PORTSDIR}/security/nss \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
- ibus.2:${PORTSDIR}/textproc/ibus \
cups.2:${PORTSDIR}/print/cups-client
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins \
@@ -57,7 +57,6 @@ DESKTOP_ENTRIES="Chromium" "${COMMENT}" "${DATADIR}/product_logo_48.png" \
ALL_TARGET= chrome
#user tunables showing defaults, some won't compile if changed
-#GYP_DEFINES+= target_arch=ia32 #or x64, should be detected automatically
#GYP_DEFINES+= use_system_bzip2=1
#GYP_DEFINES+= use_system_libevent=0
#GYP_DEFINES+= use_system_libjpeg=1
@@ -68,8 +67,12 @@ GYP_DEFINES+= use_system_ffmpeg=0
GYP_DEFINES+= use_system_yasm=1
#GYP_DEFINES+= use_system_zlib=1
GYP_DEFINES+= python_ver=${PYTHON_VER}
+GYP_DEFINES+= disable_nacl=1
+GYP_DEFINES+= linux_use_heapchecker=1
+GYP_DEFINES+= linux_link_gsettings=1
+GYP_DEFINES+= linux_link_gnome_keyring=1
-OPTIONS= CODECS "Compile and enable patented codecs like H.264" off \
+OPTIONS= CODECS "Compile and enable patented codecs like H.264" on \
GCONF "Use GConf2 for preferences" on \
VPX "Use system libvpx for VP8 codec" on