aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-06-24 01:45:26 +0800
committercpm <cpm@FreeBSD.org>2017-06-24 01:45:26 +0800
commitccbd78d2942f68f3f34072f0165c556a26438665 (patch)
treeda8061c38cc414c99619788baf58d861733c70ef /www/chromium
parent65855f9d9c2b7b6c99fc8e7afd792c775d8bca44 (diff)
downloadfreebsd-ports-gnome-ccbd78d2942f68f3f34072f0165c556a26438665.tar.gz
freebsd-ports-gnome-ccbd78d2942f68f3f34072f0165c556a26438665.tar.zst
freebsd-ports-gnome-ccbd78d2942f68f3f34072f0165c556a26438665.zip
www/chromium: update to 59.0.3071.109
- Fix TEST option Changelog: https://chromium.googlesource.com/chromium/src/+log/59.0.3071.104..59.0.3071.109?pretty=fuller&n=10000 MFH: 2017Q2
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/Makefile.tests2
-rw-r--r--www/chromium/distinfo10
-rw-r--r--www/chromium/files/patch-base_logging__unittest.cc11
-rw-r--r--www/chromium/files/patch-chrome_test_BUILD.gn43
-rw-r--r--www/chromium/files/patch-components_os__crypt_os__crypt.h13
-rw-r--r--www/chromium/files/patch-components_os__crypt_os__crypt__unittest.cc20
-rw-r--r--www/chromium/files/patch-content_test_BUILD.gn28
-rw-r--r--www/chromium/files/patch-content_test_suite.cc18
-rw-r--r--www/chromium/files/patch-gpu_BUILD.gn17
-rw-r--r--www/chromium/files/patch-gpu_gles2__conform__support_BUILD.gn15
11 files changed, 130 insertions, 49 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index bcd94f797261..1ed3f9edcf4b 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 59.0.3071.104
+PORTVERSION= 59.0.3071.109
CATEGORIES= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
diff --git a/www/chromium/Makefile.tests b/www/chromium/Makefile.tests
index 6319f4157fd1..0890147bbeac 100644
--- a/www/chromium/Makefile.tests
+++ b/www/chromium/Makefile.tests
@@ -1,4 +1,5 @@
#$FreeBSD$
+#net_unittests : fatal error: 'sys/epoll.h' file not found
#telemetry_unittests : unknown ninja target
TEST_TARGETS= base_unittests \
crypto_unittests \
@@ -12,7 +13,6 @@ TEST_TARGETS= base_unittests \
compositor_unittests \
ipc_tests \
dbus_unittests \
- net_unittests \
media_unittests \
chromedriver_unittests \
chromedriver_tests \
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index f42c365eb971..dde69044cd9c 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1497583686
-SHA256 (chromium-59.0.3071.104.tar.xz) = a949fa166cdcdbd8419fbdb4583804613d9845130f0c851e4c647d79a4c300d0
-SIZE (chromium-59.0.3071.104.tar.xz) = 531895868
-SHA256 (chromium-59.0.3071.104-testdata.tar.xz) = 4826be59b1f29dcf25c9868d0cac296fb2c98a8f1f944e6a3d7cea275705b771
-SIZE (chromium-59.0.3071.104-testdata.tar.xz) = 124231072
+TIMESTAMP = 1498132680
+SHA256 (chromium-59.0.3071.109.tar.xz) = 83faeb3537428d83728258b28e907caaee6e6572bcd7d9b9a5f6009e7ea758d9
+SIZE (chromium-59.0.3071.109.tar.xz) = 531839168
+SHA256 (chromium-59.0.3071.109-testdata.tar.xz) = 211447bd78861623329ab39f6611b7caccc69c483d616adcd9610def524699b0
+SIZE (chromium-59.0.3071.109-testdata.tar.xz) = 124235432
diff --git a/www/chromium/files/patch-base_logging__unittest.cc b/www/chromium/files/patch-base_logging__unittest.cc
new file mode 100644
index 000000000000..8cd0a56dcf8a
--- /dev/null
+++ b/www/chromium/files/patch-base_logging__unittest.cc
@@ -0,0 +1,11 @@
+--- base/logging_unittest.cc.orig 2017-06-21 19:47:24.089128000 +0200
++++ base/logging_unittest.cc 2017-06-21 20:02:08.177123000 +0200
+@@ -272,7 +272,7 @@
+ // need the arch-specific boilerplate below, which is inspired by breakpad.
+ // At the same time, on OSX, ucontext.h is deprecated but si_addr works fine.
+ uintptr_t crash_addr = 0;
+-#if defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(OS_BSD)
+ crash_addr = reinterpret_cast<uintptr_t>(info->si_addr);
+ #else // OS_POSIX && !OS_MACOSX
+ struct ucontext* context = reinterpret_cast<struct ucontext*>(context_ptr);
diff --git a/www/chromium/files/patch-chrome_test_BUILD.gn b/www/chromium/files/patch-chrome_test_BUILD.gn
index 37faee3ea5b3..ac0d28fdb5b3 100644
--- a/www/chromium/files/patch-chrome_test_BUILD.gn
+++ b/www/chromium/files/patch-chrome_test_BUILD.gn
@@ -1,6 +1,6 @@
---- chrome/test/BUILD.gn.orig 2017-06-05 19:03:04 UTC
-+++ chrome/test/BUILD.gn
-@@ -192,7 +192,7 @@ static_library("test_support") {
+--- chrome/test/BUILD.gn.orig 2017-06-15 21:03:02.000000000 +0200
++++ chrome/test/BUILD.gn 2017-06-22 05:09:51.612311000 +0200
+@@ -192,7 +192,7 @@
]
}
@@ -9,7 +9,7 @@
public_deps += [ "//crypto:platform" ]
}
if (is_mac) {
-@@ -454,7 +454,7 @@ if (!is_android) {
+@@ -454,7 +454,7 @@
"$root_out_dir/test_page.css.mock-http-headers",
"$root_out_dir/ui_test.pak",
]
@@ -18,7 +18,7 @@
data += [
"$root_out_dir/chrome_100_percent.pak",
"$root_out_dir/chrome_200_percent.pak",
-@@ -463,7 +463,7 @@ if (!is_android) {
+@@ -463,7 +463,7 @@
"$root_out_dir/resources.pak",
]
}
@@ -27,7 +27,7 @@
data += [ "$root_out_dir/libppapi_tests.so" ]
}
-@@ -570,7 +570,7 @@ if (!is_android) {
+@@ -570,7 +570,7 @@
"base/interactive_test_utils_views.cc",
]
}
@@ -36,7 +36,7 @@
if (!is_chromeos) {
# Desktop linux.
sources -= [
-@@ -2044,14 +2044,14 @@ test("browser_tests") {
+@@ -2044,14 +2044,14 @@
sources += [ "//third_party/liblouis/nacl_wrapper/liblouis_wrapper_browsertest.cc" ]
deps += [ "//chrome/browser/chromeos" ]
data_deps += [ "//third_party/liblouis:liblouis_test_data" ]
@@ -53,7 +53,7 @@
sources += [ "../browser/nacl_host/test/nacl_gdb_browsertest.cc" ]
data_deps += [ "//chrome/browser/nacl_host/test:mock_nacl_gdb" ]
}
-@@ -2063,7 +2063,7 @@ test("browser_tests") {
+@@ -2063,7 +2063,7 @@
configs +=
[ "//build/config/win:default_large_module_incremental_linking" ]
}
@@ -62,7 +62,7 @@
data_deps += [ "//components/nacl/loader:nacl_helper" ]
if (enable_nacl_nonsfi) {
-@@ -2200,7 +2200,7 @@ test("browser_tests") {
+@@ -2200,7 +2200,7 @@
}
}
@@ -71,7 +71,7 @@
# Set rpath to find the CDM adapter even in a non-component build.
configs += [ "//build/config/gcc:rpath_for_built_shared_libraries" ]
}
-@@ -2430,7 +2430,7 @@ test("browser_tests") {
+@@ -2430,7 +2430,7 @@
if (toolkit_views) {
sources -= [ "../browser/ui/views/select_file_dialog_extension_browsertest.cc" ]
}
@@ -80,7 +80,7 @@
sources +=
[ "../browser/ui/views/ime/input_ime_apitest_nonchromeos.cc" ]
}
-@@ -2620,7 +2620,7 @@ test("browser_tests") {
+@@ -2620,7 +2620,7 @@
"../browser/extensions/api/networking_private/networking_private_chromeos_apitest.cc",
]
}
@@ -89,7 +89,7 @@
sources += [
# Tests for non mobile and non CrOS (includes Linux, Win, Mac).
"../browser/metrics/desktop_session_duration/audible_contents_tracker_browsertest.cc",
-@@ -2802,7 +2802,7 @@ if (!is_android) {
+@@ -2802,7 +2802,7 @@
"//testing/xvfb.py",
]
@@ -98,7 +98,7 @@
data += [
"$root_out_dir/chrome_100_percent.pak",
"$root_out_dir/chrome_200_percent.pak",
-@@ -3504,7 +3504,7 @@ test("unit_tests") {
+@@ -3504,9 +3504,14 @@
"$root_out_dir/resources.pak",
]
}
@@ -106,8 +106,15 @@
+ if (is_linux || is_bsd || is_win) {
data += [ "$root_out_dir/chrome_200_percent.pak" ]
}
++
++ if (is_bsd) {
++ sources -= [ "../common/component_flash_hint_file_linux_unittest.cc" ]
++ }
++
if (is_win) {
-@@ -4234,7 +4234,7 @@ test("unit_tests") {
+ data_deps += [ "//chrome" ]
+ data += [ "$root_out_dir/chrome.exe" ]
+@@ -4234,7 +4239,7 @@
"//ui/wm",
]
}
@@ -116,7 +123,7 @@
sources += [
"../browser/password_manager/native_backend_kwallet_x_unittest.cc",
"../browser/shell_integration_linux_unittest.cc",
-@@ -4256,7 +4256,7 @@ test("unit_tests") {
+@@ -4256,7 +4261,7 @@
if (use_gio) {
deps += [ "//build/linux/libgio" ]
}
@@ -125,7 +132,7 @@
deps += [ "//chrome/browser/ui/libgtkui" ]
}
-@@ -4537,18 +4537,18 @@ test("unit_tests") {
+@@ -4537,18 +4542,18 @@
"//components/os_crypt:gnome_keyring_direct",
]
}
@@ -147,7 +154,7 @@
ldflags = [ "-Wl,--strip-debug" ]
}
if (is_mac) {
-@@ -5045,7 +5045,7 @@ if (safe_browsing_mode == 1 && is_mac) {
+@@ -5045,7 +5050,7 @@
}
}
@@ -156,7 +163,7 @@
# TODO(609855): Make this compile on Android and run on the bots.
test("chrome_app_unittests") {
sources = [
-@@ -5071,7 +5071,7 @@ if (!is_android) {
+@@ -5071,7 +5076,7 @@
}
}
diff --git a/www/chromium/files/patch-components_os__crypt_os__crypt.h b/www/chromium/files/patch-components_os__crypt_os__crypt.h
index 5eb2565dc001..ff837388509b 100644
--- a/www/chromium/files/patch-components_os__crypt_os__crypt.h
+++ b/www/chromium/files/patch-components_os__crypt_os__crypt.h
@@ -1,5 +1,5 @@
---- components/os_crypt/os_crypt.h.orig 2017-04-19 19:06:32 UTC
-+++ components/os_crypt/os_crypt.h
+--- components/os_crypt/os_crypt.h.orig 2017-06-15 21:03:04.000000000 +0200
++++ components/os_crypt/os_crypt.h 2017-06-21 19:21:25.185823000 +0200
@@ -13,7 +13,7 @@
#include "base/strings/string16.h"
#include "build/build_config.h"
@@ -18,3 +18,12 @@
// If |store_type| is a known password store, we will attempt to use it.
// In any other case, we default to auto-detecting the store.
// This should not be changed after OSCrypt has been used.
+@@ -71,7 +71,7 @@
+ DISALLOW_IMPLICIT_CONSTRUCTORS(OSCrypt);
+ };
+
+-#if defined(OS_LINUX) && !defined(OS_CHROMEOS) && defined(UNIT_TEST)
++#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS) && defined(UNIT_TEST)
+ // For unit testing purposes, inject methods to be used.
+ // |get_key_storage_mock| provides the desired |KeyStorage| implementation.
+ // If the provider returns |nullptr|, a hardcoded password will be used.
diff --git a/www/chromium/files/patch-components_os__crypt_os__crypt__unittest.cc b/www/chromium/files/patch-components_os__crypt_os__crypt__unittest.cc
new file mode 100644
index 000000000000..f6a6036dfdab
--- /dev/null
+++ b/www/chromium/files/patch-components_os__crypt_os__crypt__unittest.cc
@@ -0,0 +1,20 @@
+--- components/os_crypt/os_crypt_unittest.cc.orig 2017-06-21 19:22:48.122268000 +0200
++++ components/os_crypt/os_crypt_unittest.cc 2017-06-21 19:23:55.247270000 +0200
+@@ -18,7 +18,7 @@
+ #include "components/os_crypt/os_crypt_mocker.h"
+ #include "testing/gtest/include/gtest/gtest.h"
+
+-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
++#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
+ #include "components/os_crypt/os_crypt_mocker_linux.h"
+ #endif
+
+@@ -151,7 +151,7 @@
+ class OSCryptConcurrencyTest : public testing::Test {
+ public:
+ OSCryptConcurrencyTest() {
+-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
++#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
+ // Mock the key storage, but not the process of getting the passwords.
+ UseMockKeyStorageForTesting(
+ []() -> KeyStorageLinux* { return OSCryptMockerLinux::GetInstance(); },
diff --git a/www/chromium/files/patch-content_test_BUILD.gn b/www/chromium/files/patch-content_test_BUILD.gn
index 5232b9fa78f3..e9290842b1f4 100644
--- a/www/chromium/files/patch-content_test_BUILD.gn
+++ b/www/chromium/files/patch-content_test_BUILD.gn
@@ -1,6 +1,6 @@
---- content/test/BUILD.gn.orig 2017-06-05 19:03:07 UTC
-+++ content/test/BUILD.gn
-@@ -815,7 +815,7 @@ test("content_browsertests") {
+--- content/test/BUILD.gn.orig 2017-06-15 21:03:05.000000000 +0200
++++ content/test/BUILD.gn 2017-06-22 13:52:52.066701000 +0200
+@@ -815,7 +815,7 @@
}
}
@@ -9,8 +9,22 @@
data += [
"$root_out_dir/content_shell.pak",
"data/",
-@@ -1442,7 +1442,7 @@ test("content_unittests") {
- sources += [ "../browser/memory/memory_monitor_linux_unittest.cc" ]
+@@ -1435,14 +1435,19 @@
+ sources += [ "../common/quarantine/quarantine_unittest.cc" ]
+ }
+
++ if (is_bsd) {
++ sources -= [
++ "../browser/memory/test_memory_monitor.cc",
++ "../common/quarantine/quarantine_linux_unittest.cc",
++ ]
++ }
++
+ # ChromeOS also defines linux but their memory-monitors conflict.
+ if (is_chromeos) {
+ sources += [ "../browser/memory/memory_monitor_chromeos_unittest.cc" ]
+- } else {
+- sources += [ "../browser/memory/memory_monitor_linux_unittest.cc" ]
}
- if (is_android || is_linux || is_mac || is_win) {
@@ -18,7 +32,7 @@
data = [
"$root_out_dir/content_shell.pak",
"data/",
-@@ -1657,7 +1657,7 @@ test("content_unittests") {
+@@ -1657,7 +1662,7 @@
"//ui/shell_dialogs:shell_dialogs",
]
@@ -27,7 +41,7 @@
sources +=
[ "../browser/media/capture/desktop_capture_device_unittest.cc" ]
deps += [ "//third_party/webrtc/modules/desktop_capture" ]
-@@ -1695,7 +1695,7 @@ test("content_unittests") {
+@@ -1695,7 +1700,7 @@
}
}
diff --git a/www/chromium/files/patch-content_test_suite.cc b/www/chromium/files/patch-content_test_suite.cc
new file mode 100644
index 000000000000..cb25cf9ebda6
--- /dev/null
+++ b/www/chromium/files/patch-content_test_suite.cc
@@ -0,0 +1,18 @@
+--- content/test/content_test_suite.cc.orig 2017-06-22 13:36:32.924786000 +0200
++++ content/test/content_test_suite.cc 2017-06-22 13:39:16.176707000 +0200
+@@ -85,6 +85,7 @@
+ // to initialize GL, so don't do it here.
+ bool is_child_process = base::CommandLine::ForCurrentProcess()->HasSwitch(
+ switches::kTestChildProcess);
++#if !defined(OS_BSD)
+ if (!is_child_process) {
+ gpu::GPUInfo gpu_info;
+ gpu::CollectBasicGraphicsInfo(&gpu_info);
+@@ -92,6 +93,7 @@
+ base::CommandLine::ForCurrentProcess());
+ gl::GLSurfaceTestSupport::InitializeOneOff();
+ }
++#endif
+ testing::TestEventListeners& listeners =
+ testing::UnitTest::GetInstance()->listeners();
+ listeners.Append(new TestInitializationListener);
diff --git a/www/chromium/files/patch-gpu_BUILD.gn b/www/chromium/files/patch-gpu_BUILD.gn
index b1e3465b5410..9e9382921a99 100644
--- a/www/chromium/files/patch-gpu_BUILD.gn
+++ b/www/chromium/files/patch-gpu_BUILD.gn
@@ -1,6 +1,6 @@
---- gpu/BUILD.gn.orig 2017-04-19 19:06:34 UTC
-+++ gpu/BUILD.gn
-@@ -96,7 +96,7 @@ test("command_buffer_gles2_tests") {
+--- gpu/BUILD.gn.orig 2017-06-15 21:03:06.000000000 +0200
++++ gpu/BUILD.gn 2017-06-22 12:14:14.034866000 +0200
+@@ -96,7 +96,7 @@
libs += [ "android" ]
deps += [ "//ui/android:ui_java" ]
}
@@ -9,3 +9,14 @@
configs += [ "//build/config/gcc:rpath_for_built_shared_libraries" ]
}
}
+@@ -321,6 +321,10 @@
+ "ipc/common/struct_traits_unittest.cc",
+ "ipc/host/shader_disk_cache_unittest.cc",
+ ]
++
++ if (is_bsd) {
++ sources -= [ "config/gpu_util_unittest.cc" ]
++ }
+
+ if (is_mac) {
+ sources += [ "ipc/client/gpu_memory_buffer_impl_io_surface_unittest.cc" ]
diff --git a/www/chromium/files/patch-gpu_gles2__conform__support_BUILD.gn b/www/chromium/files/patch-gpu_gles2__conform__support_BUILD.gn
index 82d02b2c1408..94491a70bd8c 100644
--- a/www/chromium/files/patch-gpu_gles2__conform__support_BUILD.gn
+++ b/www/chromium/files/patch-gpu_gles2__conform__support_BUILD.gn
@@ -1,6 +1,6 @@
---- gpu/gles2_conform_support/BUILD.gn.orig 2017-04-19 19:06:34 UTC
-+++ gpu/gles2_conform_support/BUILD.gn
-@@ -60,7 +60,7 @@ executable("gles2_conform_support") {
+--- gpu/gles2_conform_support/BUILD.gn.orig 2017-06-21 00:03:18.000000000 +0200
++++ gpu/gles2_conform_support/BUILD.gn 2017-06-22 14:00:33.510247000 +0200
+@@ -60,7 +60,7 @@
"//gpu/gles2_conform_support/egl",
"//ui/gl",
]
@@ -9,12 +9,3 @@
sources += [
"native/egl_native_aura.cc",
"native/egl_native_x11.cc",
-@@ -413,7 +413,7 @@ if (internal_gles2_conform_tests) {
- # Must be done this way for warning flags to be ordered correctly.
- ":gles2_conform_test_warnings",
- ]
-- if (is_linux) {
-+ if (is_linux || is_bsd) {
- if (!is_chromeos) {
- deps += [ "//build/config/linux/gtk2" ]
- }