aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-06-12 06:39:21 +0800
committerrene <rene@FreeBSD.org>2012-06-12 06:39:21 +0800
commit0259a62b91288a94f5809ec1deb6e2cdeaca89fd (patch)
tree4596b3ee983f6e49cf3d390bd65fa5a7ab6038e4 /www/chromium
parentf8bf590f64e74d59b5c1535caaa3ec00df5be712 (diff)
downloadfreebsd-ports-gnome-0259a62b91288a94f5809ec1deb6e2cdeaca89fd.tar.gz
freebsd-ports-gnome-0259a62b91288a94f5809ec1deb6e2cdeaca89fd.tar.zst
freebsd-ports-gnome-0259a62b91288a94f5809ec1deb6e2cdeaca89fd.zip
- Disable backtrace from libexecinfo which causes chrome to crash when compiled
with release CFLAGS under i386. - Bump PORTREVISION Submitted by: George Liaskos
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile1
-rw-r--r--www/chromium/files/patch-base__debug__stack_trace_posix.cc14
2 files changed, 15 insertions, 0 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 19b74b606162..a425f0bc3944 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -8,6 +8,7 @@
PORTNAME= chromium
DISTVERSIONPREFIX= courgette-redacted-
DISTVERSION= 19.0.1084.56
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.goodking.org/downloads/ \
ftp://rene-ladan.nl/pub/distfiles/ \
diff --git a/www/chromium/files/patch-base__debug__stack_trace_posix.cc b/www/chromium/files/patch-base__debug__stack_trace_posix.cc
new file mode 100644
index 000000000000..8dc782f1ff4c
--- /dev/null
+++ b/www/chromium/files/patch-base__debug__stack_trace_posix.cc
@@ -0,0 +1,14 @@
+--- base/debug/stack_trace_posix.cc.orig 2012-06-11 23:22:13.000000000 +0300
++++ base/debug/stack_trace_posix.cc 2012-06-12 00:09:38.000000000 +0300
+@@ -153,6 +153,11 @@
+ count_ = 0;
+ return;
+ }
++#elif defined(OS_FREEBSD)
++ // Disable backtrace for now, libexecinfo crashes in getframeaddr
++ // in release build / i386.
++ count_ = 0;
++ return;
+ #endif
+ // Though the backtrace API man page does not list any possible negative
+ // return values, we take no chance.