aboutsummaryrefslogtreecommitdiffstats
path: root/www/cl-lml
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /www/cl-lml
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'www/cl-lml')
-rw-r--r--www/cl-lml/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/cl-lml/Makefile b/www/cl-lml/Makefile
index 578e694a24f1..959532d79b78 100644
--- a/www/cl-lml/Makefile
+++ b/www/cl-lml/Makefile
@@ -6,6 +6,7 @@
PORTNAME= lml
PORTVERSION= 2.5.7
+PORTREVISION= 1
CATEGORIES= www textproc
MASTER_SITES= http://files.b9.com/lml/ \
http://people.bsdgroup.de/~as/freebsd/distfiles/
@@ -14,22 +15,19 @@ PKGNAMEPREFIX= cl-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Lisp Markup Language
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
+NO_BUILD= yes
-NO_BUILD= yes # installs the sources only
-CL_LIBDIR= ${PREFIX}/lib/common-lisp
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+USE_ASDF= yes
.if !defined(NOPORTDOCS)
PORTDOCS= Makefile make.lisp readme.html readme.lml
.endif
do-install:
- @${MKDIR} ${CL_LIBDIR}/lml
- @${INSTALL_DATA} ${WRKSRC}/*.lisp ${CL_LIBDIR}/lml
- @${INSTALL_DATA} ${WRKSRC}/lml.asd ${CL_LIBDIR}/lml
- @${LN} -sf ${CL_LIBDIR}/lml/lml.asd ${CL_LIBDIR}/system-registry/lml.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.lisp ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/lml.asd ${ASDF_PATHNAME}
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${PORTDOCS}
@@ -37,4 +35,5 @@ do-install:
.endfor
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>