aboutsummaryrefslogtreecommitdiffstats
path: root/www/cmsmadesimple
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-22 17:39:46 +0800
committermiwi <miwi@FreeBSD.org>2014-05-22 17:39:46 +0800
commitf7f83f96b7592afaa1d067c4e83968b5fc94b4c0 (patch)
tree48a8d70b2489f39d56e72535a8ffe9e71f9f7734 /www/cmsmadesimple
parentb698f62d3827b146ad90740af669d68e612c58ab (diff)
downloadfreebsd-ports-gnome-f7f83f96b7592afaa1d067c4e83968b5fc94b4c0.tar.gz
freebsd-ports-gnome-f7f83f96b7592afaa1d067c4e83968b5fc94b4c0.tar.zst
freebsd-ports-gnome-f7f83f96b7592afaa1d067c4e83968b5fc94b4c0.zip
- Stage support
PR: 190026 Submitted by: Joseph Benden <joe@thrallingpenguin.com>
Diffstat (limited to 'www/cmsmadesimple')
-rw-r--r--www/cmsmadesimple/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/cmsmadesimple/Makefile b/www/cmsmadesimple/Makefile
index 14e61c2144d3..7c2a5197167d 100644
--- a/www/cmsmadesimple/Makefile
+++ b/www/cmsmadesimple/Makefile
@@ -25,23 +25,22 @@ CMS_FILES= favicon_cms.ico fileloc.php include.php \
WRITABLE_DIRS= tmp tmp/templates_c tmp/cache \
uploads uploads/images modules
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
@cd ${WRKSRC} && ${RM} -f config.php
do-install:
.for i in ${CMS_DIRS}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${WWWDIR}
.endfor
.for i in ${CMS_FILES}
- @cd ${WRKSRC} && ${CP} ${i} ${WWWDIR}/${i}
+ @cd ${WRKSRC} && ${CP} ${i} ${STAGEDIR}${WWWDIR}/${i}
.endfor
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${CHMOD} -R 755 ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
+ @${CHMOD} -R 755 ${STAGEDIR}${WWWDIR}
- @if [ ! -f ${WWWDIR}/config.php ]; then \
- ${TOUCH} ${WWWDIR}/config.php ; fi
+ @if [ ! -f ${STAGEDIR}${WWWDIR}/config.php ]; then \
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/config.php ; fi
post-install:
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' \
@@ -50,12 +49,12 @@ post-install:
>> ${TMPPLIST}
.for i in ${WRITABLE_DIRS}
- @${CHMOD} 775 ${WWWDIR}/${i}
+ @${CHMOD} 775 ${STAGEDIR}${WWWDIR}/${i}
@${ECHO_CMD} '@exec ${CHMOD} 775 ${WWWDIR}/${i}' \
>> ${TMPPLIST}
.endfor
- @${CHMOD} 666 ${WWWDIR}/config.php
+ @${CHMOD} 666 ${STAGEDIR}${WWWDIR}/config.php
@${ECHO_CMD} '@exec ${CHMOD} 666 ${WWWDIR}/config.php' \
>> ${TMPPLIST}