aboutsummaryrefslogtreecommitdiffstats
path: root/www/codeigniter
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2011-05-03 22:38:10 +0800
committerglarkin <glarkin@FreeBSD.org>2011-05-03 22:38:10 +0800
commit765e12305bd26acec64650fde4e0ffa2a87d6ec5 (patch)
treeae76742bec9e988a65cc1e74601c179462cec7ce /www/codeigniter
parent98ab28da180ebc6ff6f41abc8180e4f4a440089f (diff)
downloadfreebsd-ports-gnome-765e12305bd26acec64650fde4e0ffa2a87d6ec5.tar.gz
freebsd-ports-gnome-765e12305bd26acec64650fde4e0ffa2a87d6ec5.tar.zst
freebsd-ports-gnome-765e12305bd26acec64650fde4e0ffa2a87d6ec5.zip
- Renamed www/codeigniter-devel to www/codeigniter by updating to version
2.0.3 here - Added CONFLICTS for www/codeigniter17 Approved by: appleboy.tw@gmail.com (maintainer)
Diffstat (limited to 'www/codeigniter')
-rw-r--r--www/codeigniter/Makefile72
-rw-r--r--www/codeigniter/distinfo4
-rw-r--r--www/codeigniter/files/pkg-message-apache.in6
-rw-r--r--www/codeigniter/files/pkg-message-noapache.in6
-rw-r--r--www/codeigniter/pkg-plist317
5 files changed, 126 insertions, 279 deletions
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index 5cb3ddcedc8d..43827c9cc562 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -6,63 +6,73 @@
#
PORTNAME= codeigniter
-PORTVERSION= 1.7.3
+PORTVERSION= 2.0.3
CATEGORIES= www
-MASTER_SITES= http://codeigniter.com/download_files/ \
- LOCAL/glarkin
-DISTNAME= CodeIgniter_${PORTVERSION}
+MASTER_SITES= https://bitbucket.org/ellislab/codeigniter-reactor/get/
+PKGNAMESUFFIX= -devel
+DISTNAME= 13e8f9b4feba
-MAINTAINER= glarkin@FreeBSD.org
+MAINTAINER= appleboy.tw@gmail.com
COMMENT= A framework for developing PHP web applications
USE_ZIP= yes
+CONFLICTS= codeigniter-1.[0-9]*
+
NO_BUILD= yes
USE_PHP= session pcre
WANT_PHP_WEB= yes
CI_SYS_DIR= system
-CI_CONF_DIR= ${CI_SYS_DIR}/application/config
+CI_CONF_DIR= application/config
+WRKSRC= ${WRKDIR}/ellislab-codeigniter-reactor-${DISTNAME}
+WWWDIR= ${PREFIX}/www/codeigniter
+PORTDOCS= *
+
+LATEST_LINK= codeigniter-devel
# These are all user-configurable files that we'll install
-# a .sample copy for each.
CI_CONF_FILES= index.php ${CI_CONF_DIR}/autoload.php \
${CI_CONF_DIR}/config.php ${CI_CONF_DIR}/constants.php \
${CI_CONF_DIR}/database.php \
- ${CI_CONF_DIR}/hooks.php ${CI_CONF_DIR}/mimes.php \
+ ${CI_CONF_DIR}/doctypes.php \
+ ${CI_CONF_DIR}/foreign_chars.php \
+ ${CI_CONF_DIR}/hooks.php \
+ ${CI_CONF_DIR}/mimes.php \
+ ${CI_CONF_DIR}/profiler.php \
${CI_CONF_DIR}/routes.php ${CI_CONF_DIR}/smileys.php \
${CI_CONF_DIR}/user_agents.php
# This is the rest of the CodeIgniter installation that doesn't change
STD_BITS= ${CI_CONF_DIR}/index.html \
- ${CI_SYS_DIR}/application/controllers \
- ${CI_SYS_DIR}/application/errors \
- ${CI_SYS_DIR}/application/helpers \
- ${CI_SYS_DIR}/application/hooks \
- ${CI_SYS_DIR}/application/index.html \
- ${CI_SYS_DIR}/application/language \
- ${CI_SYS_DIR}/application/libraries \
- ${CI_SYS_DIR}/application/models \
- ${CI_SYS_DIR}/application/views \
- ${CI_SYS_DIR}/cache \
- ${CI_SYS_DIR}/codeigniter \
+ application/cache \
+ application/controllers \
+ application/core \
+ application/errors \
+ application/helpers \
+ application/hooks \
+ application/index.html \
+ application/language \
+ application/libraries \
+ application/logs \
+ application/models \
+ application/third_party \
+ application/views \
+ ${CI_SYS_DIR}/core \
${CI_SYS_DIR}/database \
${CI_SYS_DIR}/fonts \
${CI_SYS_DIR}/helpers \
${CI_SYS_DIR}/language \
- ${CI_SYS_DIR}/libraries \
- ${CI_SYS_DIR}/logs \
- ${CI_SYS_DIR}/plugins \
- ${CI_SYS_DIR}/scaffolding
+ ${CI_SYS_DIR}/libraries
OPTIONS= APACHE "Configure for Apache-2.x" off \
- PROD "Install for production server (see: make confighelp)" Off \
- MSSQL "Install MSSQL support for PHP" Off \
- MYSQL "Install MySQL support for PHP" Off \
- MYSQLI "Install MySQLi support for PHP" Off \
- ODBC "Install ODBC support for PHP" Off \
- PGSQL "Install PostgreSQL support for PHP" Off \
- SQLITE "Install SQLite support for PHP" Off
+ PROD "Install for production server (see: make confighelp)" Off \
+ MSSQL "Install MSSQL support for PHP" Off \
+ MYSQL "Install MySQL support for PHP" Off \
+ MYSQLI "Install MySQLi support for PHP" Off \
+ ODBC "Install ODBC support for PHP" Off \
+ PGSQL "Install PostgreSQL support for PHP" Off \
+ SQLITE "Install SQLite support for PHP" Off
.include <bsd.port.pre.mk>
@@ -187,7 +197,7 @@ post-install:
fi
.endif
.if !defined(NOPORTDOCS)
- @cd ${WRKSRC}/user_guide/ && ${COPYTREE_SHARE} . ${DOCSDIR}
+ @cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/www/codeigniter/distinfo b/www/codeigniter/distinfo
index 66024df49f51..760b34b9eebc 100644
--- a/www/codeigniter/distinfo
+++ b/www/codeigniter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CodeIgniter_1.7.3.zip) = df207c4bf4b1a34de54f21e269cd4bffe894f1b429d12b9b040e9067dac545fe
-SIZE (CodeIgniter_1.7.3.zip) = 2234099
+SHA256 (13e8f9b4feba.zip) = 8b769267eb2e8b5568f03a0df5e54e65b396beb9b9681b555a0f23586af1444a
+SIZE (13e8f9b4feba.zip) = 2259258
diff --git a/www/codeigniter/files/pkg-message-apache.in b/www/codeigniter/files/pkg-message-apache.in
index ba70e0fca94e..800f3358b738 100644
--- a/www/codeigniter/files/pkg-message-apache.in
+++ b/www/codeigniter/files/pkg-message-apache.in
@@ -7,16 +7,16 @@ the CodeIgniter configuration file is loaded.
Optional post-installation instructions include:
-- Open the %%WWWDIR%%/system/application/config/config.php
+- Open the %%WWWDIR%%/application/config/config.php
file with a text editor and set your base URL.
- If you intend to use a database, open the
- %%WWWDIR%%/system/application/config/database.php
+ %%WWWDIR%%/application/config/database.php
file with a text editor and set your database settings.
- Other user-configurable files include:
%%WWWDIR%%/index.php
- Any file located in %%WWWDIR%%/system/application/config
+ Any file located in %%WWWDIR%%/application/config
- If you are upgrading from a prior release, please visit:
http://codeigniter.com/user_guide/installation/upgrading.html
diff --git a/www/codeigniter/files/pkg-message-noapache.in b/www/codeigniter/files/pkg-message-noapache.in
index fa06056f1d74..e1e63d89e1bf 100644
--- a/www/codeigniter/files/pkg-message-noapache.in
+++ b/www/codeigniter/files/pkg-message-noapache.in
@@ -4,16 +4,16 @@ You have just installed the CodeIgniter web application framework.
Optional post-installation instructions include:
-- Open the %%WWWDIR%%/system/application/config/config.php
+- Open the %%WWWDIR%%/application/config/config.php
file with a text editor and set your base URL.
- If you intend to use a database, open the
- %%WWWDIR%%/system/application/config/database.php
+ %%WWWDIR%%/application/config/database.php
file with a text editor and set your database settings.
- Other user-configurable files include:
%%WWWDIR%%/index.php
- Any file located in %%WWWDIR%%/system/application/config
+ Any file located in %%WWWDIR%%/application/config
- If you are upgrading from a prior release, please visit:
http://codeigniter.com/user_guide/installation/upgrading.html
diff --git a/www/codeigniter/pkg-plist b/www/codeigniter/pkg-plist
index ebf4990ac6be..cf9625264f48 100644
--- a/www/codeigniter/pkg-plist
+++ b/www/codeigniter/pkg-plist
@@ -1,159 +1,7 @@
%%NOAPACHE%%%%CONFDIR%%/codeigniter.conf
-%%PORTDOCS%%%%DOCSDIR%%/changelog.html
-%%PORTDOCS%%%%DOCSDIR%%/database/active_record.html
-%%PORTDOCS%%%%DOCSDIR%%/database/caching.html
-%%PORTDOCS%%%%DOCSDIR%%/database/call_function.html
-%%PORTDOCS%%%%DOCSDIR%%/database/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/database/connecting.html
-%%PORTDOCS%%%%DOCSDIR%%/database/examples.html
-%%PORTDOCS%%%%DOCSDIR%%/database/fields.html
-%%PORTDOCS%%%%DOCSDIR%%/database/forge.html
-%%PORTDOCS%%%%DOCSDIR%%/database/helpers.html
-%%PORTDOCS%%%%DOCSDIR%%/database/index.html
-%%PORTDOCS%%%%DOCSDIR%%/database/queries.html
-%%PORTDOCS%%%%DOCSDIR%%/database/results.html
-%%PORTDOCS%%%%DOCSDIR%%/database/table_data.html
-%%PORTDOCS%%%%DOCSDIR%%/database/transactions.html
-%%PORTDOCS%%%%DOCSDIR%%/database/utilities.html
-%%PORTDOCS%%%%DOCSDIR%%/doc_style/index.html
-%%PORTDOCS%%%%DOCSDIR%%/doc_style/template.html
-%%PORTDOCS%%%%DOCSDIR%%/general/alternative_php.html
-%%PORTDOCS%%%%DOCSDIR%%/general/ancillary_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/general/autoloader.html
-%%PORTDOCS%%%%DOCSDIR%%/general/caching.html
-%%PORTDOCS%%%%DOCSDIR%%/general/common_functions.html
-%%PORTDOCS%%%%DOCSDIR%%/general/controllers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/core_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/general/creating_libraries.html
-%%PORTDOCS%%%%DOCSDIR%%/general/credits.html
-%%PORTDOCS%%%%DOCSDIR%%/general/errors.html
-%%PORTDOCS%%%%DOCSDIR%%/general/helpers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/hooks.html
-%%PORTDOCS%%%%DOCSDIR%%/general/libraries.html
-%%PORTDOCS%%%%DOCSDIR%%/general/managing_apps.html
-%%PORTDOCS%%%%DOCSDIR%%/general/models.html
-%%PORTDOCS%%%%DOCSDIR%%/general/plugins.html
-%%PORTDOCS%%%%DOCSDIR%%/general/profiling.html
-%%PORTDOCS%%%%DOCSDIR%%/general/quick_reference.html
-%%PORTDOCS%%%%DOCSDIR%%/general/requirements.html
-%%PORTDOCS%%%%DOCSDIR%%/general/reserved_names.html
-%%PORTDOCS%%%%DOCSDIR%%/general/routing.html
-%%PORTDOCS%%%%DOCSDIR%%/general/scaffolding.html
-%%PORTDOCS%%%%DOCSDIR%%/general/security.html
-%%PORTDOCS%%%%DOCSDIR%%/general/styleguide.html
-%%PORTDOCS%%%%DOCSDIR%%/general/urls.html
-%%PORTDOCS%%%%DOCSDIR%%/general/views.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/array_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/compatibility_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/cookie_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/date_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/directory_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/download_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/email_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/file_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/form_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/html_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/inflector_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/language_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/number_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/path_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/security_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/smiley_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/string_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/text_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/typography_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/url_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/xml_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/images/appflowchart.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/arrow.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/ci_logo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/ci_logo_flame.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/ci_quick_ref.png
-%%PORTDOCS%%%%DOCSDIR%%/images/codeigniter_1.7.1_helper_reference.pdf
-%%PORTDOCS%%%%DOCSDIR%%/images/codeigniter_1.7.1_helper_reference.png
-%%PORTDOCS%%%%DOCSDIR%%/images/codeigniter_1.7.1_library_reference.pdf
-%%PORTDOCS%%%%DOCSDIR%%/images/codeigniter_1.7.1_library_reference.png
-%%PORTDOCS%%%%DOCSDIR%%/images/file.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/folder.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_bg.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_bg_darker.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_separator.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_separator_darker.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_toggle.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/nav_toggle_darker.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/smile.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/transparent.gif
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/downloads.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/troubleshooting.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_120.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_130.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_131.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_132.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_133.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_140.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_141.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_150.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_152.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_153.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_154.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_160.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_161.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_162.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_163.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_170.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_171.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_172.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_173.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_b11.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrading.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/benchmark.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/calendar.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/cart.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/config.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/email.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/encryption.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/file_uploading.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/form_validation.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/ftp.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/image_lib.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/input.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/language.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/loader.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/output.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/pagination.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/parser.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/sessions.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/table.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/trackback.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/typography.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/unit_testing.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/uri.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/user_agent.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/validation.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/xmlrpc.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/zip.html
-%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/nav/hacks.txt
-%%PORTDOCS%%%%DOCSDIR%%/nav/moo.fx.js
-%%PORTDOCS%%%%DOCSDIR%%/nav/moo.fx.pack.js
-%%PORTDOCS%%%%DOCSDIR%%/nav/nav.js
-%%PORTDOCS%%%%DOCSDIR%%/nav/prototype.lite.js
-%%PORTDOCS%%%%DOCSDIR%%/nav/user_guide_menu.js
-%%PORTDOCS%%%%DOCSDIR%%/overview/appflow.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/at_a_glance.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/cheatsheets.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/features.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/getting_started.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/goals.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/index.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/mvc.html
-%%PORTDOCS%%%%DOCSDIR%%/toc.html
-%%PORTDOCS%%%%DOCSDIR%%/userguide.css
-@unexec if cmp -s %D/%%WWWDIR%%/index.php.sample %D/%%WWWDIR%%/index.php; then rm -f %D/%%WWWDIR%%/index.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/index.php has not been removed"; fi
-%%WWWDIR%%/index.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/index.php ]; then cp -p %D/%F %B/index.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/index.php has not been overwritten"; fi
+%%WWWDIR%%/application/cache/.htaccess
+%%WWWDIR%%/application/cache/index.html
+%%WWWDIR%%/application/config/index.html
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php ]; then cp -p %D/%F %B/autoload.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php has not been overwritten"; fi
@@ -166,13 +14,21 @@
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php ]; then cp -p %D/%F %B/database.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php has not been overwritten"; fi
+@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php has not been removed"; fi
+%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php ]; then cp -p %D/%F %B/doctypes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/doctypes.php has not been overwritten"; fi
+@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php has not been removed"; fi
+%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php ]; then cp -p %D/%F %B/foreign_chars.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/foreign_chars.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php ]; then cp -p %D/%F %B/hooks.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php has not been overwritten"; fi
-%%WWWDIR%%/%%CI_CONF_DIR%%/index.html
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php ]; then cp -p %D/%F %B/mimes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php has not been overwritten"; fi
+@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php has not been removed"; fi
+%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php ]; then cp -p %D/%F %B/profiler.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/profiler.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php ]; then cp -p %D/%F %B/routes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php has not been overwritten"; fi
@@ -182,28 +38,43 @@
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php.sample
@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php ]; then cp -p %D/%F %B/user_agents.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php has not been overwritten"; fi
-%%WWWDIR%%/system/application/controllers/index.html
-%%WWWDIR%%/system/application/controllers/welcome.php
-%%WWWDIR%%/system/application/errors/error_404.php
-%%WWWDIR%%/system/application/errors/error_db.php
-%%WWWDIR%%/system/application/errors/error_general.php
-%%WWWDIR%%/system/application/errors/error_php.php
-%%WWWDIR%%/system/application/errors/index.html
-%%WWWDIR%%/system/application/helpers/index.html
-%%WWWDIR%%/system/application/hooks/index.html
-%%WWWDIR%%/system/application/index.html
-%%WWWDIR%%/system/application/language/english/index.html
-%%WWWDIR%%/system/application/libraries/index.html
-%%WWWDIR%%/system/application/models/index.html
-%%WWWDIR%%/system/application/views/index.html
-%%WWWDIR%%/system/application/views/welcome_message.php
-%%WWWDIR%%/system/cache/index.html
-%%WWWDIR%%/system/codeigniter/Base4.php
-%%WWWDIR%%/system/codeigniter/Base5.php
-%%WWWDIR%%/system/codeigniter/CodeIgniter.php
-%%WWWDIR%%/system/codeigniter/Common.php
-%%WWWDIR%%/system/codeigniter/Compat.php
-%%WWWDIR%%/system/codeigniter/index.html
+%%WWWDIR%%/application/controllers/index.html
+%%WWWDIR%%/application/controllers/welcome.php
+%%WWWDIR%%/application/core/index.html
+%%WWWDIR%%/application/errors/error_404.php
+%%WWWDIR%%/application/errors/error_db.php
+%%WWWDIR%%/application/errors/error_general.php
+%%WWWDIR%%/application/errors/error_php.php
+%%WWWDIR%%/application/errors/index.html
+%%WWWDIR%%/application/helpers/index.html
+%%WWWDIR%%/application/hooks/index.html
+%%WWWDIR%%/application/index.html
+%%WWWDIR%%/application/language/english/index.html
+%%WWWDIR%%/application/libraries/index.html
+%%WWWDIR%%/application/logs/index.html
+%%WWWDIR%%/application/models/index.html
+%%WWWDIR%%/application/third_party/index.html
+%%WWWDIR%%/application/views/index.html
+%%WWWDIR%%/application/views/welcome_message.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/index.php.sample
+%%WWWDIR%%/system/core/Benchmark.php
+%%WWWDIR%%/system/core/CodeIgniter.php
+%%WWWDIR%%/system/core/Common.php
+%%WWWDIR%%/system/core/Config.php
+%%WWWDIR%%/system/core/Controller.php
+%%WWWDIR%%/system/core/Exceptions.php
+%%WWWDIR%%/system/core/Hooks.php
+%%WWWDIR%%/system/core/Input.php
+%%WWWDIR%%/system/core/Lang.php
+%%WWWDIR%%/system/core/Loader.php
+%%WWWDIR%%/system/core/Model.php
+%%WWWDIR%%/system/core/Output.php
+%%WWWDIR%%/system/core/Router.php
+%%WWWDIR%%/system/core/Security.php
+%%WWWDIR%%/system/core/URI.php
+%%WWWDIR%%/system/core/Utf8.php
+%%WWWDIR%%/system/core/index.html
%%WWWDIR%%/system/database/DB.php
%%WWWDIR%%/system/database/DB_active_rec.php
%%WWWDIR%%/system/database/DB_cache.php
@@ -251,7 +122,7 @@
%%WWWDIR%%/system/fonts/index.html
%%WWWDIR%%/system/fonts/texb.ttf
%%WWWDIR%%/system/helpers/array_helper.php
-%%WWWDIR%%/system/helpers/compatibility_helper.php
+%%WWWDIR%%/system/helpers/captcha_helper.php
%%WWWDIR%%/system/helpers/cookie_helper.php
%%WWWDIR%%/system/helpers/date_helper.php
%%WWWDIR%%/system/helpers/directory_helper.php
@@ -282,70 +153,43 @@
%%WWWDIR%%/system/language/english/index.html
%%WWWDIR%%/system/language/english/number_lang.php
%%WWWDIR%%/system/language/english/profiler_lang.php
-%%WWWDIR%%/system/language/english/scaffolding_lang.php
%%WWWDIR%%/system/language/english/unit_test_lang.php
%%WWWDIR%%/system/language/english/upload_lang.php
-%%WWWDIR%%/system/language/english/validation_lang.php
%%WWWDIR%%/system/language/index.html
-%%WWWDIR%%/system/libraries/Benchmark.php
+%%WWWDIR%%/system/libraries/Cache/Cache.php
+%%WWWDIR%%/system/libraries/Cache/drivers/Cache_apc.php
+%%WWWDIR%%/system/libraries/Cache/drivers/Cache_dummy.php
+%%WWWDIR%%/system/libraries/Cache/drivers/Cache_file.php
+%%WWWDIR%%/system/libraries/Cache/drivers/Cache_memcached.php
%%WWWDIR%%/system/libraries/Calendar.php
%%WWWDIR%%/system/libraries/Cart.php
-%%WWWDIR%%/system/libraries/Config.php
-%%WWWDIR%%/system/libraries/Controller.php
+%%WWWDIR%%/system/libraries/Driver.php
%%WWWDIR%%/system/libraries/Email.php
%%WWWDIR%%/system/libraries/Encrypt.php
-%%WWWDIR%%/system/libraries/Exceptions.php
%%WWWDIR%%/system/libraries/Form_validation.php
%%WWWDIR%%/system/libraries/Ftp.php
-%%WWWDIR%%/system/libraries/Hooks.php
%%WWWDIR%%/system/libraries/Image_lib.php
-%%WWWDIR%%/system/libraries/Input.php
-%%WWWDIR%%/system/libraries/Language.php
-%%WWWDIR%%/system/libraries/Loader.php
+%%WWWDIR%%/system/libraries/Javascript.php
%%WWWDIR%%/system/libraries/Log.php
-%%WWWDIR%%/system/libraries/Model.php
-%%WWWDIR%%/system/libraries/Output.php
%%WWWDIR%%/system/libraries/Pagination.php
%%WWWDIR%%/system/libraries/Parser.php
%%WWWDIR%%/system/libraries/Profiler.php
-%%WWWDIR%%/system/libraries/Router.php
%%WWWDIR%%/system/libraries/Session.php
%%WWWDIR%%/system/libraries/Sha1.php
%%WWWDIR%%/system/libraries/Table.php
%%WWWDIR%%/system/libraries/Trackback.php
%%WWWDIR%%/system/libraries/Typography.php
-%%WWWDIR%%/system/libraries/URI.php
%%WWWDIR%%/system/libraries/Unit_test.php
%%WWWDIR%%/system/libraries/Upload.php
%%WWWDIR%%/system/libraries/User_agent.php
-%%WWWDIR%%/system/libraries/Validation.php
%%WWWDIR%%/system/libraries/Xmlrpc.php
%%WWWDIR%%/system/libraries/Xmlrpcs.php
%%WWWDIR%%/system/libraries/Zip.php
%%WWWDIR%%/system/libraries/index.html
-%%WWWDIR%%/system/logs/index.html
-%%WWWDIR%%/system/plugins/captcha_pi.php
-%%WWWDIR%%/system/plugins/index.html
-%%WWWDIR%%/system/plugins/js_calendar_pi.php
-%%WWWDIR%%/system/scaffolding/Scaffolding.php
-%%WWWDIR%%/system/scaffolding/images/background.jpg
-%%WWWDIR%%/system/scaffolding/images/index.html
-%%WWWDIR%%/system/scaffolding/images/logo.jpg
-%%WWWDIR%%/system/scaffolding/index.html
-%%WWWDIR%%/system/scaffolding/views/add.php
-%%WWWDIR%%/system/scaffolding/views/delete.php
-%%WWWDIR%%/system/scaffolding/views/edit.php
-%%WWWDIR%%/system/scaffolding/views/footer.php
-%%WWWDIR%%/system/scaffolding/views/header.php
-%%WWWDIR%%/system/scaffolding/views/index.html
-%%WWWDIR%%/system/scaffolding/views/no_data.php
-%%WWWDIR%%/system/scaffolding/views/stylesheet.css
-%%WWWDIR%%/system/scaffolding/views/view.php
-@dirrm %%WWWDIR%%/system/scaffolding/views
-@dirrm %%WWWDIR%%/system/scaffolding/images
-@dirrm %%WWWDIR%%/system/scaffolding
-@dirrm %%WWWDIR%%/system/plugins
-@dirrm %%WWWDIR%%/system/logs
+%%WWWDIR%%/system/libraries/javascript/Jquery.php
+@dirrm %%WWWDIR%%/system/libraries/javascript
+@dirrm %%WWWDIR%%/system/libraries/Cache/drivers
+@dirrm %%WWWDIR%%/system/libraries/Cache
@dirrm %%WWWDIR%%/system/libraries
@dirrm %%WWWDIR%%/system/language/english
@dirrm %%WWWDIR%%/system/language
@@ -360,28 +204,21 @@
@dirrm %%WWWDIR%%/system/database/drivers/mssql
@dirrm %%WWWDIR%%/system/database/drivers
@dirrm %%WWWDIR%%/system/database
-@dirrm %%WWWDIR%%/system/codeigniter
-@dirrm %%WWWDIR%%/system/cache
-@dirrm %%WWWDIR%%/system/application/views
-@dirrm %%WWWDIR%%/system/application/models
-@dirrm %%WWWDIR%%/system/application/libraries
-@dirrm %%WWWDIR%%/system/application/language/english
-@dirrm %%WWWDIR%%/system/application/language
-@dirrm %%WWWDIR%%/system/application/hooks
-@dirrm %%WWWDIR%%/system/application/helpers
-@dirrm %%WWWDIR%%/system/application/errors
-@dirrm %%WWWDIR%%/system/application/controllers
-@dirrmtry %%WWWDIR%%/system/application/config
-@dirrmtry %%WWWDIR%%/system/application
+@dirrm %%WWWDIR%%/system/core
@dirrmtry %%WWWDIR%%/system
+@dirrm %%WWWDIR%%/application/views
+@dirrm %%WWWDIR%%/application/third_party
+@dirrm %%WWWDIR%%/application/models
+@dirrm %%WWWDIR%%/application/logs
+@dirrm %%WWWDIR%%/application/libraries
+@dirrm %%WWWDIR%%/application/language/english
+@dirrm %%WWWDIR%%/application/language
+@dirrm %%WWWDIR%%/application/hooks
+@dirrm %%WWWDIR%%/application/helpers
+@dirrm %%WWWDIR%%/application/errors
+@dirrm %%WWWDIR%%/application/core
+@dirrm %%WWWDIR%%/application/controllers
+@dirrmtry %%WWWDIR%%/application/config
+@dirrm %%WWWDIR%%/application/cache
+@dirrmtry %%WWWDIR%%/application
@dirrmtry %%WWWDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/overview
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/nav
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/libraries
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/installation
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/helpers
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/general
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc_style
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/database
-%%PORTDOCS%%@dirrm %%DOCSDIR%%