aboutsummaryrefslogtreecommitdiffstats
path: root/www/codeigniter
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-11-01 10:24:31 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-11-01 10:24:31 +0800
commit75ff58903d39659e6b726694e5393299ad0c57de (patch)
tree8e3853753d7f40babb9e59f2ab558babb7e0592d /www/codeigniter
parent45af8c513d04bc7d3a6c68d1147d0e6d50f6870e (diff)
downloadfreebsd-ports-gnome-75ff58903d39659e6b726694e5393299ad0c57de.tar.gz
freebsd-ports-gnome-75ff58903d39659e6b726694e5393299ad0c57de.tar.zst
freebsd-ports-gnome-75ff58903d39659e6b726694e5393299ad0c57de.zip
www/codeigniter: update 2.2.5 -> 2.2.6
- Update PORTVERSION and distinfo for security release (2.2.6) - Take MAINTAINER [1] - Register CONFLICTS for upcoming 3.x release - Add additional line breaks into file list - Convert to options helpers and reorder variables - Unmute do-install commands - Fix WWW: - Fix NOAPACHE variable in pkg-plist to match option (APACHE) PR: 203403 Approved by: maintainer timeout (16 months since last submission) [1] Security: https://vuxml.FreeBSD.org/freebsd/bdd57272-803c-11e5-ab94-002590263bf5.html MFH: 2015Q4
Diffstat (limited to 'www/codeigniter')
-rw-r--r--www/codeigniter/Makefile92
-rw-r--r--www/codeigniter/distinfo4
-rw-r--r--www/codeigniter/pkg-descr2
-rw-r--r--www/codeigniter/pkg-plist2
4 files changed, 38 insertions, 62 deletions
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index 5abb88b10f53..ddbdcbd0090b 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -2,17 +2,17 @@
# $FreeBSD$
PORTNAME= codeigniter
-PORTVERSION= 2.2.5
+PORTVERSION= 2.2.6
CATEGORIES= www
-MAINTAINER= appleboy.tw@gmail.com
+MAINTAINER= junovitch@FreeBSD.org
COMMENT= Framework for developing PHP web applications
USES= tar:tgz
USE_GITHUB= yes
GH_ACCOUNT= bcit-ci
-CONFLICTS= codeigniter-1.[0-9]*
+CONFLICTS= codeigniter-1.[0-9]* codeigniter-3.[0-9]*
NO_ARCH= yes
NO_BUILD= yes
@@ -26,8 +26,10 @@ WRKSRC= ${WRKDIR}/CodeIgniter-${PORTVERSION}
PORTDOCS= *
# These are all user-configurable files that we'll install
-CI_CONF_FILES= index.php ${CI_CONF_DIR}/autoload.php \
- ${CI_CONF_DIR}/config.php ${CI_CONF_DIR}/constants.php \
+CI_CONF_FILES= index.php \
+ ${CI_CONF_DIR}/autoload.php \
+ ${CI_CONF_DIR}/config.php \
+ ${CI_CONF_DIR}/constants.php \
${CI_CONF_DIR}/database.php \
${CI_CONF_DIR}/doctypes.php \
${CI_CONF_DIR}/foreign_chars.php \
@@ -35,7 +37,8 @@ CI_CONF_FILES= index.php ${CI_CONF_DIR}/autoload.php \
${CI_CONF_DIR}/mimes.php \
${CI_CONF_DIR}/migration.php \
${CI_CONF_DIR}/profiler.php \
- ${CI_CONF_DIR}/routes.php ${CI_CONF_DIR}/smileys.php \
+ ${CI_CONF_DIR}/routes.php \
+ ${CI_CONF_DIR}/smileys.php \
${CI_CONF_DIR}/user_agents.php
# This is the rest of the CodeIgniter installation that doesn't change
@@ -61,6 +64,10 @@ STD_BITS= ${CI_CONF_DIR}/index.html \
${CI_SYS_DIR}/libraries
OPTIONS_DEFINE= APACHE DOCS MSSQL MYSQL MYSQLI ODBC PGSQL SQLITE
+OPTIONS_SUB= yes
+
+SUB_FILES= pkg-message
+PLIST_SUB+= ECHO_MSG=${ECHO_MSG} CI_CONF_DIR=${CI_CONF_DIR}
APACHE_DESC= Configure for Apache-2.x
MSSQL_DESC= Install MSSQL support for PHP
@@ -70,64 +77,33 @@ ODBC_DESC= Install ODBC support for PHP
PGSQL_DESC= Install PostgreSQL support for PHP
SQLITE_DESC= Install SQLite support for PHP
-.include <bsd.port.pre.mk>
-
-SUB_FILES= pkg-message
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
-PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
+APACHE_VARS= USE_APACHE_RUN=22+
+DOCS_VARS= SUB_LIST+=HASHMARK=
+DOCS_VARS_OFF= SUB_LIST+=HASHMARK=\#
+MSSQL_VARS= USE_PHP+=mssql
+MYSQL_VARS= USE_PHP+=mysql
+MYSQLI_VARS= USE_PHP+=mysqli
+ODBC_VARS= USE_PHP+=odbc
+PGSQL_VARS= USE_PHP+=pgsql
+SQLITE_VARS= USE_PHP+=sqlite3
+
+# These variables are specifically defined for Apache
+CONF= codeigniter.conf
CONFDIR= ${PREFIX}/${CONFDIR_REL}
CONFDIR_REL= ${APACHEETCDIR}/Includes
-.else
-PLIST_SUB+= NOAPACHE="@comment "
-.endif
-PLIST_SUB+= ECHO_MSG=${ECHO_MSG} CI_CONF_DIR=${CI_CONF_DIR}
-
-.if ${PORT_OPTIONS:MMSSQL}
-USE_PHP+= mssql
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MMYSQLI}
-USE_PHP+= mysqli
-.endif
-
-.if ${PORT_OPTIONS:MODBC}
-USE_PHP+= odbc
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite3
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-SUB_LIST+= HASHMARK=\#
-.else
-SUB_LIST+= HASHMARK=
-.endif
-
-CONF= codeigniter.conf
+PLIST_SUB+= CONFDIR=${CONFDIR_REL}
SUB_FILES+= ${CONF}
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "${STD_BITS}" ${STAGEDIR}${WWWDIR}
- @for i in ${CI_CONF_FILES}; do \
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${STD_BITS}" ${STAGEDIR}${WWWDIR}
+ for i in ${CI_CONF_FILES}; do \
${INSTALL_DATA} ${WRKSRC}/$$i ${STAGEDIR}${WWWDIR}/$$i.sample; \
done
-post-install:
-.if ${PORT_OPTIONS:MAPACHE}
- ${CP} ${WRKDIR}/${CONF} ${STAGEDIR}${CONFDIR}/codeigniter.conf;
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- @cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-.endif
+post-install-APACHE-on:
+ ${MKDIR} ${STAGEDIR}${CONFDIR}
+ ${CP} ${WRKDIR}/${CONF} ${STAGEDIR}${CONFDIR}/codeigniter.conf;
+post-install-DOCS-on:
+ cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/codeigniter/distinfo b/www/codeigniter/distinfo
index 301f27c94389..e0b2587ff685 100644
--- a/www/codeigniter/distinfo
+++ b/www/codeigniter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bcit-ci-codeigniter-2.2.5_GH0.tgz) = c529a0016ae982c67ee899475fa5cdf4b27ffed4d18714270f78e3a4554d9de3
-SIZE (bcit-ci-codeigniter-2.2.5_GH0.tgz) = 1970502
+SHA256 (bcit-ci-codeigniter-2.2.6_GH0.tgz) = 3105487ab24430027d0a8ed49329d84e59c3f464be492e1d427d3b49352fbe85
+SIZE (bcit-ci-codeigniter-2.2.6_GH0.tgz) = 1971743
diff --git a/www/codeigniter/pkg-descr b/www/codeigniter/pkg-descr
index 3efcf744cb0e..36ddeb8d1639 100644
--- a/www/codeigniter/pkg-descr
+++ b/www/codeigniter/pkg-descr
@@ -2,4 +2,4 @@ CodeIgniter is a powerful PHP framework with a very small footprint,
built for developers who need a simple and elegant toolkit to create
full-featured web applications.
-WWW: http://http://www.codeigniter.com/
+WWW: http://www.codeigniter.com/
diff --git a/www/codeigniter/pkg-plist b/www/codeigniter/pkg-plist
index 423dab819f54..866764add03f 100644
--- a/www/codeigniter/pkg-plist
+++ b/www/codeigniter/pkg-plist
@@ -1,4 +1,4 @@
-%%NOAPACHE%%%%CONFDIR%%/codeigniter.conf
+%%APACHE%%%%CONFDIR%%/codeigniter.conf
%%WWWDIR%%/application/cache/.htaccess
%%WWWDIR%%/application/cache/index.html
%%WWWDIR%%/application/config/index.html